Recent Posts

Pages: 1 2 3 [4] 5 6 ... 10
General Discussion / Re: Configuration board(brushed) for quad
« Last post by TheOtherCliff on January 04, 2022, 06:15:26 am »
You must make some direct settings using System->Settings to make PWM for brushed motors work.

Be aware that you control a BANK which is a set of outputs.  You do not set up the PWM rate of the outputs individually, but as a set of outputs.  Look at the top of the Output page to see what bank controls which outputs.

Here is a thread that we point to when someone wants to do this.  :)

Let me know if this gets it working for you.
General Discussion / Configuration board(brushed) for quad
« Last post by andregcoimbra on January 03, 2022, 01:52:26 pm »

I bougth a board (CC3D Brushed - use MOSFET 7700 at for brushed motor. The firmware was updated well but a can't get the configuration to work. I have tried few values to bankupdatefreq, channel max, channel neutral, channel min, but without success. The motors keep always on and don't respond to throtle. Someone alredy work well at this board?

Firmware General / Re: Revolution firmware
« Last post by TheOtherCliff on January 02, 2022, 10:50:09 pm »
As I recall, 15.09 has a different bootloader than 16.09 (and higher).  This could be confusing things.  I suggest that you use 16.09 (everything: bl, firmware, GCS) exclusively.

You have a regular, OpenPilot Revolution (or Revo Mini with external oplink connection), correct?  Not Revo Nano.

First, I suggest that you look for a way to erase settings, flight logs, etc. flash memory from ArduCopter GCS, then here is a 16.09 bl_revolution.hex that I built for you to try to flash with your Arducopter GCS.  Let me know if Arducopter can flash it.

Then you will need to do the manual method with 16.09 GCS to flash the firmware after putting this on the Revo.  Use the firmware built into the "upgrade and erase", not a download version.  You probably do this anyway.  I'm just being complete.

I recall that user KarlA has experience with ArduCopter/ArduPilot.  You could Private Message him for advice, but please talk about it here on the forum so others can benefit from the answers.  :)
Firmware General / Re: Revolution firmware
« Last post by jbjbjb82 on January 02, 2022, 06:56:08 pm »
I tried the ef and bl bin files, and the rescue and upgrade annd erase options, in no case the GCS recognizes the board.
I didn't build the FW by myself, I tried using the exxisting 15.09 and 16.09 versions.  I tried as well a different USB cable and port. With my PC I used the LP CGS properly with the same board before I flashed the Arducopter firmware. After that, it is unable to connect the board to the LP CGS, but still works well with Arducopter.

"You might try flashing the BL_revolution.hex using Arducopter GCS". I have flashed the "arducopter_with_bl.hex" file, and I am running arducopter good. Is there aa hex file for librepilot bl?

I have no more ideas, so I guess the board must have some HW failure preventing the connection to LP GCS, however it is working with Arducopter and QGS. Anyway, thank you for your support. By the moment, I'll keep running Arducopter.
Firmware General / Re: Revolution firmware
« Last post by TheOtherCliff on January 02, 2022, 03:43:25 am »
Some things to try or think about.

Do those LED flashes look like Arducopter or LibrePilot to you?  The slow fade on off blue is what a bootloader does when it does not have firmware to run.

Have you tried the ef_revolution.bin?  That should make the Revo completely bootable and able to connect to whatever version of LibrePilot GCS matches the ef_*.bin

Did you do "manual mode" erase settings?  I would do that.

Be aware that there is a big difference between bl_* and bu_* bootloaders.

Just wondering if you built these firmwares and bootloaders yourself or if you have tried something from  :)

You might try flashing the BL_revolution.hex using Arducopter GCS.

Have you tried a different USB cable?  A PC with a known working LibrePilot GCS?
Firmware General / Re: Revolution firmware
« Last post by jbjbjb82 on January 01, 2022, 07:26:42 pm »
That is the problem, the manual method should work, but it doesn't. I select Rescue or Upgrade and Erase, but the board is not detected by the GCS, with the message "Timed out while waiting for a board to be connected!".

The current status of the board when I connect the USB cable is:
- In the device driver administrator, it appears the USB device "Revolution". No COM port appears.
- The leds when connect the USB cable: solid green +
(1) solid blue, for about 5 seconds
(2) slow blink blue and orange by about 3 seconds
(3) fast blink blue and orange by about 10 seconds
(4) slow blink blue and orange until the USB cable is disconnected.

I have followed exactly the instructions to flash the bl and fw with the dfu_flash script. The board worked properly with arducopter firmware, the probvlem is that the GCS doesn't found the board. I guess if it could be something related to windows drivers and windows 11?
Firmware General / Re: Revolution firmware
« Last post by TheOtherCliff on January 01, 2022, 09:29:31 am »
One other point to make.  ef_revolution.bin is "entire flash", so bootloader and firmware.  Once you flash this, the board should boot up and LEDs flash like normal; if not, then there was something wrong with the flashing and you should figure that out first.
General Discussion / Re: ? fried onboard transmitter
« Last post by trust on January 01, 2022, 05:18:20 am »
As I recall I had issues with different units and it turned out to be the antennas - some antennas did not work at all or poorly on some units. I ended up testing a bunch of antennas and found ones that seemed to work well on all the units I tested (4 or 5).
I could also "detune" antennas by placing bits of foil wrapped around and moved up and down and improved antennas that didn't work well. But it was not a very good solution - I only recommend it for a temp fix.
Firmware General / Re: Compiling Librepilot in Windows 10 - problems and solutions
« Last post by trust on January 01, 2022, 05:09:44 am »
I have plenty of space on Google drive- also box accounts which I never use. I've uploaded each version of next that I've tested to google drive. I can view share it with anyone interested, but I can't promise to provide much support.

I too ended up having to use the older python to compile - not a terribly big deal but I attempted to fix it to work with 3 and it was too much effort.

My next version contains all the changes I made for bimode plus a manual mixer function and Telemetry+output mode
The code appears to be about 2Gb
But msys32 is something like 18Gb!
Firmware General / Re: Revolution firmware
« Last post by TheOtherCliff on December 31, 2021, 11:37:56 pm »
"Manual Method" on this page should work.  Be careful to do exactly as said.  Disconnect, then click button, then connect.  Maybe even do this with "erase settings" before "upgrade".
Pages: 1 2 3 [4] 5 6 ... 10