Recent Posts

Pages: 1 ... 4 5 [6] 7 8 ... 10
LibrePilot2Go / Re: LP2Go with OPLink Mini
« Last post by jbjbjb82 on January 26, 2022, 12:03:03 am »
Thank you, TheOtherCliff. Following your first advice works!! I have increased the baud rate to 115200 in both Revo and OpLink MIni, and now I can get the LP2Go working. Now I face a  couple of additional problems:

In the PC version of LP: In the System Health widget, the status of GPS alternates between red, meaning it work but there is no fix,  and black with a red cross, meaning that there is no GPS. I have checked the wiring is good.

In addition, the I2C box is solid red, and shows a critical warning: "I2C Port is working, but there are acknowledgement errors". The MAG box is black.

Any ideas? Previoulsly, I had the GPS connected to the Flexi Port (with no mag), and the GPS worked corretly.
LibrePilot2Go / Re: LP2Go with OPLink Mini
« Last post by TheOtherCliff on January 25, 2022, 12:33:14 pm »
I haven't used LP2Go so my advice is general.  For me to help, can you do this stuff on a PC with GCS, to get it working and later move to LP2Go?

MainPort broken:  Use a magnifying glass to look for bent pins inside the tiny connector on the Revo.  I have had this happen twice.  I have corrected it by:
- using a #11 Xacto blade (very thin and pointy) to start straightening the pin
- then using very thin needle nose pliers to clamp on the pin to finish straightening it out

"Com Speed: 57600"
This is serial link speed, but I would think that you want to increase it if anything.  You may try changing the number of mag packets though.  This is how to do that using GCS:

First enable Meta Data this way:
Click: system page -> view options (eyeball picture)
Enable: show metadata

(In System -> Data Objects)  The packet send rates and send modes for AuxMagSensor, MagSensor, and MagState can be changed from whatever they are set to now.  (In Meta Data) The important things are Mode and Flight Telemetry Update Period.  Flight Update Periodic must be enabled for the Flight Telemetry Update Period to work.  Maybe you just need to enable a UAVO being sent if they are not currently being sent?  Which one(s)?

Some Meta Data modes are not good to enable on some UAVOs.  For instance, FlightUpdateOnChange is not good for mag packets which come at 75 per second (or e.g. gyro stuff which comes at 500 per second).

(On System page) After changing a thing, highlight it by single clocking on it, then press the red up arrow at the top of the screen (Save) to make it permanent (Revo must be connected for this to work).  Remember the old metadata values that you changed; there is no single "reset to default".  To reset all metadata to defaults, you can do "Export UAV Settings", "Erase Settings", then "Import UAV Settings".
LibrePilot2Go / LP2Go with OPLink Mini
« Last post by jbjbjb82 on January 24, 2022, 11:20:37 pm »
It seems that the Main port of my Revolution board is damaged, it doesn't recognize the GPS. So I connected the GPS in the Flexi Port (GND, VCC, TX, RX), then connected the OPLink mini to my tablet with USB and everything seems to work OK with LP2Go.

However, as I have a GPS with compass, I want to try a different config: PPM+GPS in the FlexiIO port (GND, VCC, RC (5), TX (7), RX (8)), and connected the Mag to the FlexiPort with I2C protocol (GND, VCC, SCL and SDA). In this case, LP2Go doesn't work in my tablet, it display a "Warning: UAVO problem: Check OPLink connection and/or try reducing the serial link speed. FC UAVO Version: 00000000. LP2Go UAVO Version: 086dc116".

I have configured the Receiver Port (PPM+GPS), USB HID Function (USB Telemetry) and FlexiPort (I2C), and FC and OPLink are properly configured with the same parameters as receiver/coordinator: Link Type: Data, Max.Chan: 250, Min Chan: 0, Max Power: 100, Com Speed: 57600.

Any help ? thank you in advance.
Link to picture showing large X2 (bad) and small X2 (good).  So far, that seems a good way to know which is good or bad without testing.;topic=4197.0;attach=7316
Applications - Autonomous Flight / Re: Do any "OpLink Air/Ground" have the good RF chip?
« Last post by karla on January 24, 2022, 09:27:48 am »
hey, let me check what I have in my bin.
Think I have some.
will take some days...
When these first came out I bought a set of OpLink Air/Ground (but no Revo Mini, I wanted the SMA on the Ground) and found they did not work with any of my other OpLink stuff (bad clone RFM22 chip).  Big change in RSSI, looks like once a "hop cycle".  This culminated in finding the bad RFM22 chips with the large X2.

My question is whether anyone has bought these lately (or ever) and found that they use the good RFM22 chip.

I might consider buying a Revo Mini, but I would like the option to add RF later if I want, and if that RF is always broken I will just stick with regular Revos.

As an aside, I bet we could determine which hop messes up and code an option to skip that.  This would allow mixing good and bad OpLinks.  We might even have an edge case issue (e.g. 0x0000=0xFFFF or a 0x8000 as positive/negative) that could be corrected.  Are there actually 251 (40kHz) channels (0 to and including 250)?  That would mean that at least one hop is completely outside the band or that the two endpoints are on the band edges.  I tried to flag this long ago...
Firmware General / Re: Revolution firmware [SOLVED]
« Last post by jbjbjb82 on January 19, 2022, 06:09:01 pm »
The beeps I menctioned are not caming from the board, but from Windows when the board is connected/disconnected. And the Safe Boot didn't become active before. But...

Finally, I got the board connected to the CGS and working under Windows 11 !!!

What I did was: a clean install of Windows 10. Then I instaled LP CGS 16.09, and the board was successfully connected to the CGS. The BL was v6 and the FW was v15.09. I upgraded the FW to 16.09 with no problem. Just to be sure, I made a new DFU installation of BL and FW with LP DFU Flash, and then upgraded again the FW to v16.09.

After that, I made a new clean installation of W11, and installed LP, now the board is connected to the CGS and it seems to be working properly.

I guess that the problem could be with the device drivers: when I installed W11 by the first time, it was not a clean installation, but a migration from W10, and maybe that some drivers in W11 were inherited from W10 and not installed properly or get corrupted; then when I connected the board, I didn't had a COM port and a USB composite device. Now with the clean W11 installation, the board is recognized and working fine,  and those COM and USB devices appears in the DD Admin.

So, thank you for all your hints and support, it may be in the future some guys can benefit from this experience. My conclusion: I recommend a clean installation of W11 over a migration from W10.
Firmware General / Re: Revolution firmware
« Last post by TheOtherCliff on January 19, 2022, 07:01:18 am »
The board beeps every 5 seconds,

the blue led goes out for a second, and and the DD window refresh, it seems that it is trying to connect but it doesn't, the beep repeats every 5 seconds, forever...

Revolution boards don't have a beeper, so I guess you mean that everything is connected to the board and that the motors are beeping via the ESCs.  I mention this in the unlikely case: if the board has a beeper, it is not a Revo.

Blue LED goes out every 5 (to 7) seconds is a sign that the code has locked up and the watchdog has rebooted it.  In my personal experience, this is usually caused by invalid/conflicting settings, or incorrect wiring.

Just some info: I would not think it likely that Windows 11 would cause a Revo lockup (and thus the 5 second boot loop).  I have not heard of anyone trying Windows 11, so it is possible that it doesn't work, at least without some setting in Windows.  I recall that some previous versions of Windows had some backward compatibility (previous Windows versions) mode settings.

With problems like this it sometimes helps to try a different USB cable or to completely uninstall and reinstall GCS.  Also the wiki has some troubleshooting steps to remove the driver.  I know you have tried some of this already...

Try the following and report back:
- disconnect absolutely everything from the Revo leaving it unpowered and no USB connection
- do not plug in Revo USB until told to
- run GCS and go to Firmware tab
- press Rescue and follow the instructions to plug in Revo USB
- after a few seconds (say less than 10 seconds), some of the grayed out buttons become active
- press Safe Boot and see if that lets it connect

Did Safe Boot become active or did Revo continue to do blue LED 5 second boot loop?  Did Safe Mode allow you to connect normally with GCS?
Firmware General / Re: Revolution firmware
« Last post by jbjbjb82 on January 18, 2022, 11:39:29 pm »
I am using GCS 16.09. It is supposed that when I connect the board to the USB port, a new "USB composite device" must appear in the Device Driver administrator, but it doesn't appears, only appears  "Revolution" in the "USB Devices" section . The board beeps every 5 seconds, the blue led goes out for a second, and and the DD window refresh, it seems that it is trying to connect but it doesn't, the beep repeats every 5 seconds, forever...

My next step is to replace Windows 11 with a fresh windows 10 install, I'll keep you informed of the result.
General Discussion / lipo battery charger and battery charging time
« Last post by Gray on January 18, 2022, 04:09:31 am »
Friends I bought a 4s 850mah lipo battery my question is how many minutes do you need to charge this battery. If left plugged in for too long, the battery will lose its function.
It needs to be removed for use shortly before the battery is fully discharged. That is, there is a short amount of time left until it is used. Until... Is such a thing true?
I'm waiting for answers from friends who have this knowledge.
Pages: 1 ... 4 5 [6] 7 8 ... 10