FIXED: (CC3D can't save settings) Problem with settings
« on: April 17, 2020, 09:31:48 pm »
Hello everyone
Just want to know if there's any  problem with librepilot infect  is couple of times I was trying to setup OP board  getting at some point to save the configuration is taking time to save and pop up message apear and saying mixe problem I tried not luck
« Last Edit: October 05, 2020, 07:17:49 pm by TheOtherCliff »

Re: (CC3D can't save settings) Problem with settings
« Reply #1 on: April 18, 2020, 04:42:39 am »
If anyone is willing to send me a CC3D that has this problem so I can find out what causes it, I would be grateful, but first do Firmware page: "Halt", then "Erase Settings" and tell me what number Firmware page: "FlightTime" starts counting after pressing OK button to do the erase, like in this video:

I modified the title of this thread in your post.  :)  I did it so other people would know that it is this same issue.

There is a problem that for some people CC3D gets to where they cannot "save settings".  Most people see this problem as a failure to save mixer settings (I forget the exact wording) when running the setup wizard.  The problems with fixing the problem are:

1 - I cannot re-create the problem.  I don't know of any developer that can re-create the problem.  Very hard to find the cause.
2 - If anyone has found the cause or a LibrePilot solution to the problem, they have not posted back to say so.
3 - People who have the problem understandably get tired of trying this or that test and just use the CleanFlight / BetaFlight work around and get on with their lives.  :)

The one, solution that is known to work is to use CleanFlight or BetaFlight (command line stuff at very bottom of their Configurator) "FLASH_ERASE" command to erase it.  After that you can flash LibrePilot firmware back on the CC3D and it will work until you run the setup wizard / change settings many / enough times that the problem comes back and you need CF / BF again.  I recall hearing that you may need to use an old version like CleanFlight 1.10?  I think you will need to flash the CF / BF firmware onto the CC3D to do this?

Could you please answer some questions and would you be willing to try a test or two for us?
Question: On Firmware page press Halt.  What is your Bootloader / BL version (3 or 4)?
Question: On your current computer: Have you ever done any install of any OpenPilot GCS version or LibrePilot GCS version other than the one you are using?  Or are there maybe even several different versions all installed together now?
Question: Could you try to install your LibrePilot on a different computer that has never had OpenPilot or LibrePilot on it and try to do: Firmware page: "Halt" then "Erase Settings" and after pressing OK on "Erase Settings" wait for the "FlightTime" to start counting again and tell me what number "FlightTime" started counting on?  Good numbers are over 20 (it takes over 20 seconds to erase) and bad numbers are under 5 (it didn't even try to erase).
Question: Do you have Bluetooth set up on your computer?  It will show up in the Connections: list in the bottom right corner of LibrePilot GCS.

Here is a link into a thread that has a video of "Erase Settings" failing and so FlightTime starts counting, beginning with 2.  The post after that has a video of "Erase Settings" working and FlightTime starting to count beginning with 23:

Here is the last post of a long thread about this:
« Last Edit: April 18, 2020, 05:13:00 am by TheOtherCliff »

Re: (CC3D can't save settings) Problem with settings
« Reply #2 on: June 14, 2020, 06:16:43 am »
I have been having this same problem. I read the work around for this is to download and connect with cleanflight and reset the board through there but I can not get the board to connect with that program. I get a can not open serial port error every time, even after downloading the drivers.
Anyways to try and help and to answer your questions the board has bootloader 4.

As for the second question, I had my CC3D setup with a windows 10 desktop and it was fine. I sold the computer and bought a windows 10 laptop and started having this problem immediately. I have only had the newest available version of LibrePilot on both computers.

I do have Bluetooth on this laptop and it is turned on.

I don't have a second computer to connect with anymore but I tried the "erase command" and after hitting okay it gives a progress bar that sits at 0% and never advances. It never connects and never starts a "flight time".

I hope this helps, I am extremely new to everything about this so if you have more questions please let me know and I will do my best to answer them.

Re: (CC3D can't save settings) Problem with settings
« Reply #3 on: June 15, 2020, 05:26:53 am »
FYI: Many microprocessor projects like LibrePilot have a bootloader and also have firmware.  The bootloader (a small program) runs first and it runs the firmware (the main program that has "all" the features).

It's my understanding that BL4 requires good firmware to erase settings.  It actually boots the firmware with a special startup so the firmware knows that it needs to erase settings instead of run normally.  Are you saying that you don't have firmware on it, only a BL4 bootloader?  You can tell that is the case when at power on, the LED just does slow fades on and off over and over.  Not having firmware would be a reason why it doesn't erase settings.  First flash the LP firmware that comes with the GCS you now have installed, then try erasing again.  It shouldn't lock up.  FlightTime will start at twenty-something if it is working correctly (no erase issue), or it will start at some low number (rather than say at twenty-something) if you have the erase issue.

If I understand, your computer swap makes you believe that the erasing problem is with the new computer and the old one worked fine.  On this new computer, did LP install well the first time and so the install has only been done once, right?

Bluetooth is a question.  The following assumes that you now get FlightTime starting at some low number.  Please for a test, disable bluetooth and verify that it is disabled by checking that the LP GCS does not show a bluetooth option in the "Connections:" list at the bottom right of the GCS screen.  Then try erase settings again.

Re: (CC3D can't save settings) Problem with settings
« Reply #4 on: June 16, 2020, 05:31:42 am »
The board currently has 16.09 on it now and I believe that's all it has ever had. I tried erase settings with and without Bluetooth and the flight timer starts up right at 3 seconds every time.
I have uninstalled LF several times in an attempt to make it work with the CC3D and every time I have installed it installs fine.
It says the firmware on the board is from 12-12-2016 and I cant seem to get it to upgrade to a newer version than that, not sure if that matters or not.

Re: (CC3D can't save settings) Problem with settings
« Reply #5 on: June 16, 2020, 08:55:56 am »
It says the firmware on the board is from 12-12-2016
12-12-2016 sounds like the release version of 16.09

I cant seem to get it to upgrade to a newer version than that, not sure if that matters or not.
So you have tried to put "next" on it?  If you were trying a later version (one of the nexts and not just 16.09 on top of 16.09) then it's significant that you can't upgrade to a newer version of firmware because both "erase settings" and "flash firmware" require the firmware to do something a bit different than a normal startup.

If you would please, do a "File -> Export UAV Settings" and post the UAV file here.  I will install it on my CC3D.   I doubt that it will break it, but I would like to try.

Also please do a Firmware page Halt, then after a few seconds, try to read the firmware using Retrieve button which will appear, and if successful, post the file here.  I suspect that won't work, so if you are an adventurous geek ;) and you know how to put a bootloader on a CC3D using an FTDI, then you could read the firmware with the same setup and post the firmware you read here.

Finally, would you be willing to send me your CC3D if I drop ship you a replacement from eBay (bent or straight pins, with yellow case and some cables)?

Re: (CC3D can't save settings) Problem with settings
« Reply #6 on: June 17, 2020, 05:11:10 am »
I was successful on putting "next" onto the board, I believe I just had the 16.09 on the computer so I uninstalled and found the link for "next".

I have both links attached, I think both saved correctly. Never got any failure warnings anyways.

If neither of these links shine anymore light on the issue I would be happy to send you my board!

Re: (CC3D can't save settings) Problem with settings
« Reply #7 on: June 17, 2020, 06:08:12 am »
These are the next firmware and the default settings UAV for next from after you did Upgrade (and Erase) ...

Does the problem still happen?  When you do Firmware -> Halt ... then EraseSettings and OK, what does the FlightTime start at?  If it still starts at about 3 seconds, then you still have the problem and the files are still helpful.

What version of next is this?  If you don't know, the install file name will tell me or a screen shot of Help -> About LibrePilot will tell me.  Thanks!

Re: (CC3D can't save settings) Problem with settings
« Reply #8 on: June 17, 2020, 06:24:41 am »
Ya nothing seems to have changed, it starts exactly on 3 every time I have tried it.

The Next version is "next:8c101adc 20190221"

Re: (CC3D can't save settings) Problem with settings
« Reply #9 on: June 18, 2020, 11:47:35 am »
Sorry, haven't gotten to installing it on my CC3D yet.  It seems like everything I need is boxed up "somewhere" for house remodeling...   ::)

There is a thing you could try though, and I just verified that it works.  Download a Linux live DVD, burn it and boot from it (takes several minutes) and install the Linux version of LibrePilot (a few minutes).  It will run entirely from RAM and not touch your hard drive.  (sorry that mouse scrolling is backwards).

From your current PC OS Google:
Code: [Select]
linux mint 19.3 mate download
Download the 64 bit version and burn the ISO to a DVD (or USB thumb drive, requires a special program to create it).

Boot from the DVD.  Run the firefox web browser (a lower left icon) and go to then Documentation (the wiki) and search for
Code: [Select]
and the first in the found list should be next downloads.  Go there and you will find these lines so you don't need to copy them from this post.
Code: [Select]
sudo add-apt-repository ppa:librepilot/next
sudo apt-get update
sudo apt-get install librepilot

Start a "terminal" (a lower left icon) and enter the commands (copy from firefox and paste into the terminal (right click has a menu)) one at a time.  They may ask you to confirm that you want to do it.  When you are done, run LibrePilot.  Find it in Menu (lower left) Accessories.  Plug in CC3D and try the Firmware -> EraseSettings and see what FlightTime starts at.
« Last Edit: June 18, 2020, 12:03:07 pm by TheOtherCliff »

Re: (CC3D can't save settings) Problem with settings
« Reply #10 on: June 19, 2020, 06:47:13 pm »
Thanks for taking the time to explain all of that, I was able to use Linux through a USB but the end result was the same. Flight time still started at 3 and still not able to save settings :(

Re: (CC3D can't save settings) Problem with settings
« Reply #11 on: June 27, 2020, 01:53:44 am »
Well I flashed the firmware and settings you posted and it works fine here.

Some (all?) possible categories for causes:
1- PC hardware (couid be something like new USB3 / BlueTooth incompatibility or something broken like low USB voltage)
2- PC software (like a certain version of Windows update or such or an LP bug)
3- FC hardware (something broken, cheap defective component, etc.)
4- FC software (bootloader or firmware bug or corruption or non-LP version of something)
5- FC option bytes (fuses) or settings memory or other configurable thing has a bad value stored in it but can be changed

We've shown that it probably isn't #2 PC software by you booting Linux and running Linux version of LP and problem still happens.  We've shown that it probably isn't #4 FC software by me running your firmware and it is OK.  Could still be a bootloader issue, but others say they updated bootloader and it didn't fix it.

If I had a broken CC3D in my hands, I could #5 examine fuses, extract the settings memory (there are some otherwise inaccessible settings that can mark it as full).  If it is still broken, with all of these known to be correct then it looks like bad CC3D hardware, but it might be possible to develop a work-around.  If I can't get it to break at all, then it points more to PC hardware.  I recall a user (maybe you) saying that the problem started when he traded in his old PC for a new one.  PM me if you could send me this broken CC3D.
« Last Edit: July 25, 2020, 02:25:54 am by TheOtherCliff »

Re: (CC3D can't save settings) Problem with settings
« Reply #12 on: July 01, 2020, 08:52:05 pm »
CC3D is good for basic flight, but doesn't have enough memory for advanced features like GPS flight modes.

Although GPS can, if desired, change it from requiring flying skills to not, it is good to first learn to fly without GPS.

Having a GPS and GPS flight modes has a learning curve for build and setup, but it's sweet to be able to take your hands off the sticks and have it stay where it is, even in the wind.  Waypoint flights are really fun in a geeky way.  I like to program a flight around the subdivision sidewalks a couple hundred feet up (high, to not seem a threat to anyone watching) at a walking pace and walk underneath it with the transmitter.  My quads generally are designed to be reasonably quiet too, I wouldn't do it with a noisy quad.  At the club field, I can tell it to fly the perimeter and have it take a video of the flight, quad and thus video pointing in whatever directions I want.

Re: (CC3D can't save settings) Problem with settings
« Reply #13 on: July 09, 2020, 08:41:46 am »
Just to be certain of the facts:

You have seen that it is broken with both 16.09 and next:r782 (next:8c101adc 20190221).  (So I can use either of these firmwares and it should stay broken.)

You did attempt Erase Settings using that version of "Linux Mint" DVD that I discussed, and it still failed (comes back after about 3 seconds instead of about 23 or so).

Did you say this was a fairly new PC?  What processor is in it?

Erase Settings can be done several different ways.  It shouldn't make any difference, but I would like to do exactly what you did.  How did you do Erase Settings specifically when booted from the Mint DVD?

Upgrading firmware can be done several different ways.  When you upgraded firmware how did you do it?


I'll start by saving off the current firmware two different ways (GCS and SBL).
Then flash some debug firmware that checks the settings storage for data errors (not hardware errors).
Then flash some debug firmware that dumps out all of settings memory for later analysis if desired.

Then flash the r782 firmware back on it and attempt to Erase Settings with the Linux Mint DVD.

If this succeeds, then it seems fairly well proven that the problem is with your PC or USB cable since that is all that is different from when you used the Linux Mint DVD.  Even if it is your PC, it could be some new hardware that we don't support well yet.  Fast CPU and USB3 immediately come to mind.

If it fails, then more debug code should show where it is failing.

Re: (CC3D can't save settings) Problem with settings
« Reply #14 on: July 17, 2020, 08:03:22 am »
I think I recall you saying you had ordered another CC3D.  I would be very interested to know if Erase Settings takes 23 second or 3 seconds on your new CC3D.

I received the "bad CC3D" (we don't yet know exactly where the problem is).

I read the bootloader and firmware off of it with dfu-util, SBL, and a USB-serial adapter.  I wrote that bl/fw to my CC3D and it erases fine. Unplug my CC3D, Firmware page, Rescue, plug in CC3D, Erase Settings, OK, and FlightTime starts counting again at 23 (23 is good and 3 is bad).

At this point I need to do some tests that will modify the "bad CC3D" firmware or settings which means there is a chance of the problem magically disappearing with the modifications.

For the first thing I do, I can:
1 - Boot the Linux DVD that I had you try and see if Erase Settings works there or not.  If it works for me, it pretty much says that there is something about your PC or USB cable.  It could be bad hardware, or it could be something in LP code that needs to be updated to work with some newer hardware.
2 - Flash some debug firmware that lets me examine the contents of settings memory.  Settings memory is wiped by a successful Erase Settings.

I have decided to #1 erase with DVD.  If erase fails, I can still do #2 debug code.  If erase succeeds, then the cause is related to your PC and USB cable and it seems I can't do anything more with the "bad CC3D".

If first thing is #2 flashing debug firmware and I don't find a problem (reading the source code I don't see an obvious cause), and I then put old bl/fw back and erase with DVD ... what if it works then?  Did my flashing magically fix the issue?  There is no certainty.