Blauner

  • *
  • 11
Problem with USB - Revolution
« on: November 15, 2019, 08:53:41 pm »
Hello everyone,
I have a problem with my 2019 MacBook Pro - Catalina 10.15.1, when I connect the flight controller -Revolution-, the LibrePilot program does not recognize the device.

Note:
these devices are displayed:
-tty.usbmodem14401
-cu.usbmodem14401

Has anyone experienced this problem?

MacBook Pro 2019
Mac OSX: Catalina 10.15.1
USB: USB-C
LibrePilot: 16.09

Thanks.
« Last Edit: November 15, 2019, 09:21:14 pm by Blauner »

Re: Problem with USB - Revolution
« Reply #1 on: January 14, 2020, 02:36:20 pm »
Hello everyone,
I have a problem with my 2019 MacBook Pro - Catalina 10.15.1, when I connect the flight controller -Revolution-, the LibrePilot program does not recognize the device.

Note:
these devices are displayed:
-tty.usbmodem14401
-cu.usbmodem14401

Has anyone experienced this pcloud​
LibrePilot: 16.09 problem?

MacBook Pro 2019
Mac OSX: Catalina 10.15.1
USB: USB-C chat avenue

Thanks.

If you bought an RTF quad that has OP on it, then it is probably a good idea to download the matching version of OP, and install and run it.  That gets you in the air and flying so you can at least test it to make sure it works before diving into learning how to set it up from scratch like you would if you started over with LP.
« Last Edit: January 16, 2020, 07:48:18 am by Kasey00 »

Re: Problem with USB - Revolution
« Reply #2 on: January 14, 2020, 05:31:52 pm »
Excellent advice!

Sorry, looks like this question slipped through the cracks till now.

karla

  • *****
  • 553
Re: Problem with USB - Revolution
« Reply #3 on: January 15, 2020, 02:21:27 am »
I don't have a solution for this, rather I can add on to the problem.
I also have one 2019 MacBook Pro - Catalina 10.15.1 (and now .2) and also a win10 pc machine.

For one revolution and one revo nano board, the Mac (with r782) do not recognize them (not even doing a rescue).
These two boards were setup with the pc with r782 and works totally normal when connected to the pc.

Then I have 2 sparky2, one revolution and another revo nano that works totally fine with the mac but can not be recognized by the pc (r782).

I was thinking this was due to some next inconsistency so I have tried to start installing all boards from LP 16.09.
But the issue is already at 16.09. some boards will not be recognized by the pc and some will not be recognized by the mac. All boards I started with a dfumethod to flash the respective bootloader first (successfully) then connect for an Upgrade and erase. some boards cant be recognized. The bootloader flashing was all performed on the pc using.

I think this is so odd so I have not even bothered to ask about it. However, this might have same cause as @blauner problem...

Re: Problem with USB - Revolution
« Reply #4 on: January 15, 2020, 06:40:56 am »
That is very odd.

Does the FC power LED come on when you plug in USB?  For one particular FC that works here but not there, what do the LED's look like when plugged in here or there?

For an FC that works well on the PC, but not on the Mac, have you tried taking the FC and that PC USB cable both to the Mac and trying all the Mac USB ports?

Have you tried a powered USB hub if you have one handy?

Certainly you have tried powering the Mac / PC off and back on...

karla

  • *****
  • 553
Re: Problem with USB - Revolution
« Reply #5 on: January 16, 2020, 03:00:46 am »
I don't have the mac here but when I get back I can make a little video demonstration.