Revo Nano issues?
« on: July 19, 2015, 06:46:13 pm »
I was able to get a Nano from the first batch and have spent close to 30 hours trying to figure out it's issues.

It connects to GCS fine on my older laptop but has been super touchy configuring and calibrating. Would lock up the GCS when the reboot command is sent to the Nano and will not show GPS as connected even tho the GPS is powered on correctly and LED indicates Sat lock.

I did manage to get basic setting installed and bench test seemed fine but test flight did not go well. Hovered for about 2 minutes but was drifting badly and when I gave it about 65% the front motors cut out and it flipped upside down. I installed the Nano on a perfectly good flying quad using a CC3D so all parts were good to go before adding the Nano.

I ordered a second Nano and it should be here tomorrow so I will be able to see if it's a defective unit but in case it acts the same as the first I was hoping to find some answers if possible. 

liftbag

  • *****
  • 215
    • LibrePilot
Re: Revo Nano issues?
« Reply #1 on: July 19, 2015, 07:02:43 pm »
Hi, can you post here the .uav file?

I'll try to look at it and, if not me, definitely a developer will tell you if there is some wrong settings or if there is a possibility that the board is defective.
« Last Edit: July 19, 2015, 07:33:07 pm by liftbag »

Re: Revo Nano issues?
« Reply #2 on: July 19, 2015, 10:29:12 pm »
Thanks for the reply. Sorry I am not sure where to look for the UAV file?

I did save a UAV file but can not seem to figure out how to upload it?

liftbag

  • *****
  • 215
    • LibrePilot
Re: Revo Nano issues?
« Reply #3 on: July 19, 2015, 10:37:58 pm »
Thanks for the reply. Sorry I am not sure where to look for the UAV file?

I did save a UAV file but can not seem to figure out how to upload it?
You can zip the file and attach to your reply. Clic on "+ Attachment and other options" and then browse to your zip file.

Re: Revo Nano issues?
« Reply #4 on: July 19, 2015, 11:07:49 pm »
Thanks here you go.

ggrif

  • *
  • 171
Re: Revo Nano issues?
« Reply #5 on: July 19, 2015, 11:29:16 pm »
Happy to see you are finally getting some help! 😜

liftbag

  • *****
  • 215
    • LibrePilot
Re: Revo Nano issues?
« Reply #6 on: July 19, 2015, 11:30:15 pm »
Thanks here you go.

I had a quick look and found no particular problems.
I submitted the file to the attention of the developers for further confirmation.

filnet

  • *****
  • 71
Re: Revo Nano issues?
« Reply #7 on: July 19, 2015, 11:35:52 pm »
Which OS is GCS running on?

Re: Revo Nano issues?
« Reply #8 on: July 19, 2015, 11:41:28 pm »
I have it on Windows Vista 32bit, Windows 7 64bit and Windows 8.1 64bit. Both 64bit OS's GCS crashes when the reboot command is sent to the FC. It runs pretty well on the old laptop with 32bit Vista but that thing is slow so GCS is a bit sluggish.

I can not even begin to figure out what is conflicting with the GCS on my PC? Could it be hardware? I have a I5 3570k, 12gbs or ram, AMD 280x 120gb SSD HD and and 1TB SATA HD.
« Last Edit: July 19, 2015, 11:44:28 pm by RC Madman »

filnet

  • *****
  • 71
Re: Revo Nano issues?
« Reply #9 on: July 19, 2015, 11:48:04 pm »
Can you try to run GCS with "-log gcs.log" as additional command line arguments and post the resulting log file after a crash.
Could help...

liftbag

  • *****
  • 215
    • LibrePilot
Re: Revo Nano issues?
« Reply #10 on: July 20, 2015, 12:25:59 am »
Thanks here you go.

Well, seems your board settings are ok.

Are you sure that your board is firmly locked to the frame or in his box?

On the gcs side, try to post the log file as suggested by filnet.

Open the command prompt and type these two lines followed by the enter key.

Code: [Select]
cd C:\Program Files (x86)\OpenPilot\bin
Code: [Select]
openpilotgcs.exe -log gcs.log
After the crash you can find the file gcs.log in the path C:\Program Files (x86)\OpenPilot\bin

Re: Revo Nano issues?
« Reply #11 on: July 20, 2015, 12:56:35 am »
Thanks guys, I will update with the log asap. The FC seems to be firmly attached to the frame. 3M double sided tape.

liftbag

  • *****
  • 215
    • LibrePilot
Re: Revo Nano issues?
« Reply #12 on: July 20, 2015, 01:05:31 am »
The FC seems to be firmly attached to the frame. 3M double sided tape.
Ok, take a look at the board inside its box too  ;)

I think if tomorrow the other nano will come, we can narrow the field of suppositions.

Re: Revo Nano issues?
« Reply #13 on: July 20, 2015, 02:46:51 am »
The first crash log is right at the beginning of Vehicle setup when you have the option to "Erase and Update". The second log is skipping the Update and going to the end where you save. 

Re: Revo Nano issues?
« Reply #14 on: July 20, 2015, 06:09:06 am »
How does this log look? A couple of the caution light kept going on and off while just sitting.
« Last Edit: July 20, 2015, 06:17:51 am by RC Madman »