I need some help.  I have a openpilot revolution board that I recently upgraded to firmware 16.09 +r782.  In trying to set up a new quadcopter build, I am encountering a problem.  I used the vehicle setup wizard and completed all of the calibrations.  In addition to the revolution board, I am running a u-blox based gps with magnetometer.  Now, I am getting a warning message in the "Flight Data/System Health" screen.  The message says "waiting for the board to be steady before gyro init".  The board/copter is perfectly level and not moving.  I've gone through the vehicle setup wizard and calibration procedure two times and am still getting the warning message. 

I also unchecked the "Wait until board is steady" option under Gyro Initialization on the attitude settings page to see if that would make a difference but it did not, I still get the warning message.

Any ideas what is wrong?


Re: Help, Warning: Waiting for board to be steady before gyro init
« Reply #1 on: July 09, 2019, 12:08:20 am »
I suggest that you post your settings UAV file (File->ExportUavSettings) for us to look at.  :)

My guess is that you are running a new AttiEstAlgo (Attitude->Settings->AttiEstAlgo).  I would test with the old ones "Basic (Complementary)" or "GPS Navigation (INS13)" to see if the issue still happens since disabling "Wait until the board is steady" (and pressing Save, and rebooting the board) should fix this issue when it happens due to gyro hardware farther out of tolerance than expected.

You should also be aware that the board must be perfectly motionless for any AttiEstAlgo that uses Complementary/CF to initialize correctly.  It can see the motion if you are holding the board or aircraft in your hand or try to do it while riding a boat, etc.

I just checked my next build and it is r796, so you aren't running the latest next although 782 is the "released next".  ;)
« Last Edit: July 09, 2019, 12:57:12 am by TheOtherCliff »

Re: Help, Warning: Waiting for board to be steady before gyro init
« Reply #2 on: July 09, 2019, 06:52:34 pm »
Thank-you for the help.  Next time I will be sure to post the UAV settings.  I ended up unstalling the version of the firmware I had and reinstalled the 16.09 release and everything is now working, I may have had a setting wrong or tried to use two different versions of firmware?  It was hard to isolate the exact problem because I had made several changes at the same time including rebuilding my quad, flashing and configuring new firmware, trying new locations for the flight controller etc. so it seemed like going back to a previous version of the firmware that I knew had worked in the past was the best way to help start to isolate the problem.  It looks now like my gyros are working fine so the problem was either in my configuration/firmware or electric noise as this was the first time I had tried to mount the flight controller in the center of the frame.

I really appreciate everything you are doing on this project, I am sure it is a lot of work.