Not heading movement direction when return home activated
« on: August 26, 2017, 12:04:23 am »
Hi there. Only a question on return home.
When I activate return home the quad maintains its orientation. There is a way to return home heading movement direction?
« Last Edit: August 26, 2017, 12:11:26 am by ppnvedado »

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Not heading movement direction when return home activated
« Reply #1 on: August 26, 2017, 12:28:01 am »
That's the normal/default behavior of YawControl as 'manual'

Look others options for VtolPathFollowerSettings > YawControl in UAVOBrowser
Be warned, orientation changes can be violent.


Re: Not heading movement direction when return home activated
« Reply #2 on: August 26, 2017, 12:36:10 am »
violent???????!!!!!!!
let's check that!!!!!! 8)

Re: Not heading movement direction when return home activated
« Reply #3 on: August 28, 2017, 03:35:03 pm »
hi again.
Change made and the quad can handle the direction change, it's really violent. Can this be modify by bank settings?
another thing. have lots of problem calibrating the internal magnetometer. I will use only external and that one seems to work fine. Does INS13 uses internal magnetometer data in calculation even if you configure AuxOnly?
« Last Edit: August 28, 2017, 04:09:47 pm by ppnvedado »

Re: Not heading movement direction when return home activated
« Reply #4 on: August 28, 2017, 10:31:44 pm »
You can reduce yaw rate or even reduce yaw PID 'P'

AuxOnly is aux only.  :)

Re: Not heading movement direction when return home activated
« Reply #5 on: August 28, 2017, 10:56:17 pm »
thanks, I will do that. I assumed it was only external, but have to know to descart things when something goes wrong, and I have always lot of that  ;)

Re: Not heading movement direction when return home activated
« Reply #6 on: September 02, 2017, 09:35:26 pm »
too much ??? in programing, so back to 0.
Reprogram board and do all. All seems to work fine, altitude vario and hold position with some variations in altitude. Board covered and foam to reduce light effect.
how important is thermal calibration? never done it.

Re: Not heading movement direction when return home activated
« Reply #7 on: September 02, 2017, 10:19:40 pm »
Thermal calibration mainly helps vertical drift.  In my experience, without it, AV, AH, and GPS modes can drift vertically about a meter per minute.

Re: Not heading movement direction when return home activated
« Reply #8 on: September 02, 2017, 10:23:48 pm »
then, it will be done!!!!! 8)

Re: Not heading movement direction when return home activated
« Reply #9 on: September 04, 2017, 10:27:21 pm »
Thermal calibration done!!!
I have oscillations in the first flight minutes, not only up and down, horizontal too. Then steady, almost no movement at all, impressive.
I'll do some testing covering the FC and post result. Any other suggestion?

Another thing, I want to use oplink in data+control. does anyone know where I can find an empty JR transmiter case to put in it BEC+oplink+bluetooth transmitter?
Thanks
« Last Edit: September 04, 2017, 10:47:01 pm by ppnvedado »

Re: Not heading movement direction when return home activated
« Reply #10 on: September 04, 2017, 11:11:46 pm »
Maybe start another thread about that subject so users can see a problem similar to theirs by the title.

Start with the flight mode you are using and whether the oscillation is faster than 1 per second or slower.  A video would help a lot.

Re: Not heading movement direction when return home activated
« Reply #11 on: September 05, 2017, 08:39:48 am »
ok, you are right, two new subjects.

Re: Not heading movement direction when return home activated
« Reply #12 on: November 10, 2017, 08:17:36 pm »
That's the normal/default behavior of YawControl as 'manual'

Look others options for VtolPathFollowerSettings > YawControl in UAVOBrowser
Be warned, orientation changes can be violent.



violent orientation changes solved in bank settings by lowering max degrees/sec in Yaw.