Cannot save settings from librepilot to CC3D.
« on: March 21, 2020, 05:56:36 am »

I have encountered an issue where I cannot save configuration settings to a CC3D.
It was working a few days ago with what is, as far as I can tell, exactly the same setup.

I've found a few other threads on this topic, but none of them had solution.
It seems to me as though the CC3D cannot access it's own config storage media.

Here are the symptoms:

When saving settings at the end of the vehicle setup wizard, it stops on 'preparing mixer settings', and the text turns red.
When saving other configuration settings, the saving process does not complete.
I can view telemetry data, incl. receiver input.
I can update firmware without issue.

I have tried on 2 different PC's: win Vista & win 10.

Librepilot is at the newest version.
I have tried multiple cables, no change.
I have tried updating the boot-loader using the rescue method, this caused a whole bunch of other problems, which I fixed, end result was no change.


Edit by Cliff to say that he posted that he found a solution here:
The solution known to work is to use the FLASH_ERASE command line command in BetaFlight or CleanFlight.  This might be an issue with having multiple versions of OpenPilot and LibrePilot installed at the same time, try uninstalling EVERYTHING OP and LP and installing the one version that you want to use.
« Last Edit: March 25, 2020, 05:51:37 am by TheOtherCliff »

Re: Cannot save settings from librepilot to CC3D.
« Reply #1 on: June 11, 2020, 08:21:14 pm »
I'm glad that I got involved in this time and read good things.