Installing on Ubuntu 19.04 and newer
« on: February 13, 2020, 04:56:52 pm »
Hi,

Is there a way to install LibrePilot on Ubuntu 19.04 or newer?
So far going through PPA is no longer an option cause of lack of repository maintenance, going through dpkg issues number of "non downloadable" dependencies:
The following packages have unmet dependencies:
Code: [Select]
librepilot : Depends: libopenscenegraph99 but it is not installable
              Depends: libopenthreads14 but it is not installable
              Depends: qt56base but it is not installable
              Depends: qt56declarative but it is not installable
              Depends: qt56multimedia but it is not installable
              Depends: qt56serialport but it is not installable
              Depends: qt56svg but it is not installable

Is there any other way to install without building from source?

Regards,

P.

Re: Installing on Ubuntu 19.04 and newer
« Reply #1 on: February 14, 2020, 04:48:13 am »
This is a general issue with apps on Linux.  Different "versions of Linux" and different versions of support libraries (like QT).  For LibrePilot, the thing that bites me the most is QT, OSG and OSGEarth versions.

For some apps, I have at times used videbcontrol to edit the dependency list in the *.deb file and then made some old name links to the new libraries if needed.  A more standard way to TRY to fix this would be to download the correct library versions (perhaps from an old Ubuntu version) and see if you can get them to install using dpkg -i.

Another (developer) solution might be to package LP up (including all dependencies) using one of the containers available:
https://askubuntu.com/questions/866511/what-are-the-differences-between-snaps-appimage-flatpak-and-others?rq=1

Edit:
I also recall installing qt56 from a downloaded qt installer (qt-opensource-linux-x64-5.6.1.run, 5.6.3 is available and you should probably use that instead) to the default system location ... and each time before building, running (sourcing) a script that set all the environment variables to point to the download / installed version rather than the system version.  I don't remember why I did this rather than install with 'make qt_sdk_install' / 'make build_sdk_install'.  It may have been when we were having some issues with the QT download location and QT install options and the normal make script wasn't working.
« Last Edit: February 15, 2020, 06:17:36 pm by TheOtherCliff »