Hi guys,
I have a problem with my quad that is an older RTF Model (Storm Racing Drone 3s) using the CC3D controller.
I want to fly in rate mode, so I created a settings bank for it, but it does not work. It is the same as flying in attitude mode.
The transmitter works fine and it changes the modes, so that is not the problem.

It is possible to do flips, but the quad stabilizes itself just like in attitude mode. When I roll forward and let go of the stick, it rights itself instantly.
The only effect is, that it is possible to do flips and the responsiveness changes, but it is not in "real" rate mode.
Is there some setting that I am overlooking?

This guy on a german forum had the same problem, but never found a solution:
http://www.kopterforum.de/topic/51361-librepilot-regelt-im-rate-mode/

Does anyone have an idea what I might be doing wrong?
Thank you !!

f5soh

  • *****
  • 4527
    • LibrePilot
Hi,

Looks normal, pos1 and pos2 uses Attitude and pos3 uses Rattitude
Attitude refers to a self-level mode and Rattitude to a Rate/Attitude mix.

You should set one flight mode position with "Stabilized3" with Rate in roll, pitch and Yaw axis or define a new stabilized mode where you set something like Roll:Acro+, Pitch:Acro+, Yaw:Rate or AxisLock. You should also consider Acro+

More details in this page : Input configuration





Hey, thanks for the quick answer.
I understand from your post that I have to set a mode with Rate settings.
But I have done this already, as you can see in the picture of the modes window.
Shouldnt it work then with this setup?

f5soh

  • *****
  • 4527
    • LibrePilot
Quote
I understand from your post that I have to set a mode with Rate settings.
But I have done this already, as you can see in the picture of the modes window.
Yes, Stabilized3 is the one configured with Rate mode by default but the FlightMode positions uses only Stabilized1(Attitude) and Stabilized2 (Rattitude)

No Rate mode configured or selectable using flight mode switch : Try setting "Stabilized3" in one flightmode position ?

Wow, it worked. All I had to was change to the right stabilized mode...
I am so stupid....!!!
Thank you for the tipp!!