Arming with Switch does not work
« on: April 14, 2019, 04:48:12 pm »
I have an issue, that might be quite frequent, but I haven't found any helpful answer yet.
Currently my Copter had a setting to Arm the Copter with "Yaw Left" this worked quite well.
Now I tried to configure a Switch on my RC to Accessory0 and use it for arming.

Channel 6 corresponds to my switch. I configured it, but it does not work.
The Quad it on reacting at all to the switch.

A added a PDF with several screenshots of my quad configuration, that proves that the Switch is correctly recognized in the Software.
I also attached the full Configuration file of the Quad, in case you want to check Firmware or Software Versions.

Has anybody a good idea, what setting I missed and why it is not working?
I already checked this thread, but my Neutral is in the middle. ( )


  • *****
  • 4572
    • LibrePilot
Re: Arming with Switch does not work
« Reply #1 on: April 14, 2019, 06:04:00 pm »

While arming, be sure the Throttle stick is to min position. This means bellow the Throttle neutral value.

Re: Arming with Switch does not work
« Reply #2 on: April 14, 2019, 09:21:03 pm »
Thanks :)
It worked. I increased the Trotle Neutral value by 5 points.
Looks like "Yaw left" also made me reduced the throttle as I had to touch the stick.

It is always the little things... ::)