Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #15 on: March 01, 2019, 01:12:37 pm »
I returned to libre now. i will test it. Thanks.

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #16 on: March 01, 2019, 01:31:55 pm »
Another test:
On the vehicle tab I made a simple Car configuration.One motor and one servo. I saved. nuturaly red x. I dont care it. I continue with output conf. I saw motor and servo slider came to the output tab. I made a min max setup.And I saved .
I have red x again on the save button. I dont care it. I connected esc and servo to the configured channels.On the output tab. I clicked live test. I tested the sliders for the motor and servo. Motor and servo running without problem. I can say this an saving to flash isue. Who created this İsue . I dont know.May be Fw maybe Murphy. I hope Murphy do it. I will change cpu next week. Because i changed flash before. I checked flash leg connections all is ok.

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #17 on: March 01, 2019, 05:34:27 pm »
Hi I am writing this for the f5soh user. You give an procedure to me for erease the flash under BF. I have a `st flash loader` utl. Before I load the fw by this utl I erease the flash more 10 times. I think This is same with the BF flash erease. İf you are thinking not same. I can do it again with BF.

f5soh

  • *****
  • 4560
    • LibrePilot
Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #18 on: March 01, 2019, 06:01:28 pm »
Erasing flash using the ST-Util do nothing to the 2516 flash device i think, only CPU related...
BF flash erase will format the 2516 device, if you look the post i linked this solved the issue.


Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #19 on: March 01, 2019, 09:35:05 pm »
Ok. I will do it.

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #20 on: March 02, 2019, 06:11:33 pm »
I do your suggestion. But result is same. I attached the pics. This libre 16.09 dont write the flash.
 

Re: Cannot save anything in my CC3D
« Reply #21 on: March 02, 2019, 07:57:50 pm »
It is interesting that flash_info says that size is zero.

BF says your fw not support to logging.
In your flash_erase test did you use the exact Cleanflight GCS and firmware version (V1.10) from successful user pointed at by @f5soh?

(Since you already replaced the flash chip) It seems that one of these is probably true:
- solder blob
- connection not soldered
- bad / broken trace
- incorrect board traces design
- bad CPU chip
- wrong or missing components (such as flash CS pullup or voltage regulator)
- your version of BF does not access the external flash chip
- bad voltage regulator

After using Cleanflight V1.10 I would probably use CC3D schematic and a volt ohm meter to check the CPU to flash connections (or I think you maybe already did) and a few other things like flash CS pullup value (R17 should be 10K) and VCC.  CC3D schematic can be found at "hardware/Production/CopterControl 3D/CopterControl 3D Schematic.pdf"

(not saying the following is the problem, just information for you)  Some Sparky2 FC boards have a problem with baro chip.  It turns out that the reason is that clone board maker used different voltage regulator.  That would have been OK, but the different voltage regulator needed a different capacitor for it's precision voltage reference source and made bad power with the incorrect capacitor.

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #22 on: March 03, 2019, 09:09:49 am »
Ok . This is hw error I think. I will check some of these . If I have not find anything else.I will buy a new board. I will use it with 15.09. I am not clear about 16.09 fw. Thank you for your information.

Re: Cannot save anything in my CC3D
« Reply #23 on: March 03, 2019, 05:29:42 pm »
OK.  Thank you for your testing.  I am guessing that you didn't use Cleanflight V1.10 flash_erase, so someone still needs to test that.
« Last Edit: May 21, 2019, 05:31:19 pm by TheOtherCliff »

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #24 on: March 04, 2019, 01:12:02 pm »
Flash_erase command says erasing and wait aprox 2 sec.After it says done. I think it is erasing the flash. But ı will try to test with 1.1 .

Re: Cannot save anything in my CC3D
« Reply #25 on: March 04, 2019, 05:49:02 pm »
It may or may not make a difference, but please make sure to use Cleanflight V1.10 like the guy who had success.  :)

Not Betaflight V1.1

And indeed V1.10 usually comes after v1.9 and I am guessing that is what that guy meant.
« Last Edit: March 04, 2019, 05:53:43 pm by TheOtherCliff »

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #26 on: March 26, 2019, 03:03:39 am »
Even my CC3d could not save. I performed the albertferraz procedure:

1 - Download Firmware Cleanflight V 1.10.
2 - Install the drivers indicated for your card
3 - Connect with Cleanflight
4 - At the command line of the CF type "flash_erase"
5 - Return to LibrePilot and do the normal process of installing the firmware
 
To be precise, I used the Cleanflight configurator version 1.10 and showed the Gyro and Accel icons in red. The cc3d has now saved the configuration. Thank you

guindi

  • *
  • 11
Re: No se puede guardar nada en mi CC3D
« Reply #27 on: March 27, 2019, 08:11:43 pm »
Hello everybody !

I've got a puzzle problem. I CANNOT SAVE ANYTHING IN MY CC3D. (i have read lot of topics but i didn't find a solution)

What's happening ? :

*I configure my CC3D until the final test (without propellers). I activated the always armed mode for this test. But my level is not good, so i decided to restart all configuration.

I click on VEHICLE SETUP WIZARD, and at the end i can't save my settings.

I check the ESC are disarmed. I reinstalled librepilot on my windows 10. I rescue my CC3D. Erase all, and upgrade it.

So please, help me :'(


Tengo exactamente el mismo problema Se queda en guardando configuración y se bloquea. Actualmente tengo tres placas cc3d y a todas les pasa lo mismo

Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #28 on: March 27, 2019, 10:43:34 pm »
Please try the albertferraz procedure just above your first post.  And please please let us know if it fixes your problem or not.

Also very important!  What other firmware did you run, and what settings, that broke it this way (so developers can make the problem happen and program the fix).

-----------------------------------------

Vía el traductor de Google

Por favor, intente el procedimiento de albertferraz justo por encima de su primera publicación. Y por favor, háganos saber si soluciona su problema o no.

¡También muy importante! ¿Qué otro firmware ejecutó y qué configuración se rompió de esta manera (para que los desarrolladores puedan resolver el problema y programar la solución)?

guindi

  • *
  • 11
Re: CANNOT SAVE ANYTHING IN MY CC3D
« Reply #29 on: March 28, 2019, 06:58:42 am »
Please try the albertferraz procedure just above your first post.  And please please let us know if it fixes your problem or not.

Also very important!  What other firmware did you run, and what settings, that broke it this way (so developers can make the problem happen and program the fix).

-----------------------------------------


Vía el traductor de Google

Por favor, intente el procedimiento de albertferraz justo por encima de su primera publicación. Y por favor, háganos saber si soluciona su problema o no.

¡También muy importante! ¿Qué otro firmware ejecutó y qué configuración se rompió de esta manera (para que los desarrolladores puedan resolver el problema y programar la solución)?


Disculpe pero no se quien es alberferraz. He hecho todas las pruebas que se exponen en este foro y sigue igual. Hay que comentar, que todas las placas funcionaron en una primera prueba. Al efectuar la segunda ocurrio el problema y ya no se resolvió. El soft de arranque es el cc3d BL 4 y el firmware el 16.09 de la pagina oficial de librepilot. He probado con la version 15.09 y ninguna de las placas la acepta