Unable to save settings, Revolution
« on: October 22, 2018, 08:56:23 pm »
I have a new Revolution from HK that I am unable to save settings to. 
I always get a red X on save on any setting. 
Sometimes it looks like it might save, I can quite GCS, go back in, and the change will still be there, but if I reboot the board the change is gone.
I loaded BetaFlight on it and it works fine.
Currently trying to use LibrePilot Next.  Flashes fine with new firmware, just cant make settings changes.
Yes, Armed is set to disable always.

Snippet from shell:
Send save object request to board  "HwSettings"
Saving of "HwSettings" failed after 3 tries.

Suggestions?

startrek66

  • ***
  • 156
  • F330+Revo
Re: Unable to save settings, Revolution
« Reply #1 on: October 22, 2018, 09:37:28 pm »
when you save see the green tick?
do you use the usb or oplink connection? Is the USB cable in good condition? see the oplink telemetry bar?

Inviato dal mio SM-G800F utilizzando Tapatalk


Re: Unable to save settings, Revolution
« Reply #2 on: October 23, 2018, 12:39:51 am »
Especially with a new board, your flashing of firmware needs to include erasing (Upgrade & Erase, or Erase Settings).

You cannot save settings if it is armed (safety).  Always Armed is a pain that way.  Are you using Always Armed?

Re: Unable to save settings, Revolution
« Reply #3 on: October 23, 2018, 04:00:22 pm »
Always getting the red X.

Using USB, two different cables on two different computers.
Also tried Ubuntu and Windows.  I will test one more Window box in a while.

I did an upgrade and erase (a couple of times).
Arming shows as always disabled which I believe is the default.

Telemetry is coming across fine over USB.

Re: Unable to save settings, Revolution
« Reply #4 on: October 23, 2018, 09:46:31 pm »
Can it save one simple setting right after "Upgrade and Erase"?  Is it only after other changes (running setup) that it won't save?

It might be power.  After plugging in USB, you could plug in your flight battery (through ESC or BEC) and then try saving settings.

Do you have another Revo or even a CC3D?  Or a friend that has a Revo?  It would help to know if (save settings first to not wipe them out) Upgrade and Erase on one of those works or doesn't.

What LP version are you running?  Did you download it here?  Did you build it from source yourself?  Something might be confused there, like you somehow have a mixture of versions.  You might try uninstalling all your versions and installing the one you want, and starting again with Upgrade and Erase and one simple setting.

Re: Unable to save settings, Revolution
« Reply #5 on: October 25, 2018, 10:03:23 pm »
Tried just one change as suggested immediately after flash/erase.  Red x on save.
Also hooked up a BEC (I was betting this would fix it) but it did not help.

Took a CC3D and tried the same setup.  Works fine.  I can save settings, etc.  Reflashed it to same level of software to make sure.
Wish I had another Revo but not willing to invest in another until I can determine if I have bad hardware or something else going on.

Running LIbrePilot Next r725 as 16.09 did not play nice with my my Ubuntu release.

I will see about getting 16.09 running on a Windows box tonight.

Thanks for the suggestions.  More welcome.

Re: Unable to save settings, Revolution
« Reply #6 on: October 26, 2018, 05:40:28 am »
You could try flashing the bootloader again.  Recall that you must flash firmware after the bootloader and you must use Rescue style process (press button THEN plug in USB) to flash the firmware in this case.

Well, you obviously used a different USB cable for CC3D vs. Revo.  There is that; try another (short, USB2) USB cable (you have already tried 2).  I have some old USB cables that only work well with USB 1.x.  It would be a badly made cable to have the fairly modern micro USB connector and yet not even support USB 2.0

You could check the board with a strong magnifying glass for solder blobs, shorts, broken traces.  And you could reflow the solder on the memory chip (does it have accessible pins, I forget) and CPU.

Are there any components missing?
« Last Edit: October 26, 2018, 06:14:17 am by TheOtherCliff »