robertr

  • *
  • 31
Motors keep spinning when testing Failsafe.
« on: July 15, 2018, 08:12:59 pm »
  Hello, I have a failsafe problem after switching from receiver PWM to S-bus.
 Everything worked good with the PWM setup, motors shutdown when testing failsafe but since I changed to S-bus when I test failsafe the quad shuts down but the motors keep spinning at idle speed.
 I suppose I would ok with it like this as long as the quad landed upright on a bare surface but would probably burn something up if the props were blocked.
 Hopefully something simple I missed, newby here.
 Thanks, Robert.

Re: Motors keep spinning when testing Failsafe.
« Reply #1 on: July 15, 2018, 08:23:44 pm »
There is a setting for that on Output page "Motors Spin when Output Neutral..." or similar.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #2 on: July 15, 2018, 09:11:33 pm »
 Hello Cliff, I had that enabled with my Pwm receiver and the motors shut down when failsafed but with the same setup with S-bus they keep running.
 If I turn off " Motors spin when neutral" ASWA becomes disabled.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #3 on: July 15, 2018, 09:39:49 pm »
 I did go from 490 to Oneshot 125 for my esc's if that is any help. Quad is flying nice, just have the failsafe issue to sort out if possible.

Re: Motors keep spinning when testing Failsafe.
« Reply #4 on: July 16, 2018, 12:05:55 pm »
Then it is probably just a matter of setting Output Mins low enough so that they don't spin.  Output Neutrals is what you set to "idle speed".

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #5 on: July 16, 2018, 04:46:33 pm »
 Thanks Cliff, I will give that a try, going to play around with it today and see what happens.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #6 on: July 16, 2018, 07:20:37 pm »
 Well I tried setting motor outputs as low as they would go but then AWSA quits working, apparently the motors have to be spinning for AWSA to work.
 Very strange, everything worked perfectly using a PWM receiver, with S-bus receiver I have the failsafe problem.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #7 on: July 17, 2018, 05:26:53 pm »
 I spent most of my day yesterday trying to get my failsafe working properly with S-bus receiver connection, no luck.
 Most likely something I am missing but I am a newbie and my old brain is at a loss .
 I will most likely have to upgrade my board and try out Betaflight, probably be worse off but hey that is the hobby I guess. ;D
 Thanks everyone for your help, especially Cliff, I could not have made it this far without it, Robert.
 

Re: Motors keep spinning when testing Failsafe.
« Reply #8 on: July 17, 2018, 06:30:23 pm »
Do you understand that there are two kinds of failsafe?
- Rx failsafe when Tx is out of range, set in RC system
- FC failsafe when Rx is not sending a signal to FC any more, set in FC with GCS

Some Rx don't have a failsafe and just hold last position.  Some Rx can be set to stop sending signal when out of range and that is how you use FC failsafe.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #9 on: July 17, 2018, 09:25:44 pm »
 Yeah I tried setting both, then one at a time with the same result, inputs go to zero but quad motors keep idling. Same setup with pwm receiver and motors would completely shut down on failsafe.

Re: Motors keep spinning when testing Failsafe.
« Reply #10 on: July 17, 2018, 09:51:31 pm »
Well I tried setting motor outputs as low as they would go but then AWSA quits working, apparently the motors have to be spinning for AWSA to work.

Do you know that you set (Output) Mins so that motors are off, and Neutrals so that motors spin at idle speed?  If this is set, and proven to work with Test Outputs (take props off) then the problem is not the Output Min/Neutral/Max.

The other issue is depends on whether you successfully had Rx failsafe or FC failsafe working.  For instance if you have a different Rx now, some Rx's don't have failsafe (Rx failsafe won't work) and some Rx's can't be set to stop sending signal during failsafe (FC failsafe won't work).

Are you using the same kind of failsafe you used before (Rx vs. FC) or were you say using FC failsafe before and Rx failsafe now, because that would do it.  Motors set to always spin and the FC doesn't know that there is a failsafe.

Which ever failsafe you are using, you should make sure the throttle is as low as it will go during failsafe.  That seems like the cause to me.  You can connect GCS and watch what the Inputs and Outputs do when you go into failsafe.  That (Input) will tell you whether the throttle stick goes all the way down.

Also, you didn't mention whether you have an arming switch.  Maybe your Rx failsafe just needs to set the arming switch to disarmed if that is what you had before.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #11 on: July 17, 2018, 10:49:53 pm »
 Cliff I bought a Taranis QX7 with a XSR receiver, manual for the radio says " Sbus port always outputs, no pulse could not perform properly on it. Set "Hold" or "Custom" for S-bus port".
 Maybe a transmitter ,receiver problem. I will check Youtube and make sure I am setting up the failsafe correctly.
 Thanks again Cliff.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #12 on: July 20, 2018, 06:05:37 pm »
 No luck with finding a solution for my failsafe problem, I think it is something on the Librepilot end because the failsafe works when I am not using ASWA but as soon as I enable ASWA I have problems.
 Not going to worry about it and just keep flying short range till I can afford to switch to a new F4 controller and try out Betaflight. There must not be any one else using S-bus with their CC3D controller, must be all using PWM or PPM I guess.
 Thanks again for your help Cliff, now I wil get out of your hair. Aside from the failsafe problem I realy liked using Librepilot with my CC3D controller.
 Robert.

Re: Motors keep spinning when testing Failsafe.
« Reply #13 on: July 20, 2018, 09:30:36 pm »
I don't use CC3D.  I use Revo, Sparky2, and Nano.  I use SBus with most of these and I do have and use FC failsafe on all my models.  It is easy for me.  My Taranis Tx has a failsafe option that tells the Rx "don't send pulses", and that works with the Rx's I use.

robertr

  • *
  • 31
Re: Motors keep spinning when testing Failsafe.
« Reply #14 on: July 21, 2018, 03:30:05 am »
 My QX7 is the same and I set it the same as you " no pulses" . Anyway, trying out my tuning skills today and so far so good.