OpenPilot CC3D problem
« on: August 26, 2017, 07:06:50 pm »
Hey guys, im new to the forum so sorry if i post in the wrong area but i recently bought a CC3D Evo flight controller from AliExpress(yea i know, mistake #1) and when i plug it into my computer with the data cable, it doesnt even light up, but when its plugged in with a battery, the receiver gets power from it just fine. Anyone able to help? i ordered an FTDI driver to upload a bootloader and firmware incase, as well as a new board from amazon.

f5soh

  • *****
  • 4007
    • LibrePilot
Re: OpenPilot CC3D problem
« Reply #1 on: August 26, 2017, 08:28:59 pm »
Hi, welcome.

If no light, just ask for replacement or just put the FC to the trash.
There is no magic, if nothing due to a hardware issue (no power) the software cannot repair.

Re: OpenPilot CC3D problem
« Reply #2 on: August 27, 2017, 05:06:37 am »
But even if it's still giving power to the receiver? And if I flash firmware there's no chance I can fix it?

hwh

  • *
  • 1018
Re: OpenPilot CC3D problem
« Reply #3 on: August 27, 2017, 05:39:06 am »
Power to the rx is just a direct trace on the board.   If no led comes on when power is applied there's a hardware defect since the power led would come on even with no firmware at all.  The power led is connected to the output of one of the voltage regulators.  If it's not on either the protection diode is bad, the voltage regulator is bad, the led is bad, or something is shorted and pulling so much power that the regulator can't keep up.  If it were just the led that's bad the board would still boot up and connect to the computer.

Re: OpenPilot CC3D problem
« Reply #4 on: August 27, 2017, 06:31:15 am »
Or the USB cable is bad (try a different cable that you know works) or the USB connector on the CC3D is bad or the computer USB can't produce enough current to power the CC3D (try a different computer, use a desktop, not a laptop).

Try the USB and battery at the same time.  If the USB works when the battery is plugged in, you can just do it that way.  This will require some thought when you use it for setup wizard or ESC calibration because of safety or other reasons.  Removing props is the safe way.

Re: OpenPilot CC3D problem
« Reply #5 on: August 28, 2017, 08:46:30 pm »
Thanks for all the responses guys. The problem is that even when I connect only the battery, nothing happens. The ESC's make noise of course, but no light,  no arming, and when I connect it to the computer, no connection. So I ordered a new cc3d from amazon. and that one worked just fine, then it does during setup. So I'm not sure what could have gone wrong. Its not my drone connection is it? I also ordered a Naze32 6dof, hopefully that works better.

Re: OpenPilot CC3D problem
« Reply #6 on: August 28, 2017, 10:35:08 pm »
Naze32 is not supported in LP 16.09, but might be supported in the next release.