Re: Erratic transmitter behavior in Librepilot
« Reply #15 on: August 11, 2017, 06:44:38 pm »
@f5soh
Is this a problem with having RSSI on PPM stream (or any stream)?

RSSI movement would be detected as stick movement during transmitter wizard.

Re: Erratic transmitter behavior in Librepilot
« Reply #16 on: August 12, 2017, 01:50:02 pm »
I've now given up on the wizard and configured the TX manually however the motors spin up very fast like 50% is there a way in the config to adjust this?
Mike

Re: Erratic transmitter behavior in Librepilot
« Reply #17 on: August 12, 2017, 03:30:38 pm »
It could possibly mean you need to calibrate the esc's. You do that on the output page. There is a really good page in the wiki page on this website. Sometimes its best to just skip the wizards and set up your self. I had issues with the wizard setting up my quad and just skipped through it and went back manually and set up the steps i skipped and it works great. Some people don't use the wizards at all. it's not mandatory you do it, it's just there to help people out that dont know everything you need to do. As long as you go through every tab and have everything that applys to your craft you will be fine. When you go for your madien flight just make sure you lift off and fly los  to make sure the controls are correct . Good luck. hope everything works out for you and your craft.

Try this link

https://librepilot.atlassian.net/wiki/plugins/servlet/mobile?contentId=12058743#content/view/12058743
« Last Edit: August 12, 2017, 05:35:15 pm by Wayne'sWorld »

Re: Erratic transmitter behavior in Librepilot
« Reply #18 on: August 13, 2017, 01:40:39 am »
Do ESC calibration
https://librepilot.atlassian.net/wiki/display/LPDOC/ESC+Calibration

If it still goes to 50% right away, and you have non-default PIDs your PIDs (mainly D terms) may be too high.

f5soh

  • *****
  • 3767
    • LibrePilot
Re: Erratic transmitter behavior in Librepilot
« Reply #19 on: August 14, 2017, 10:54:51 am »
I've now given up on the wizard and configured the TX manually however the motors spin up very fast like 50% is there a way in the config to adjust this?
Mike

Revert the Stabilization > Basic > "Zero integral when Throttle is low" (bottom) to Checked, as default.
In previous config file you posted some days ago, it was disabled.
Almost sure this will fix your Throttle jump while moving the Throttle stick. :D

« Last Edit: August 14, 2017, 10:57:53 am by f5soh »