FS-i6 setup switches now quad won't arm
« on: April 20, 2017, 07:25:31 pm »
Would someone tell me what I'm doing wrong here? After creating 6 flightmodes in LibrePilot and programming the switches as shown below  my 250 QC with a Revo will no longer arm unless I change it to always armed. When I do that it automatically throttles up.

Channel 5 & 6 for the 6 flight modes, channel 7 for a second throttle safety and channel 8 I'm not sure what I'm using it for yet. I think I'm going to use it for failsafe return home.

Aux Channels
Channel 5 = Sw C+D
Channel 6 = Sw D
Channel 7 = Sw A
Channel 8 = Sw B

Switch assignments
Fly mode  = Sw D 
Idle mode = Sw B
Thro. Hold = Sw A

Throttle hold
Hold  =  Off   
Value = 50%
« Last Edit: April 20, 2017, 09:20:10 pm by schoonke »

Re: FS-i6 setup switches now quad won't arm
« Reply #1 on: April 21, 2017, 03:57:54 am »
If it was working before, then the answer is that your arming stick positions (or arming switch position, etc.) is not what it was before.

You can read what your transmitter sticks are saying by looking at the Input page.  Make sure you turn off "always armed" first.

For arming with right yaw, the throttle must be zero (not even 5%) and yaw must be 90% to 100% rightward IIRC.  Your mixes threw that off.  Find out where the mixes are making a problem, or re-run the transmitter wizard.  Be aware that the transmitter wizard can't do miracles though...  :)

Made changes on a 250 Quad, Revo, LibrePilot 16.09 and & now it won't arm?
« Reply #2 on: August 08, 2017, 11:30:39 am »
  250 Quad with a Revolution running LibrePilot 16.09. I changed the FS-i6a receiver using PWM to a FS-ia6b using PPM. Then I configured the following on a FS-i6 transmitter with 10 channel firmware: switch A (ch7-Accessory1) as a throttle safety, switch B (ch8-Accessory 2) for arming, switch C & D (ch5) for FC modes and D (ch6) to switch btw FC 1-3 & FC 4-6. Arming is set to Acc2 in configuration tab.
  All switches appear to be work on the RC settings on the configure tab but the quad won't arm. The input light on the sys health panel lights up yellow. Failsafe is unchecked on the failsafe settings tab.

  I was hoping someone might take a look at my uav file to see if you can spot where the problem might be.
  I think next time I'll defiantly do one change at a time!!!
« Last Edit: August 08, 2017, 04:24:33 pm by schoonke »


  • *****
  • 3769
    • LibrePilot
Cannot help here... all the files you posted are empty.

Yellow input alarm mean the receiver is not powered or some input channel you configured is missing and finally board is in failsafe state.
Re-run transmitter wizard.

There is multiples issues in your configuration that highlight you did the config by hand.

- Accessory2 has min/max = 0 and should be used for arming, this cannot work...
- Collective is PPM input type without channel assigned and collective is not used here.

All the above will be fixed after rerun the Transmitter Wizard.

Why you mapped the 3 Accessory to outputs, any reason ?
Outputs are also set with min/max = 1000/1001 (no range)
« Last Edit: August 08, 2017, 04:47:16 pm by f5soh »

I think it fixed everything but still doesn't arm, please see new UAV file. Also found that I had transmitter failsafe turned on. Fixed that and now the input light is green! Still not arming though.

Modified, no need to quote a post found just above.
« Last Edit: August 08, 2017, 09:10:50 pm by f5soh »


  • *****
  • 3769
    • LibrePilot
Accessory1 still wrong for arming.

Did you really redo the Transmitter Wizard ?
Accessory1 to Accessory3 are not fine.

« Last Edit: August 08, 2017, 09:12:50 pm by f5soh »

Re: FS-i6 setup switches now quad won't arm
« Reply #6 on: August 10, 2017, 06:15:07 am »
I did run transmitter wizard and that was the result. Please advise how to correct the accessory's? Should I try running the wizard again?


  • *****
  • 3769
    • LibrePilot
Re: FS-i6 setup switches now quad won't arm
« Reply #7 on: August 10, 2017, 10:47:29 am »
Try the Manual calibration.

Click the "Start Manual calibration" button
Move all sticks and switches
Click the same button called "Stop Manual calibration" button

Try moving the min value around 1000 by hand


  • *****
  • 3769
    • LibrePilot
Re: FS-i6 setup switches now quad won't arm
« Reply #8 on: August 10, 2017, 11:17:59 am »
Looking again at your latest config file, using the Transmitter Wizard the Accessory1 (ch7) and Accessory2 (ch8) cannot be detected with a min/max value set to 0.

So redo the transmitter wizard and save at end, this will remove any channel not valid or not detected.

Re: FS-i6 setup switches now quad won't arm
« Reply #9 on: August 11, 2017, 07:56:01 am »
Changing the min on all accessories to 1000 did the trick!

I can finally arm my Quad again!!!

Thank you very much for your assistance.

I can't wait to try it out tomorrow.

Re: FS-i6 setup switches now quad won't arm
« Reply #10 on: August 13, 2017, 10:32:41 pm »
I'm having a different problem now. It works good connected to LibrePilot, but when I brought it out doors not so much. It goes from 0-50% throttle with nothing between.

So I connected to LibrePilot and ran vehicle wizard and it work good. Then to make sure I went back down to 0 throttle & when I gave it throttle I'm back to 0-50%. No if I disarm and arm again its better, but again if I go back down to 0 same thing all over again?

Any ideas?


  • *****
  • 3769
    • LibrePilot
Re: FS-i6 setup switches now quad won't arm
« Reply #11 on: August 14, 2017, 10:36:48 am »
Revert the Stabilization > Basic > "Zero integral when Throttle is low" (bottom) to Checked, as default.