Brunosanta

  • *
  • 43
  • I understand it all but know nothing
VelocityRoam, Quad will fly too slow.
« on: August 09, 2017, 08:54:34 pm »
Hello All, 
Im almost sure the othercliff or Fish05 will have an answer to that!! I managed to build a new 250 with the cheap GPS banggoodthe one without mag, and internal Mag from Revolution board., all green, rock solid lock. If anyone needs the link just ask cause this board doesn't have the c9 problem for Baro, it worked out of the box no oscilations.
I used the auto tune which helped a lot. the problem is when I give stick deflection either pitch or roll, the quad flies really slow, as if there was a speed limit.
I wen to Settings>VpathRoll and changed the Angle from velocityrroam from 20 to 100 thinking it would do the trick, the problem is, it is still flying really slow.

 Another question, Do you guys reckon using Rattitude mode and GPS assist for breaking it from drifting could work better than velocity roam?
do the PID's from Attitude mode reflect on velocity roam?
And one last question: my take of not smooth, lets say if I take of straight up no problem, but If I give the quad to my brother inexperienced, he will try to give a little throttle but the props won't start all at the same time, it will sort of drift to the sides till its airborne. Could I do anything on the TPS to make sure the quad starts real smooth, if so what?
Any other settings I can play with?

One big hint, dont ask me why: Calibrate magnenometer first, then do the accelerometers.. if you do it the other way around you get the mag constantly getting bias and the drone doing toilet bow...
Another one that worked for me is:
Everybody is only optimistic on the social networks.. being real is hard nowadays

Re: VelocityRoam, Quad will fly too slow.
« Reply #1 on: August 10, 2017, 12:37:14 am »
VelocityRoam mode IS speed limited.  The stick position corresponds to speed.  By default, full stick is 10 m/s (36kph or 22 mph) which is faster than most people can run.  Half stick is half speed, etc. (the corner stick position is more...).

On System page expand "Settings" and change VtolPathFollowerSettings.HorizontalVelMax to change this value.  Press red up arrow at top of screen to save this setting.

Set that angle back to default!!!!

Rattitude is not velocity limited.

There is an auto takeoff mode that I have never used.  The answer to good takeoffs is to avoid making changes to settings (like disabling "zero the integral..."), start from level ground, leave control sticks neutral and jump it into the air as soon as you start the motors.  No sloped ground, no helping it by moving the sticks, no slow takeoff.