Re: Need a little help with setup
« Reply #15 on: December 05, 2015, 01:08:22 am »
You're right, telemetry ports are currently "hardcoded" at 57600 by mistake.

Is there a Jira for that?  I didn't see one.  :(

f5soh

  • *****
  • 4007
    • LibrePilot

Re: Need a little help with setup
« Reply #17 on: December 05, 2015, 11:33:18 am »
still no joy at 57600 same issue have changed baud on bluetooth +fc +oplink
any other ideas?

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Need a little help with setup
« Reply #18 on: December 05, 2015, 12:28:51 pm »
If USB is connected i think the USB telemetry take priority ?

Re: Need a little help with setup
« Reply #19 on: December 05, 2015, 06:10:58 pm »
no had usb disconnected and multiple attempts. its annoying me at the minute because I want to tidy up the transmitter so I can get rid of the usb.
it seems a bit more difficult to bind the fc and oplnk at 57600 so im not ruling out dodgy hardware.

Re: Need a little help with setup
« Reply #20 on: December 05, 2015, 06:32:52 pm »
Perhaps you can try to swap rx and tx on the bluetooth device...

Re: Need a little help with setup
« Reply #21 on: December 05, 2015, 07:18:51 pm »
fairly sure wiring is correct as I can see the oplink in the gcs once  connected

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Need a little help with setup
« Reply #22 on: December 05, 2015, 08:40:06 pm »
fairly sure wiring is correct as I can see the oplink in the gcs once  connected

Not sure what you say... you can see the OPlink tab inside config, connected through Bluetooth ?

Re: Need a little help with setup
« Reply #23 on: December 05, 2015, 08:47:42 pm »
yes but gcs receives no data

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Need a little help with setup
« Reply #24 on: December 05, 2015, 08:53:11 pm »
Do you have the two small bar on bottom/right that says there is Tx and Rx data ?

Like file attached

Re: Need a little help with setup
« Reply #25 on: December 05, 2015, 09:15:36 pm »
yes tx goes between ~24/48
rx between ~114/148

rx seq no. and rx rate B/s remain at 0 though.

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Need a little help with setup
« Reply #26 on: December 05, 2015, 09:18:21 pm »
So GCS is talking with OPLM through Bluetooth and you can see OPLink tab.

Not a bluetooth issue but between OPLink and Revo.
Post Config > Oplink tab screenshots for Revo and another for Oplink

Re: Need a little help with setup
« Reply #27 on: December 05, 2015, 11:35:18 pm »
Ok so problem solved thanks so much for your help you got me looking on the right track.
you were right the bluetooth to the oplink was working. but the problem was with the oplink to the revo.
So I noticed that when I connect power to the bluetooth module the revo would loose its connection with the oplink!!
It appears the voltage drops to much when powering both the oplink and the bluetooth module from my transmitter.

I will stick another reg in there as I just took a line of the existing 5v regulator beside the switch inside.
it wasnt an issue without the bluetooth module but obviously was at its limit.

Re: Need a little help with setup
« Reply #28 on: January 02, 2016, 08:14:39 pm »
Hi again

so I am fairly happy with the way it flys in attitude mode now.
however I noticed today that although the GCS tells me that my GPS has a fix(7/8 satallites) the UAV location never moves on the map. It appears to be stuck 1 location.
If I rotate the quad the UAV rotates on the map though.

I dont think I was like this before becaue I remember leaving it sit for a while before and the UAV trail would jump around abit as it picked up more satellites.

any thought on what could cause this?

I really dont want to reset and start again as I am happy with how it flys now

Re: Need a little help with setup
« Reply #29 on: January 03, 2016, 08:01:58 am »
If you don't have any GPS guided flight modes, then it will let you arm and take off without a full GPS lock.

GPS needs 7 satellites and PDOP<3.5 to come fully online.

Simple way around that for now may be just to right click on map and enable "Show Diagnostics".  You will get a green GPS trail of simple GPS coordinates.

Are you using Basic or INS13 for Attitude Algorithm?