bruno

  • *
  • 5
librepilot 16.9 et I-bus
« on: April 01, 2017, 12:48:40 pm »
Bonjour.

 Je ne sais pas si je suis sur le bon post, dans ce cas j'en suis désolé (j'ai déjà eu du mal pour la présentation).
Donc j'ai réussi le passage d'openpilot à librepilot version 15.9 (boot loader et firmware), voici donc mes questions :
   1) faut il désinstaller librepilot 15.9 avant d'installer la dernière version 16.9 ?
   2) après l'installation y a t-il une nouvelle version du boot loader et firmware a faire ?
   3) Confirmation du branchement du RX FS-i6 B sur le flexiport de la CC3D (sortie servo ,I-Bus du RX 3 fils: noir pour le moins, rouge pour le plus , le jaune relié au RX et le fil bleu qui ne sert a rien. J'ai aussi un doute sur la tension de sortie du +. Si j'ai bien compris la sortie n'est pas régulée. On trouve la tension qui rentre sur la CC3D.
   Est ce correct ?
   4) Et enfin, la commande des LEDs, je suppose qu'il faut faire comme pour le buzzer, lien ci dessous :
https://librepilot.atlassian.net/wiki/display/LPDOC/Add+a+buzzer+to+Multirotor+frame  .
Mais ou brancher les 2 fils issus de la PDB. directement sur le récepteur (sur le channel choisi) comme en PWM ou sur la CC3D et dans ce cas ou ?
Par avance merci pour la patience et les réponses.

f5soh

  • *****
  • 3922
    • LibrePilot
Re: librepilot 16.9 et I-bus
« Reply #1 on: April 02, 2017, 11:56:42 am »
Bonjour,

Tu peux installer Librepilot 16.09 dans un dossier à coté si tu veux.
Si tu passes en 16.09 il faut mettre à jour le firmware bien sûr, de la même manière que tu as mis à jour lors du passage de OP à LP.

Les tensions sur les ports ne sont pas régulées, tu peux confirmer tes doutes en mesurant cette tension.


Si tu as un accessoire qui utilise du PWM en entrée tu peux le brancher sur une des sorties.
Généralement tu en as 6 de dispo avec des connecteurs servos, plus d'autres (7, 8, 9...) sur le port récepteur.
https://librepilot.atlassian.net/wiki/display/LPDOC/CC+Hardware+Configuration#CCHardwareConfiguration-ReceiverPort

La banque correspondante aux sorties accessoires utilisées devra être en PWM-50Hz


bruno

  • *
  • 5
Re: librepilot 16.9 et I-bus
« Reply #2 on: April 04, 2017, 01:39:43 pm »
Bonjour et merci tout plein pour les explications f5soh, ainsi que pour la rapidité des réponses.  :)

bruno

  • *
  • 5
Re: librepilot 16.9 et I-bus
« Reply #3 on: April 10, 2017, 03:26:12 pm »
Bonjour à tous.
C'était trop beau pour que cela fonctionne du premier coup. Impossible de passer en I-BUS. La CC3D est reconnue (voir Image LP I-bus) mais arrivé à la calibration des esc rien (pas de bip) et impossible d'aller plus loin (pas de  de démarrage des moteurs etc). Donc  j'ai passé les autres étapes pour aller voir dans l'onglet Input (photo LP I-BUS 2) les 4 axes sont pourtant en I-BUs.
Bref retour au PWM tout ce passe bien de A à Z. Si vous avez la solution je suis preneur. Le matériel et branchement :
eachine racer250, CC3D, radio flysky FS-i6 (flashée en 10 voies) recepteur FS IA6B, PPM output sur on, photo 3 pour le branchement.

f5soh

  • *****
  • 3922
    • LibrePilot
Re: librepilot 16.9 et I-bus
« Reply #4 on: April 10, 2017, 05:04:28 pm »
Quote
recepteur FS IA6B, PPM output sur on, photo 3 pour le branchement.

Faut savoir ce que tu veux...
IBus ou PPM ?

Si PPM, tu te branches sur le "CH1 - PPM" et tu choisis PPM

bruno

  • *
  • 5
Re: librepilot 16.9 et I-bus
« Reply #5 on: May 29, 2017, 11:15:39 pm »
Bonjour, j'ai résolu mon problème.

Je poste pour donner les infos à la communauté. Tout d'abord petit rectificatif à ma dernière demande d'aide (copier coller trop rapide) donc la version complète  ci-dessous :
   - eachine racer250, CC3D, radio flysky FS-i6 (flashée en 10 voies) récepteur FS IA6B, le PWM est OK.
   - PPM output "on" sur la radio. branchement entre channel 1 (RX) et PPM input, pin8 (Receiver Port de la  CC3D) le PPM fonctionne.

Voyons le "I-BUS"

   - PPM output "off" sur la radio. branchement entre l'emplacement "servo" (RX) et Flexiport (CC3D),le I-BUS ne fonctionne pas (testé avec 2 récepteurs FS-I6B).

Comme je n'aime pas laisser un problème me tarabuster, j'ai creusé avec les moyens disponibles (un appareil pour voir la trame série serait utile, mais je n'en ai pas) j'ai emprunté une Flip32 et après paramétrage sur cleanflight, le I-BUS fonctionne très bien avec mes 2 récepteurs.

Donc CC3D incriminée mais pas "morte".  pour faire court, inspection des soudures avec une bonne loupe. Un seul contact de la prise JST du Flexiport est soudé (Vcc).
Par précaution j'ai attendu la réception d'une autre CC3D avant de confier la réparation à un pote qui voit bien  :), ne tremble pas  :)  :) et possède le fer à souder qui va bien.

Problème résolu.