A8

  • *
  • 20
Auto level mode?!!!
« on: February 12, 2017, 04:58:51 pm »
An important question !!!

What is Auto level mode ?  Rate   Ratetrainer  Attitude  Axislock  or Weakleveling?!!!

I need to give when I stick the bird Automatic Level.


A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #2 on: February 13, 2017, 09:41:02 am »
I set Attitude but Quad drift on Hover!!!!
Stick in elevator and aileron is very weak or dead!!!

What is setting in picture for better stability?


f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #4 on: February 13, 2017, 10:20:31 am »
What is Ratetriner ?

Same link for explanation : https://librepilot.atlassian.net/wiki/display/LPDOC/Input+Configuration#InputConfiguration-StabilizationModesConfiguration

You can also find the Ratetrainer page and others here :
https://librepilot.atlassian.net/wiki/display/LPDOC/Advanced+tuning

Drift can be due to a wrong level settings or simply PID that need to be adjusted.

For basic / primary flight modes, complementary is fine.

A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #5 on: February 13, 2017, 03:28:21 pm »
What is Ratetriner ?

Same link for explanation : https://librepilot.atlassian.net/wiki/display/LPDOC/Input+Configuration#InputConfiguration-StabilizationModesConfiguration

You can also find the Ratetrainer page and others here :
https://librepilot.atlassian.net/wiki/display/LPDOC/Advanced+tuning

Drift can be due to a wrong level settings or simply PID that need to be adjusted.

For basic / primary flight modes, complementary is fine.

I read all and set but auto level not work!!!

What is magnetometer setting?

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #6 on: February 13, 2017, 03:40:13 pm »
There is no need Magnetometer for Complementary + Attitude stabilization

A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #7 on: February 13, 2017, 04:21:18 pm »
There is no need Magnetometer for Complementary + Attitude stabilization

This is my setting that auto level not work:


A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #8 on: February 13, 2017, 04:25:05 pm »
Set up file :

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #9 on: February 13, 2017, 06:29:12 pm »
Are you sure you select the flightmode position 2 ?

Your PID settings are really strange, Yaw should not be the same as Roll/Pitch
Attitude P (outer loop) is pretty high.



Where did you find this settings ? Try default, clicking "Default" button.
In your screenshot number appears strangely, is this chinese numbers ?


A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #10 on: February 13, 2017, 08:31:26 pm »

My Quad is 130mm 1306  kv4000 motor , it be very loose in default setting!!!

I increase PID until fly is stable but axis not to return to level!!!!!

I think is missing from informed regulatory!!!!! :-[
« Last Edit: February 13, 2017, 08:51:34 pm by f5soh »

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #11 on: February 13, 2017, 08:50:20 pm »
Here is the PID i have for a similar setup and 1104-400kv / 130 quad.
Not extremely optimized because i use 2S and 3S battery.



Accelerometers can be affected by vibrations and report a wrong attitude.
You can test statically applying Throttle, maintaining firmly on desk and looking at PFD behavior.

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #12 on: February 14, 2017, 10:12:37 am »

- Vibrations / test on desk how react the attitude / PFD.
- Adjust PID, use easyTune / AutoTune
- Reduce Attitude P (outer loop) to default.
- Double check you really use Attitude stab and not using other you configured (Axislock / RateTrainer)



A8

  • *
  • 20
Re: Auto level mode?!!!
« Reply #13 on: February 14, 2017, 11:25:41 am »

Thank to F5soh , the final setup:

« Last Edit: February 14, 2017, 11:32:33 am by f5soh »

f5soh

  • *****
  • 4007
    • LibrePilot
Re: Auto level mode?!!!
« Reply #14 on: February 14, 2017, 11:35:54 am »
You should avoid the "Always armed" setting
Adjust your neutrals in Output tab : move the slider to the value where the motor just start using the "Test outputs" option.


No need to quote a message just posted previously.