• *
  • 2
Need help - Motors are not SPIN even armed
« on: January 13, 2017, 09:33:20 am »

I'm writing here to All, as I need your expert help to solve the issue of my quodcopter.

I am using CC3D (EVO) FC and have successfully connect all the components and done the initial setup things. But, still motors are not spinning through the transmitter even if it's armed. (Motors are spinning during calibration process & successfully calibrated many time with single & all esc process). Apart from that, I have also verified my transmitter settings and it's behave normally (able to see pitch, yaw, throttle movement in LibrePilot GUI)

When armed it's give me sound "ARMED" from the my laptop and i wait for 10 sec & tried to up the throttle but no response from the motors. (not even single motor spin). Also i tried all ESC freq. from 50 to 490 settings but still not getting things done.

I don't know where i'm doing wrong, Please guide me.

my components list are :

(1) Motor, ESC & Propeller (A2212 1200KV - Motor, Properller - 1045 & ESC - 30A simonk RED)

(2) CC3D Evo FlightController board.

(3) Copter Frame : Neewer 4-Axis Airframe

(4) LiPo Battery : 2200 mAh 3s

Waiting helping hand for your end.


Re: Need help - Motors are not SPIN even armed
« Reply #1 on: January 13, 2017, 11:16:57 am »
Why are you wait 10secs before you start the motors?
I plug in the battery wait FC LEDs connected to stop flashing rapidly which tells me not to move it,
Place on take off point than I arm, than take off.
You could be waiting to long and FC disarms

Have you selected the arming in the gcs? E.g switch or stick because when you run the wirzard it put the FC into disarm and when you finish you select which arm in gcs which would say disarm on the little down drop menu

Do you have any GPS modes selected on FC? If you do it will not arm until you enough sats and there is no warnings e.g mags etc.
« Last Edit: January 13, 2017, 11:20:23 am by Hawkview »

Re: Need help - Motors are not SPIN even armed
« Reply #2 on: January 13, 2017, 04:17:22 pm »
From PM, in case this helps others:

If GCS says it is armed, then one thing comes to mind, but I might be wrong.

16.09 has a new feature where it waits to do gyro calibration (part of arming) till after it sees that the FC is not moving.  If you have noisy gyros, it can keep it from completely arming?

Try disabling Attitude -> Settings -> Wait Until The Board Is Steady

If that fixes it, you can re-enable that and increase the "steadiness value".
System -> Settings -> AttitudeSettings -> BoardSteadyMaxVariance
Maybe try 10 or so.  Find the lowest value that works well.

To save that value, highlight (click to highlight, but not enough to edit again) the changed value and then press the red "up arrow" at the top of the screen.

Also: Quad must be sitting on the ground during this arming gyro calibration.  You can't hold it motionless enough in your hand.

One last thing: The default arming timeout is 30 seconds, so if you wait more than 30 seconds it will automatically disarm and there is no speech to tell you it is disarming.


  • *
  • 2
Re: Need help - Motors are not SPIN even armed
« Reply #3 on: January 18, 2017, 08:12:18 am »
Hi Clif,

It goes resolved. I have done as you said & it's working. :)

Thanks a ton !!!