alanod

  • *
  • 3
Eachine Racer 250 Firmware issues
« on: December 23, 2016, 02:14:19 pm »
Hi all,
I received a eachine racer 250 there yesterday and im having serious problems with trying to get librepilot onto it. The drone came premade and it shows on the computer as an unspecified device. I uninstalled and reinstalled the librepilot but everytime i click on the rescue button it times out when i plug in the drone. Its very frustrating and i hope someone can help. I also tried 2 different laptops to install and still no joy. Cheers in advance !

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Eachine Racer 250 Firmware issues
« Reply #1 on: December 23, 2016, 02:25:04 pm »
Hi, welcome.

Be sure the quad is not powered with Lipo and try the manual update for firmware:
https://librepilot.atlassian.net/wiki/display/LPDOC/Firmware+Tab#FirmwareTab-Manualmethod

Try another USB cable

alanod

  • *
  • 3
Re: Eachine Racer 250 Firmware issues
« Reply #2 on: December 23, 2016, 02:30:48 pm »
Hi i tried that and still no joy i used a bunch of usb leads too ! I'm assuming a phone lead is appropriate ?
« Last Edit: December 23, 2016, 03:55:23 pm by f5soh »

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Eachine Racer 250 Firmware issues
« Reply #3 on: December 23, 2016, 03:55:07 pm »
Some phone leads only supports charging, not data.

While powering the quad what's the board's led activity ?

alanod

  • *
  • 3
Re: Eachine Racer 250 Firmware issues
« Reply #4 on: December 23, 2016, 04:12:32 pm »
Theres just a solid blue light now there was a flashing red light before when the blue light was solid but now it is just the blue solid led

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Eachine Racer 250 Firmware issues
« Reply #5 on: December 23, 2016, 04:25:43 pm »
So blue light is power. No activity from board.
You should have at least a fading blinking led while running with the bootloader.

The only way is flash the bootloader using a ST-Link
https://librepilot.atlassian.net/wiki/display/LPDOC/Recover+board+using+ST-Link

or FTDI connected to the MainPort and SBL pads shorted:
http://www.southquay3d.com/index.php?route=news/article&news_id=9

If no other hardware issue around, of course.
« Last Edit: December 23, 2016, 04:29:22 pm by f5soh »

hwh

  • *
  • 1018
Re: Eachine Racer 250 Firmware issues
« Reply #6 on: December 23, 2016, 04:45:47 pm »
Are you sure that the one you have has a cc3d board on it?   They now sell them with cc3d, Naze32, and some F3 based board.  Only the cc3d one is compatible with LP.  http://www.banggood.com/Eachine-Racer-250-FPV-Drone-F3-NAZE32-CC3D-Built-in-5_8G-Transmitter-OSD-With-HD-Camera-PNP-Version-p-1074562.html?p=SO28133399239201512V shows two of the different boards.

The cc3d ones they were shipping early in the year when I purchased one had a green power led and a blue activity led.  It also had a mini-b usb connector not the micro-b usb connector that most phones have come with for the last couple of years.

Can you post a picture of the board?
« Last Edit: December 23, 2016, 04:53:23 pm by hwh »

Re: Eachine Racer 250 Firmware issues
« Reply #7 on: January 03, 2017, 11:33:51 pm »
LibrePilot 16.09
12/28/16

Problem – my CC3D board (Eachine 250 racer) unable to update firmware on LibrePilot. Got error message – not communicating with board.

Solution –
1- Start LibrePilot software.
2- Unplug USB to board
3- LibrePilot > Firmware tab > Upgrade and Erase > now rapidly plug in USB to CC3D board.

It finally connected and updated firmware.
Vince

f5soh

  • *****
  • 4529
    • LibrePilot
Re: Eachine Racer 250 Firmware issues
« Reply #8 on: January 03, 2017, 11:38:20 pm »
As described in first answer in this thread, this describes a manual update.
Needed if board has only bootloader and no firmware running or old v3 bootloader.