taitex

  • *
  • 24
3 COM port bugs
« on: June 28, 2016, 10:07:31 am »
1)
If HW setup for telemetry via VCP and not USB, when plugging in, GCS see and connects to USB but of course doesn't work. It is required that the user then hit Disconnect, wait about 10 seconds, then Connect to COM port.
If USB telemetry is Disabled, the USB device should not be connected to or even exposed if possible. At the very least, don't connect to it as it is not usable. My wild guess about something I don't know is the problem has to do with the USB must be published in some manner so that the VCP can work. Perhaps not as the HID device that GCS wants to connect to when it see.
2)
Repeat the above steps so that one is getting telemetry over the connected COM port to the GCS. Unplugging the USB cable crashes LibrePilot GCS.
3)
When connected via COM, Setup Wizard will not let one progress past the Board ID step (see attachment). The Next button is never enabled. Disconnecting, reconnecting, Back the Next, nothing will enable Next even when the ID info is all correct.

filnet

  • *****
  • 68

taitex

  • *
  • 24
Re: 3 COM port bugs
« Reply #2 on: June 29, 2016, 10:47:05 am »
Yes, those are both my thread and a bug I found. I wrote this set up as they are unrelated to those and different bugs independent of the fix for those. I don't know the process for getting this set on the bug list.

filnet

  • *****
  • 68
Re: 3 COM port bugs
« Reply #3 on: June 29, 2016, 09:08:25 pm »
Sorry, didn't check who did what...

See if you have access to Jira : https://librepilot.atlassian.net/

If yes then you can create issues there.

taitex

  • *
  • 24
Re: 3 COM port bugs
« Reply #4 on: June 30, 2016, 06:07:41 am »
I do not see anywhere that I have the ability to create new issues. If someone could add these issues, the project would benifit.

Re: 3 COM port bugs
« Reply #5 on: June 30, 2016, 07:48:51 am »
Is this the bug you wanted tracked?
https://librepilot.atlassian.net/browse/LP-350
@hwh (Harold) created it.

taitex

  • *
  • 24
Re: 3 COM port bugs
« Reply #6 on: June 30, 2016, 08:14:59 am »
It is related to the first one. Not sure what the joystick has to do with it.
But I listed two additional bugs.