motors start with max speed
« on: May 17, 2016, 04:45:38 am »
Hi, I am new to this group and also Quadcopters. Just recently started with
 4 1000kv motors
 2 ESC with 490Hz / 2 ESC with 50 Hz (got it from eBay, just found from software)
 CC3D OpenPilot (now LibrePilot)
 FlySky FS-T6 (6 channel)

 Problem:
 1. When configure and calibrate with LibrePilot software motors runs fine with radio, slow on min and fast on max. But as long remove the USB cable and runs directly from radio, on min they go to max speed suddenly.

 2. Calibrated manually also with ESC cable in receiver with radio, it works perfectly during process and when cable move to CC3D and runs again, shows same behaviour.

 3. Calibrated motors only directly from LibrePilot configuration software too but works fine only until connected through usb cable.

 Please help what I am doing wrong here. I cannot figure out anywhere.

 Thanks

 QF

popeye

  • *
  • 1
Re: motors start with max speed
« Reply #1 on: May 18, 2016, 12:25:15 pm »
I'm guessing you are throttling up without the props on? Mine was doing the same thing, but once I fitted the props, the problem sorted itself out. I think it has to do with the flight controller trying to lift the multi-rotor, but obviously can't with no props, so it just keeps increasing throttle speed to try to obtain lift. Fit the props, take it outside, try it. Just be ready to cut throttle quickly in case it still does it. I'm only a noob myself, so could be completely wrong also. lol

Mateusz

  • *
  • 782
Re: motors start with max speed
« Reply #2 on: May 18, 2016, 01:25:13 pm »
Go to input tab (no props) connect battery, turn on radio. Increase throttle on radio and observe if input bar changes accordingly in gcs. Good sanity check.

Sent from my Nexus 5X using Tapatalk


Floyd

  • *
  • 5
Re: motors start with max speed
« Reply #3 on: September 24, 2017, 08:15:15 am »
Hi
I have the same problem.
Setting the throttle close above minimum starts the motors with high speed and copter flips.

Its not a thing of TX configuration.
If i do the same configuration with OpenPilot everything is working perfect.
But after using the assistants in LibrePilot, all the motors start with much too high speed, and the copter flips immediately.
Throttle control is working as it should. Leveling is OK. Output channel configuration is done and working correct.
Test outputs is running the motors with minimum speed.
Attached uav from OpenPilot and LibrePilot.

Greetz
Floyd

Re: motors start with max speed
« Reply #4 on: September 24, 2017, 09:51:41 am »
Flipping will cause what looks like motors starting at full power.  Fix the flipping to start with.

Also, I bet the motors don't start at full power if the props have been removed.

You didn't say if this was a GPS capable FC with GPS installed and configured.

Many things can cause flipping.
- FC not mounted with arrow forward (and ESC connectors on right side)
- ESCs connected in the wrong order
- wrong motor spin direction
- wrong prop type on motors
- PIDs incorrect (try stock PIDs)
- ESC signal configured too slow for the PIDs (try PWMSync or PWM-490Hz)
- very bad ESC calibration
- taking off from a hillside
- moving the sticks before it is in the air
- increasing throttle slowly during takeoff (you should arm and immediately take off from level ground with a jump up to knee high)
- disabling "zero the integral when throttle is low" on stabilization page (why do newbies do this?? :) )
- aux mag / GPS not mounted correctly)
« Last Edit: September 26, 2017, 04:49:24 am by TheOtherCliff »

Floyd

  • *
  • 5
Re: motors start with max speed
« Reply #5 on: September 24, 2017, 10:20:04 am »
Hi
Thanks for the fast reply.

1. No GPS.
2.A lot of this issues can be excluded, because the copter is not behaving like that if i use OpenPilot for configuration.
- FC not mounted with arrow forward (and ESC connectors on right side)
- ESCs connected in the wrong order
- wrong motor spin direction
- wrong prop type on motors

3. ESC are configured as 490Hz (same is working with OpenPilot)
4. PIDs incorrect (try stock PIDs)
- Default PID values are active
5. This is definately true:
- increasing throttle slowly during takeoff
But it does not matter if i move the throttle slow or fast. Props allways start with very fast speed.

At the moment i'm back to OpenPilot, but this is not what i want to do in long term sight.

Greetz Floyd

f5soh

  • *****
  • 3923
    • LibrePilot
Re: motors start with max speed
« Reply #6 on: September 24, 2017, 11:24:21 am »
You should revert the Stabilization tab > Basic > "Zero integral when Throttle is low" (bottom) to Checked, as default.


After you armed the board, the more you wait and the more the motors go to high rpm due to the I (integral) term accumulation error.
The "Zero integral when Throttle is low" option prevents this behavior, allowing Integral accumulation error only when you apply Throttle.

Floyd

  • *
  • 5
Re: motors start with max speed
« Reply #7 on: September 24, 2017, 07:23:01 pm »
Hi
So, back to the beginning... ::)
Checked FC and motor position and wiring.
FC position 180° wrong.  :(
Placed and connected all correct -> copter flies (not really stable, but ok for first try)
All i wonder now is how it was working before with OpenPilot ???
I did not touch the Hardware when updating to Libre.

Nevertheless: A lot of THX for the help.
You were right.

Greetz Floyd

Re: motors start with max speed
« Reply #8 on: September 24, 2017, 11:02:24 pm »
In either version you can set "Rotate Virtual" to account for the FC rotation.  That is probably what was done to the OP version.

Be aware that there is no automatic conversion of settings from old versions to new versions.  If the description of a setting got changed (anything in that UAVO), then simply flashing the new version uses default values for that setting.