daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revo Nano in a 250 CP heli
« Reply #30 on: March 23, 2016, 11:45:14 am »
Pitch does not go 180 degrees. Its limit is 18 degress in the GUI. Try it.

I got into the habit of using the System to change parameters because the GUI has flaws. I didn't know that there are rules to this road. I have been traveling it for almost a year with very little help.

There was no documentation on the board I bought. I had to guess at the output wiring.


Happy Landings!

hwh

  • *
  • 1018
Re: Revolution Mini in a 250 CP heli
« Reply #31 on: March 23, 2016, 03:43:13 pm »
No one knew of the bug that limits it to 18 degrees.   I've entered it in the open issues at https://librepilot.atlassian.net/browse/LP-266

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #32 on: March 23, 2016, 03:47:51 pm »
Thanks,
 
I didn't know if it was a bug or not. How could I? I thought the 18 degrees was designed-in so I reversed roll and yaw instead of pitch--in the board rotation part of the GUI.
Happy Landings!

f5soh

  • *****
  • 4527
    • LibrePilot
Re: Revolution Mini in a 250 CP heli
« Reply #33 on: March 23, 2016, 04:09:04 pm »
Just a limitation to -90° / 90° like Attitude readings.

In you case do Roll 180 + Yaw 180

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #34 on: March 23, 2016, 06:02:41 pm »
Yes , thanks.

I saved with with board orientation : Roll 180 and Yaw 180
Now that I re calibrated the graphics are again correct. BUT the servos react the wrong direction when I roll or yaw. Pitch is good. I have always used the Accel and Gyro Scales to rectify this problem. What is the CORRECT way to fix this?

I have seen this before and just changed the two scales and gone flying. 

Sorry I am such a newb, but how do I reverse the helicopter's reactions?

BTW both Accel and Gyro Scale read -1. I did not change them. 
Happy Landings!

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #35 on: March 23, 2016, 07:09:32 pm »
I have come to the conclusion that the (vehicle) setup wizard sets your control directions? But there is no helicopter setup wizard. I am pretty familiar with the GUI and have not found where I can reverse my control directions.

Please tell me how to correct my swash. It moves the wrong direction when I roll the aircraft. If I roll left it rolls further left.
Help?
Please tell me how to correct my tail rotor. It will increase yaw left if the aircraft yaws left. Help?   

To be clear the sticks work the servos fine. The gyros/accelerometers don't.
Happy Landings!

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #36 on: March 25, 2016, 03:48:37 pm »
Thanks to hwh the swash works correctly. I remounted the board so the writing is up and the little arrow points forward.

The PFD (flight display) works opposite on roll to what I thought it should.  When you bank in to a turn the horizon tilts opposite to what I thought. Bank left and see more ground on the left side just like in a real cockpit.

I have included a photo of Blackie all chock full of gadgets.  I may remove the OPlink when I meet my goals with waypoint navigation.
Happy Landings!

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #37 on: April 12, 2016, 12:50:42 pm »
NEW PROBLEM!

Blackie woke up from paralysis confused. Servos work fine with TX but react wrongly. Pitch is backwards. And when I yaw the aircraft (manually turn the heli) the swash tilts. When I tilt the heli the rudder moves. Board rotation is still 0,0,0 and Accel and Gyro Scales are set at 1.

Either someone broke into my house and reprogrammed Blackie last night and ran off laughing OR something weird is going on.

I will try wipe the board and try to start with a fresh UAV. But that might be a problem because (with no heli setup wizard) I use an existing UAV to get started and who knows what little booby traps are already loaded into a file. It may have been started with the OP software and modified to work somewhat with LP.
Happy Landings!

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #38 on: April 12, 2016, 04:20:18 pm »
Blackie woke up confused and but is napping again. I must have disturbed him too much. I calibrated sensors with OPlink plug disconnected through USB. Saved. Checked that OPlink was enabled, reconnected OPlink plug, reconnected flight battery and Blackie doesn't budge. No bind, no servo wiggle, no USB and no OPlink. oh well. reload firmware again...

Hank mentioned that if the board is set up for OPlink data then it won't communicate via USB. Yup. And it gets you into a bind if somehow OPlink doesn't work. No way to communicate. Rats!

Then I reload the firmware and reload an old UAV (I have tried different ones).
1. Calibrate with USB cable.
2. Make sure it's set up for OPlink.

or reverse 1 and 2 and calibrate sensors with OPlink connected (since I installed OPlink to get accurate mag calibration).

I have done this a few times and I wonder if there is a CLEAN helicopter UAV available anywhere?

Does anyone know how to bypass the reload firmware and UAV step?     
Happy Landings!

hwh

  • *
  • 1018
Re: Revolution Mini in a 250 CP heli
« Reply #39 on: April 12, 2016, 04:38:41 pm »
...Hank mentioned that if the board is set up for OPlink data then it won't communicate via USB.

It should still work for usb with the oplink setup and connected.  I said that if the oplink was configured and then the oplink was unplugged from the revo-mini the revo-mini wouldn't boot.

daveapplemotors

  • *
  • 245
  • Helis rule
Re: Revolution Mini in a 250 CP heli
« Reply #40 on: April 13, 2016, 04:22:51 pm »
I am using Ubuntu 15.10 and recently ran into a problem* that I cured only by going backwards to the Libre Pilot release for 14.04 Ubuntu. I was using the ppa for Ubuntu 15.04+ until I couldn't use it anymore. 
*Problem:
the top menu bar in Libre Pilot that shows "FILE" when you put your mouse pointer near the top does not appear. I tried every key stroke and combination I could think of but I could not get a top menu. There is no way to Import, Export, etc. I used the program many times before it failed.

I uninstalled Libre Pilot 15.04+ which require downloading Synaptic, a superior Ubuntu (un)installer tool. The "description missing" detail in the latest release required this, I guess.  I reinstalled the 15.04+ version a few times to be sure, re-flashed the board and reloaded the oldest UAV that I have that used a satellite--way before OPLink. But each time the menu bar would not appear. It had been working before...

I have been having a devil of a  time with OPlink staying connected. I had it working a few times  but since it seems the source of some of my frustrations I removed OPlink, too.

Frustration, hair loss, grouchiness, missing flying time, blah, blah, I wanna fly my toy, bwah! I must go put in a few hours machining some TI to relax.

note to Hank re previous post: if it doesn't recognize the OPlink although plugged in, powered up, and configured properly then the mini-revo won't boot up in that case, too.  Awkward--reflash, import, try something else, and pray.
Happy Landings!