Microminosd and CC3D setup a bit of help please
« on: January 19, 2016, 05:53:01 am »
Hello all I am still only 3 weeks old into this hobby but learning fast. I have started my own build and decided to use an OSD with my CC3D board. I have had a hard time with it and documented the process and problems I have run across and posted them asking for help on the RCGROUPS forums here http://www.rcgroups.com/forums/showthread.php?t=2584285  If anyone would be so kind as to help me out with what I have done wrong that would be amazing. Thank you all for making such great software for my quads.

f5soh

  • *****
  • 4514
    • LibrePilot
Re: Microminosd and CC3D setup a bit of help please
« Reply #1 on: January 19, 2016, 07:31:54 am »
You need to flash your OSD with a firmware compatible with CleanFlight and enabled a telemetry stream  where the OSD is connected.

There is a page for OSD setup, but only related to LibrePilot, sorry:
https://librepilot.atlassian.net/wiki/display/LPDOC/MinOPOSD+setup

Re: Microminosd and CC3D setup a bit of help please
« Reply #2 on: January 19, 2016, 05:10:28 pm »
I have followed these steps previously. All went fine when I updated the Char set Charset_1_3_0 and updated the firmware to LP_MinimOSD_CC3D_analog_inputs2810. The OSD has been programmed to my needs and when I load Arducam and hit Read from OSD it pulls my settings back up no problem. If you look at my video here

It's a 2 min video showing my problem. I did manage to get my screen to display after removing the 2 black ground wires from the video side but still no OSD. Can you take a look at how I have it wired and tell me if I forgot something? Also to note when I load Libre Pilot the Telemetry Port is set for the Main Port on the CC3D board and the rate is 57600. I'm going to try switching ports and see if that helps. Thank you kindly for all your help it is greatly appreciated.

https://gyazo.com/862675706c5dea51f2c92847ae0017b0 <--Here is a link to my Arducam settings and yes it is set for NTSC not PAL.


"UPDATE"

I just switched the ports from the main port to the flexi port and I get the same results video but no OSD.
PIC of the settings in Libre Pilot https://gyazo.com/736f0f5a642170c984fcac8f9bf47bf0
No OSD pic https://gyazo.com/22cc39486b124871e39650f1c0b82d02
« Last Edit: January 19, 2016, 05:28:58 pm by Brent S »

f5soh

  • *****
  • 4514
    • LibrePilot
Re: Microminosd and CC3D setup a bit of help please
« Reply #3 on: January 19, 2016, 06:31:42 pm »
First step: check and find why no OSD activity in Video out.

OSD alone, powered and only video Out connected to Vtx you should receive OSD text with black background.
Not need video input or telemetry.

Re: Microminosd and CC3D setup a bit of help please
« Reply #4 on: January 19, 2016, 08:16:25 pm »
f5soh TY TY TY! I cannot express my joy enough to tell you IT'S WORKING NOW!! I had it wired up incorrectly from the TX. I rechecked everything and saw my mistake thanks to you. I really need to start drinking more coffee when I work on this thing after hours. But again THANK YOU SIR!

Wiring Pic https://gyazo.com/da13ac460683f249c5d5fd7f5643888d

OSD Pic through FS goggles https://gyazo.com/de1354d4487c387bd85f0b0581fd8a66

f5soh

  • *****
  • 4514
    • LibrePilot
Re: Microminosd and CC3D setup a bit of help please
« Reply #5 on: January 19, 2016, 08:40:55 pm »
I'm not sure what i see in your pic...

Why the yellow and blue  (video in / video out from OSD) are soldered on same place ?


The yellow wire from camera should go directly to OSD (videoIn) and the blue (videoOut) should go to Vtx

f5soh

  • *****
  • 4514
    • LibrePilot
Re: Microminosd and CC3D setup a bit of help please
« Reply #6 on: January 19, 2016, 08:54:27 pm »
Like that

Re: Microminosd and CC3D setup a bit of help please
« Reply #7 on: January 19, 2016, 10:39:55 pm »
You sir saved me once again. I just redid the whole thing per your instruction. Checked and verified OSD is working TY sir I would buy you a starbucks coffee if we meet.
https://gyazo.com/a10fea98013ecdd13ec0f19e4ff151d5

f5soh

  • *****
  • 4514
    • LibrePilot
Re: Microminosd and CC3D setup a bit of help please
« Reply #8 on: January 19, 2016, 10:46:02 pm »
Looks more clean :D