Libre Pilot Next R782 + CC3D + Micro Minim OSD issue ?
« on: April 15, 2019, 02:36:53 pm »
Recently updated CC3D firmware and GCS from 16.09 to Next R782.   On all devices (3 quads, a tricopter  and a Trex 450) Micro Minim OSD stopped communicating with CC3d through the main port (telemetry).   This was working OK before upgrade.   Connecting Bluetooth board to same main port after disconnecting the OSD and BT module works OK - so this indicates the port is actually working.        Downgraded some of the devices back to 16.09 and OSD functionality returned.   Have not tried Next R782 on my Revo equipped vehicles yet (mainly due to difficult physical USB port access).  So Either I am missing something or the new CC3D firmware is not compatable with the OSD's expected protocol Example - for RSSI there are new settings on CC3d which were not on 16.09 but are present on R782.   I am using the following OSD firmware : LP_MicroKvteam_CC3D_analog_inputs300718.hex as described here : when using Micro Minim OSD with CC3d. (I have no Minim OSD's flying at the moment
 so I cannot check Minim OSD issues if any)

Thanks for the effort that has been going on through all the years to get to this stage.


  • *****
  • 4572
    • LibrePilot
Re: Libre Pilot Next R782 + CC3D + Micro Minim OSD issue ?
« Reply #1 on: April 15, 2019, 04:54:27 pm »

Tested the LP_MicroKvteam_CC3D_analog_inputs300718.hex with current Next and it works, at least with a erased CC3D board and OSD connected to MainPort.

Remember the telemetry stream goes to USB instead of MainPort/FlexiPort if USB is connected to the board.
« Last Edit: April 15, 2019, 04:59:06 pm by f5soh »

Re: Libre Pilot Next R782 + CC3D + Micro Minim OSD issue ?
« Reply #2 on: April 15, 2019, 05:13:56 pm »
That was fast.   Thanks.   USB was disconnected when I noticed it cause it was in flight.   If it worked at your desk then it should work here, so something I did must be messing it up.   I will try a new controller and a new OSD wired on a BEC with Next 782.   Then start manually copying in values from screenshots.... Might be things went downhilll when I imported the model(s) from the previous (16.09) exports.    By the way - R782 model flights were all OK.

Once again Thanks.