Mini Revolution headaches
« on: April 16, 2019, 01:04:18 pm »
New pilot, old hardware, and big headaches.
I bought this a couple of years ago, but have not worked with it til now
I cannot seem to get anything in the Librepilot GCS to play nice with this controller by any stretch of the imagination. I am using the Rhino GCS build, but I cannot seem to get the firmware on the FC loaded by Rescue, or any other method in the Firmware tab. Originally I did have have firmware on there, but managed to mess that up somehow. And the only reason I ended up messing around with it, was because at the end of the Vehicle Setup Wizard, I could not save my final would just time out.
I have tried hours of internet search trying to find cohesive solutions for this particular FC but nothing I do seems to work. I know this tech is way outdated already, but does anybody have any answers...1st how and WHICH firmware do I need for GCS to play nice, and how to erase and install it on the FC?
Any help would be appreciated.


  • *****
  • 4572
    • LibrePilot
Re: Mini Revolution headaches
« Reply #1 on: April 16, 2019, 01:22:19 pm »

You do no need a special firmware to load since the firmware files are already packed into the GCS.
If rescue works this mean bootloader is here and a simple Upgrade&Erase followed by a connect to the USB port does the job.

If the rescue do not work you can recover the board using DFU method.
SBL pads for RevoMini are located here :