Servos Jumping When Throttle Is Applied
« on: December 15, 2018, 06:44:48 pm »
Hello all, I recently installed a CC3D board ( this one ) into a new Volantex Ranger 1600. I was hoping to use this as a low cost stabilizer with auto level and later on add gps for RTH. I believe I have all of the basic stuff setup correctly but I'm running into some issues when checking things out on the ground. When I throttle up I start to see servo oscillations and the servos pull in one direction until the throttle is reduced. I'm powering the servos directly from the CC3D board. Should I add a BEC or something for the servos?

Re: Servos Jumping When Throttle Is Applied
« Reply #1 on: December 15, 2018, 11:30:30 pm »
First of all, CC3D cannot do GPS flight modes.  You need a Revo class FC for that.

I have both the 1200 and the 1600.

Servo oscillations and servos pull in one direction.  That could be extreme vibration, but I think it is more likely to be a bad connection or very weak battery.  Have you ever used LiPo batteries before?  LiPo should never ever be allowed to go dead or run so long that the motor slows down.  LiPo must also match size of motor that it powers or you will kill it that way.  You would not expect 8 AA batteries to start your car.  :)

Before recharging the LiPo, what are the individual cell voltages?  You can read these on the balance connector:
pin 1 (usually black) to pin 2 is cell 1 voltage
pin 2 to pin 3 is cell 2 voltage
pin 3 to pin 4 is cell 3 voltage
Set your meter to DC volts on a scale up to say 20 volts.

Easy / best is to by a lipo voltage meter / alarm.  It will read individual cell voltages.  Buy several.  $1 shipped.

Re: Servos Jumping When Throttle Is Applied
« Reply #2 on: December 16, 2018, 08:01:26 am »
TheOtherCliff , thanks for the clarification on the GPS. I measured the cells and the readings were 3.91, 3.91, and 3.92 . I tried another battery and I ran into the same behavior with the servos. The motor is the one that came on the plane, a 2212, so I think I'm good there. Do you have any other ideas?

Re: Servos Jumping When Throttle Is Applied
« Reply #3 on: December 16, 2018, 05:29:19 pm »
   I don't know if this will help, but I encountered this same problem on a basic Heli setup, and it was due to an incorrect relationship between throttle Min. and throttle Center adjustments.  Does the servo dithering always occur at the same point as you increase throttle?  In my case it was because the ESC calibration method recommended by LP will not work with Castle's Phoenix series ESCs.

Re: Servos Jumping When Throttle Is Applied
« Reply #4 on: December 16, 2018, 06:04:16 pm »
FlySky 6 channel transmitter has a problem that can cause this.  Are you using FlySky?

May be a (very) bad solder joint or badly crimped connector.

It could be electrical noise caused by BEC built into ESC.

You should not be using TPA/TPS (Stabilization->Advanced I think?) with an airplane.

Are you using the stock prop?  What size is the prop?  What KV is the motor (1500 IIRC)?  Is the battery new?  What size is the battery?

What receiver signal protocol are you using?  PPM, PWM, SBus, DSM, etc.?

PPM incompatibilities can cause the set of channels to jump by one or more so that e.g. transmitter channel 2 controls receiver channel 1 or 3 instead of 2.

Try to narrow down what is causing it.

You can run the motor up with the transmitter, but with USB and GCS also connected and watch Input page (there is a 1 second lag) to see if signals from the receiver are jumping.  You can also watch the Output page.

You can take the prop off and see if the problem goes away (vibration or electrical load).

You could (all of these):
- disconnect motor signal connector (ESC control signal connector) from the FC (this also disconnects FC power)
- connect a different 5V power source to the FC motor signal connector to power the FC
- connect a different signal source (servo tester/controller, or a 2nd RC radio transmitter/receiver) to control the motor
- Understand that the whole battery/ESC/motor is now separated from the RC radio and FC, so it is now basically impossible for the battery/ESC/motor to electrically affect the RC radio or FC.
- see if problem still happens when you use the new way of controlling the motor to run the motor up and down
- if it happens with new motor control it must be vibration (possibly affecting a bad connection).
- see if problem still happens when you use the old way of controlling the motor (which now doesn't do anything)
- if it happens with old motor control (which isn't controlling anything any more), it is a radio problem
- if neither make it happen, it is likely a problem with the ESC/BEC/5V-power (bad power of some sort)

A video might help.