hughc

  • *
  • 6
Switching to "PathPlanner" flight mode. Nothing happens
« on: October 06, 2018, 12:38:03 am »
My quad doesn't fly the Mission Planner waypoints.

The Quad flies very well.  It uses the Revolution version of a CC3d. The motors and props are from an old Blade 350QX.
The speed controls are 10amp BLHeli(no brand, just ebay).  Receiver is Redcon CM703 using Spectrum DSMX and
connected using PPM.  Using OPLink for telemetry.

Mag was a problem. Changed to 3M VHB tape for mounting the Revolution, did the "calibrate dance"  and now Mag is
fine.

Quad will sit quitely in the air when "postion hold".

To setup a Mission I do a test fly crossing the west and east ends of my clubs runway.  From the Flight Data screen
, OPMap , quad track I select the extreme east and west gps points and add them to mission planner.  Add a velocity.
Upload the mission from mission planner to the quad(Send to UAV arrow).
Settle the quad to "position hold" approximately mid club runway.
Switch to "PathPlanner" flight mode.
Nothing happens, the quad seems to slowly lower to the ground.

Previous software experience suggested reloading the Revolution.  So I saved the quad's config.  Erased and
reloaded the firmware through Librepilot.  Restored the config.  Tested, everything flies great(surprised).  Mission command
same outcome.  The quad slowly lowers to the ground.

What am I missing?  Search the forums, learned things and improved the quad.  It must be obvious what I'm doing
wrong.

Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #1 on: October 06, 2018, 05:10:39 am »
You didn't mention setting altitude.  For each waypoint, you need to set altitude in addition to speed.

Click up a few points (Ctrl-A to add clicked position as a waypoint), bring up waypoint editor and add speed (say 2m/s) and altitude (say 3m), upload to quad, take off in Attitude mode, switch to PathPlanner mode.  That's all I have to do.

hughc

  • *
  • 6
Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #2 on: October 06, 2018, 04:13:30 pm »
Yes, altitude is included.   When I add waypoints from a previous flight trail the altitude and velocity are automatically updated.     
My method is to fly the quad to the east and west ends of the runway then land.  In LibrePilot's flight data tab the OPMap displays a trail of the flight.   The east and west extremes of the trail are clicked on and "add waypoint" is selected.  The Waypoint editor  displays  the waypoint data.  By default my altitude is 15, my speed is 2.  The defaults for all the values are used.  Then  the data is sen to the quad using the arrow(Send to UAV is the tool tip).  Next, take off "stabilized".  Switch to "Position hold".  Switch to "PathPlanner".  The quad slowly lowers to the ground.  I switch back to stabilzed and land.
Are there mins for altitude and speed?

Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #3 on: October 06, 2018, 06:42:56 pm »
Home location must be set correctly.  I usually right click on the map and select "set home location".  You must supply the altitude in meters at that place if you do it that way.  If you get the altitude wrong, then your waypoints (relative to home) will be wrong.  That may be why it seems to land when you engage PathPlanner.

There is another, better way to set Home Location if it is easy to put the model at Home Location:  With model powered, connected via telemetry with a good GPS lock, and model sitting where you want the Home Location to be, in GCS go to Configuration->Attitude->Settings.  First press Clear so the coming change is obvious.  Uncheck "Is Set" (I don't think you need to press Save here to see the change to Is Set, but I might be wrong) and within a few seconds it will fill in the current UAV location into the Home Location.  Press Save to save the new Home Location.  Because I don't do this very often, I would power the UAV off and on and verify that the Home Location is stored correctly.

With model ready to fly, powered on, connected via telemetry:

I just click a place on the map where I want to go, then press Ctrl-A to add the waypoint.  You can also right click the location and select "add waypoint".  Repeat for all the waypoints I want.

Then I bring up the waypoint editor and add 3 for altitude for all waypoints and 2 for speed for all waypoints.

I usually save it to disk, but that is not needed.

I then send it to UAV.

I then take off in Attitude mode and switch to PathPlanner mode.

Be aware that the default is that it will loop to fly the set of waypoints over and over.
« Last Edit: October 06, 2018, 06:50:53 pm by TheOtherCliff »

hughc

  • *
  • 6
Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #4 on: October 08, 2018, 11:19:14 pm »
There is a delay till I can try this new setting.  I'll get back either way.  Thank you.

hughc

  • *
  • 6
Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #5 on: October 10, 2018, 11:12:16 pm »
Visited the field again with the new info.
Step one was the better way to set Home Location, using Configuration->Attitude->Settings. 
The fields were cleared but to my surprise took 5 minutes to populate.  During the 5 minutes I saw bogus  latitude and longitude as values.  That was odd.  I did a print screen, it is attached.  Powered the quad off and on. Flew a route.  Selected two waypoints for the waypoint editor.  Will attach waypoint file too.  Sent it off to the quad.
Launched in Stabilize mode, switched to PathPlanner. I did detect an initial pitch in the quad but no movement.
 

Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #6 on: October 11, 2018, 02:58:13 am »
I  believe it won't set Home Location until GPS has a good fix, the same way it won't arm until GPS has a good fix.

Are you using "GPS Navigation" for Attitude->Settings->AttiEstAlgo?  You must.  If you are using indoor one, this problem might happen.

hughc

  • *
  • 6
Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #7 on: October 11, 2018, 04:18:33 am »
My setting for Attitude Estimation Algorithm is GPS Navigation(INS 13).

Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #8 on: October 11, 2018, 07:46:25 am »
            <field name="FlightModePosition" values="Stabilized1,PositionHold,PositionHold,CourseLock,VelocityRoam,PathPlanner"/>

Do you have a 6 position Flight Mode Switch configured?  Possibly by combining two switches in your transmitter setup?

You should plug in a flight battery and USB and go to the Input page and make sure that you are actually activating PathPlanner when you think you are.  You can see that on the Input->RCInput page and also on the Input->FMSSettings page.  You should probably verify both as you flip the switch(es).

hughc

  • *
  • 6
Re: Switching to "PathPlanner" flight mode. Nothing happens
« Reply #9 on: October 11, 2018, 09:51:47 pm »
Yes, I do have six positions programed.  2 switches.
The PathPlanner mode is now on Flight mode position 3 and Flight mode position 6.  On testing, the PathPlanners Flight Mode is selected on transmitter FM position 3 and transmitter FM position 6.
This is a change since the original configuration was uploaded.