kazmod1

  • *
  • 19
  • CC3D is the best
What can be the reason of very small amplitude of the steering controls in the mode of attitude ?  For attitude I'm in range of "insane" and still not improvement !

Thanks for help.
Kaz

kazmod1

  • *
  • 19
  • CC3D is the best
I search the forum and I found the answer. In advanced tab I gave a value 100 for ail and 100 for pitch. It is only method to improve the situation. In pitch I have nothing in down direction ! Why ? A little up and almost nothing down.
Thanks for help
Kaz

Of course there are settings that do this by design:
Stabilization -> Basic: Attitude
Stabilization->Advanced: Attitude and RateMaxLimit

I have also seen this when the PIDs were too low.  Are you running stock PIDs or have you changed them?

kazmod1

  • *
  • 19
  • CC3D is the best
No, I didn't changed stock values. What values you will advice me , that probably will not be to large?

Thank you,

Kaz
Kaz

Stock values work very well.  Leave them stock.

Some other things I can think of are:
- power: if there is not enough power, then there will not be enough control.  Power can be limited by battery too small or old or not charged, motor too small, props too small or too large.
- input page settings not correct: settings that do not let the stick full motion come through
- output page settings: min should stop motor, neutral should have motors very slow, max should be full power
- ESC calibration: badly calibrated ESCs (even just one ESC) will not let a motor run to full power, and the other motors will be reduced to keep it level

I would calibrate ESCs, including setting motor min, max, and neutrals:
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/12058743/ESC+Calibration

I would re-run the transmitter wizard (Input page).

If the model is small enough, I would put a coat and glove on for arm and hand protection, and use the Output page Test Outputs to test one motor at a time to make sure that the motors can produce full power.

f5soh

  • *****
  • 4476
    • LibrePilot
Since the vehicle is a fixed wing all the Esc calibration ^^^ stuff and motors is unrelated...

1 - Be sure all the servo limits are set correctly (and symmetric) according to the mechanical ranges, as well for the neutrals.
Those settings can be adjusted easily using the wizard.

2 - Look the Wiki Attitude page describing the settings to modify for better response in Attitude mode.

Assuming the Tx is correctly calibrated and without any dual rates set and wing flies already fine in Rate mode.

Since the vehicle is a fixed wing all the Esc calibration ^^^ stuff and motors is unrelated...

Yes, of course.  Sorry.  Didn't notice that it was fixed wing when viewing "recent posts".