My quad doesn't take off anymore
« on: July 24, 2018, 07:22:47 pm »
Hi everyone,

I built my quad a week ago, CC3D, 2300KV motors, 5030 props...
It worked well for a week, taking off whenever it was supposed to.

After a crash I bought on Amazon the same props that were broken, and I mounted them the right way, and then it didn't take off.

I tried reconfigurating all the quad (librepilot wizard) and the transmitter, trying with other fully charged batteries, switching props, checking if motors spined the right way ...

I would really appreciate any answer :)

Thank you

Re: My quad doesn't take off anymore
« Reply #1 on: July 24, 2018, 07:53:24 pm »
If it seems like there is not enough power and you are sure the battery is OK, then you should rebalance your props.  Also, did you buy the same size (diameter x pitch) props and put them on right side up?  And I guess you know there are CW and CCW types that need to be put on the correct motors.

Badly unbalanced props can move the effective throttle position to the middle which means throttle above or below the middle acts like the middle.

The other issue is the battery.  If you have ever flown it till it flew weakly or wouldn't fly any more, you have damaged the battery each time you did it.  This is a common beginner mistake.

Buy a lipo alarm (buy several), plug it in to the battery balance connector and set it for 3.7v (or 3.6v) per cell.  Land when the alarm sounds.  USD $1 shipped.

Re: My quad doesn't take off anymore
« Reply #2 on: July 24, 2018, 08:38:15 pm »
Hi, thanks a lot for your answer.

Actually I tried with a lot of different batteries, all well charged (my LiPo alarm that tells me that each cell is ok).
I'm not sure if I understand what you mean by unbalanced props, but the props don't seem to make any vibrations due to a bad balance.

Thank you again for answering :)

Re: My quad doesn't take off anymore
« Reply #3 on: July 25, 2018, 12:09:39 am »
If you didn't balance the props then they are probably out of balance.  They almost always need balancing.

If you are willing to take responsibility of flying it in your hand, you can:
- connect long USB cable to GCS
- connect flight battery
- go to GCS Output page
- click the Link box (right side of page) on all motor lines, 4 for a quad
- click the Test Outputs box at bottom
- click any one of the motor sliders to "give the slider focus"
- pressing Home will stop motors
- pressing End will make motors run full speed, I REALLY don't recommend you do this with props on, instead...
- pressing left or right computer arrow key will slow down or speed up all linked motors by a small amount each press
- hold down left or right to get there quicker
- now that you understand how it works and motors are stopped, put props back on in correct locations and tighten normally
- at this point, I put on a heavy coat (protect my arm) and a heavy glove (protect my hand) and grab the quad tightly by the bottom side
- press and hold computer keyboard right arrow key for a short time to get motors running slowly
- (strong enough to lift off yet?)  press and hold right arrow key for a short time to get motors running faster
- when done, press and hold left arrow key to stop motors
- disable the Test Outputs box (no, don't Save settings)

Does it feel like it has enough lift to take off?  Way before you get to full power?  I so, you proved that it has enough power, so it is very likely that it is a prop balance problem.  Is it pulling straight up or is it trying to twist out of your hand?

One last thing to test is that you can switch your transmitter on and go to the Input page (still need flight battery) and make sure that the transmitter throttle stick makes the GCS throttle slider move all the way from one end to the other (or at least way up past where you know it had enough power to take off.  Obviously the quad must be disarmed when you are doing this...

Re: My quad doesn't take off anymore
« Reply #4 on: July 26, 2018, 03:33:28 pm »
Trying it in my hand it seemed to have enough power, but it wanted to go forward instead of upward.

I checked the transmitter, when the joystick is all the way up, the slider goes at max value.

Thank you again for your answers :)

Re: My quad doesn't take off anymore
« Reply #5 on: July 26, 2018, 05:59:31 pm »
Did you use transmitter or GCS to control the motors?  Only using GCS skips the sensors and controls the motors directly, and that says whether the sensors are part of the problem.  Also, holding it in hand and using the transmitter you are still in self leveling mode which can make it hard to see what is going on.  Also, holding it in hand and using the transmitter is still using the sensors, but your hand probably reduces vibration.  GCS makes it pull straight while transmitter makes it try to level out.