Error on GCS build
« on: April 10, 2018, 11:26:00 am »
Hi guys!
I don't know what I did but when I try to compile the GCS on Linux I have the following output at the end of the compiling phase...

Do you know what's wrong?

Fabrizio


- LibrePilot UAVObject Generator -
Invalid usage!
Usage: uavobjectgenerator [language] [-v] xml_path template_base [UAVObj1] ... [UAVObjN]
Languages:
   -gcs           build groundstation code
   -flight        build flight code
   -arduino       build arduino code
   -java          build java code
   -python        build python code
   -matlab        build matlab code
   -wireshark     build wireshark plugin
   If no language is specified none are built - just parse xmls.
Misc:
   -h or --help   this help
   -v             verbose
   input_path     path to UAVObject definition (.xml) files.
   template_path  path to the root of the source tree.
   UAVObjXY       name of a specific UAVObject to be built.
   If any specific UAVObjects are given only these will be built.
   If no UAVObject is specified -> all are built.

f5soh

  • *****
  • 4416
    • LibrePilot
Re: Error on GCS build
« Reply #1 on: April 10, 2018, 12:27:50 pm »
This occurs in your branch or in next as well ?

Re: Error on GCS build
« Reply #2 on: April 10, 2018, 02:08:48 pm »
Yes but if I do "make gcs" everything runs...
I think there is something wrong in the "QtCreator" configuration.

Re: Error on GCS build
« Reply #3 on: April 10, 2018, 03:10:54 pm »
Indeed stupid mistake!
When i pressed the green "play" button. I was running the "uavobjectgeneration" application instead of the main "app".

Fabrizio