no consigo enlazar el oplink con mi revolution
« on: March 01, 2018, 10:27:31 pm »
Hola a toda la comunidad librepilot...mi primer post una duda, como no.
bueno pues el tema que no no hay manera de que me funcione el enlace entre el minioplink y la placa revo,
ya estoy canso de leer y reeleer todas las wikis habidas y por haber y en todas dicen que si no es la misma version la placa como el openlink no funciona, he flhaseao la placa y el mini con todos los firms que he podido y siempre  el oplink se me queda en la version 4 y la revo en la 6, seguramente sea por esto por lo que no me funciona,
¿como se flasea con la misma version?  porque algo se me pasa por alto.

a ver si alguien me puede hechar un cable
y gracias de ante mano

f5soh

  • *****
  • 4337
    • LibrePilot
Re: no consigo enlazar el oplink con mi revolution
« Reply #1 on: March 01, 2018, 10:45:27 pm »
Cuando lees que tienes que haber la misma versión en cada parte es el firmware, se hace simplemente usando el "Upgrade&Erase in conectas la placa (a lo menos con el OPLink).
Versión 4 y versión 6 son la versiones del bootloader y no pasa nada que no sean iguales, simplemente las ultimas versiones para el Oplink (v4), y la Revo(v6).

A ver si puedes poner una imagen de la pantalla "Oplink" para el oplink y la placa Revo si hay un problema de configuración en alguna parte.

Re: no consigo enlazar el oplink con mi revolution
« Reply #2 on: March 01, 2018, 10:57:42 pm »
a ver si consigo enviar las imagenes

Re: no consigo enlazar el oplink con mi revolution
« Reply #3 on: March 01, 2018, 10:59:15 pm »
esas son mis configuraciones, le he dado mil vueltas a ver si consigues ver donde esta el fallo.
por cierto muchas gracias por contestar y tan rapido.

f5soh

  • *****
  • 4337
    • LibrePilot
Re: no consigo enlazar el oplink con mi revolution
« Reply #4 on: March 01, 2018, 11:32:45 pm »
Como has probado ?
Suele ser el OPLink conectado con USB y la Revo alimentada con el +5v, sin tener el USB conectado

Re: no consigo enlazar el oplink con mi revolution
« Reply #5 on: March 01, 2018, 11:59:23 pm »
A través de Google translate

Tus configuraciones me parecen correctas. Tal vez un tablero es malo. ¿Tienes alguna otra placa para probar esto?

Tal vez utilizó la página Sistema para cambiar algunas configuraciones de Revo Oplink o Oplink de Oplink. Eso podría evitar que se conecte.

No utilizaría 100mw en las pruebas porque la salida puede quemar si olvida conectar una antena. Incluso las antenas baratas deberían funcionar incluso con 1.25mw por 10 metros. Con buenas antenas obtengo cien metros en 1.25mw en la subdivisión de casa ruidosa de RF.

Con esas configuraciones y OpLink conectado GCS PC USB y Revo con la batería, debería conectarse y debería ver Revo telemetría en GCS, como si Revo está conectado a USB.

===============================

Both of your configurations look correct to me.  Maybe one board is bad.  Do you have any other boards to test for this?

Maybe you used System page to change some Revo Oplink settings or Oplink Oplink settings.  That could keep it from connecting.

I would not use 100mw in testing because output may burn up if you forget to connect an antenna.  Even cheap antennas should work even with 1.25mw for 10 meters.  With good antennas I get a hundred meters on 1.25mw in RF noisy home subdivision.

With those settings and OpLink plugged in GCS PC USB and Revo on battery power, it should connect and you should see Revo telemetry on GCS, just like if Revo is plugged in USB.

Re: no consigo enlazar el oplink con mi revolution
« Reply #6 on: March 02, 2018, 08:57:32 pm »
Como has probado ?
Suele ser el OPLink conectado con USB y la Revo alimentada con el +5v, sin tener el USB conectado

exactamente asi es como lo pruebo y nada, le he cargado y borrado el firm varias veces y lo que mas he conseguido es que la barra de señal me de algun destello de vez en cuando, se conecta y desconecta

Re: no consigo enlazar el oplink con mi revolution
« Reply #7 on: March 02, 2018, 09:04:11 pm »
A través de Google translate

Tus configuraciones me parecen correctas. Tal vez un tablero es malo. ¿Tienes alguna otra placa para probar esto?

Tal vez utilizó la página Sistema para cambiar algunas configuraciones de Revo Oplink o Oplink de Oplink. Eso podría evitar que se conecte.

No utilizaría 100mw en las pruebas porque la salida puede quemar si olvida conectar una antena. Incluso las antenas baratas deberían funcionar incluso con 1.25mw por 10 metros. Con buenas antenas obtengo cien metros en 1.25mw en la subdivisión de casa ruidosa de RF.

Con esas configuraciones y OpLink conectado GCS PC USB y Revo con la batería, debería conectarse y debería ver Revo telemetría en GCS, como si Revo está conectado a USB.

===============================

Both of your configurations look correct to me.  Maybe one board is bad.  Do you have any other boards to test for this?

Maybe you used System page to change some Revo Oplink settings or Oplink Oplink settings.  That could keep it from connecting.

I would not use 100mw in testing because output may burn up if you forget to connect an antenna.  Even cheap antennas should work even with 1.25mw for 10 meters.  With good antennas I get a hundred meters on 1.25mw in RF noisy home subdivision.

With those settings and OpLink plugged in GCS PC USB and Revo on battery power, it should connect and you should see Revo telemetry on GCS, just like if Revo is plugged in USB.

tengo dos tableros revolution con sus openlink (dos kit comprados a la vez) y los dos me dan el mismo fallo, no consigo enlazarlos,
ya estoy empezando a sospechar de mi version de librepilot, voy a probar a configurarlo con otro ordenador.

no entiendo lo de la pagina de sistema.

si, la mayoria las veces he puesto la maxima potencia 100mw siempre con las antenas conectadas y tampoco, tambien he probado a 1,6 el oplink y 50 la revo
( no se donde lo lei)

muchas gracias por sus repuestas y el interes mostrado
« Last Edit: March 02, 2018, 09:09:24 pm by mandarra »

Re: no consigo enlazar el oplink con mi revolution
« Reply #8 on: March 02, 2018, 09:11:48 pm »
o acaso hay que seguir algun orden a la hora de cargar el firm????
primero openlink y despues revo... o al reves??

Re: no consigo enlazar el oplink con mi revolution
« Reply #9 on: March 03, 2018, 04:08:58 am »
A través de Google translate

El pedido (orden de firmware intermitente o pedido de encendido) no importa.

¿Siempre has alimentado Revos y OpLinks con 5v de potencia? Algunas versiones no soportan más voltaje que eso.

¿Tal vez el OpLink es malo y los Revos son buenos?

(una prueba que creo que funcionaría). Podrías reemplazar temporalmente el OpLink con otro Revo. Asegúrate de que Revo esté configurado como lo hizo OpLink, incluido el de "OPLinkCoordinator". Conecte ese Revo a USB, al igual que OpLink. Encienda el otro Revo con una batería (a través de ESC / BEC u otra fuente de 5v) tal como lo hizo antes. No obtendrá telemetría, pero si va a la página de OpLink en el GCS, debería ver el "Nivel de RX" / "RX Level" trabajando para mostrar que está viendo el OpLink en el aire.

=====================================

Order (flashing firmware order or power on order) does not matter.

Have you always powered the Revos and OpLinks with 5v power?  Some versions cannot stand more voltage than that.

Maybe the OpLink is bad and the Revos are good?

(a test that I think would work) You could temporarily replace the OpLink with another Revo.  Make sure that Revo is set just like the OpLink was, including being set as "OPLinkCoordinator". Connect that Revo to USB, just like the OpLink.  Power the other Revo with a battery (through ESC/BEC or other 5v source) just like before.  You will not get telemetry, but if you go to the OpLink page in the GCS, you should see "RX Level" working to show that it is seeing the airborne OpLink.

Re: no consigo enlazar el oplink con mi revolution
« Reply #10 on: March 03, 2018, 12:01:31 pm »
quieres decir probar con dos revos? uno como coordinator y el otro como receiver??
me parece buena idea, voy a probar y te cuento.

Re: no consigo enlazar el oplink con mi revolution
« Reply #11 on: March 03, 2018, 01:41:16 pm »
wow, a la primera  ;) ;) ;) has tenido una gran idea theothercliff, con dos revos funciona perfecto.
eso refuerza la teoria de que con versiones distintas no funciona, como las dos revos llevan la misma version funciona.
ahora la pregunta es.... ¿donde descargo una version bl6 para el openlink? o ¿donde descargo una version bl4 para la revo? si en la wiki no estan


Re: no consigo enlazar el oplink con mi revolution
« Reply #12 on: March 03, 2018, 01:54:05 pm »
versiones

f5soh

  • *****
  • 4337
    • LibrePilot
Re: no consigo enlazar el oplink con mi revolution
« Reply #13 on: March 03, 2018, 02:00:42 pm »
Quote
¿donde descargo una version bl6 para el openlink? o ¿donde descargo una version bl4 para la revo? si en la wiki no estan
El ultimo bootloader para la revo es versión 6
El ultimo bootloader para el oplink es versión 4
Lo que necesitas ser iguales son los firmwares, no pasa nada con el bootloader actualizado normalmente en cada parte.

Puedes hacer la misma prueba con los dos OPLink, uno conectado con el PC y otro alimentado con una fuente 5v dentro de un puerto Flexi o Main, o simplemente conectado con otro PC/cargador USB.

Re: no consigo enlazar el oplink con mi revolution
« Reply #14 on: March 03, 2018, 08:27:02 pm »
Dudo que necesites un nuevo gestor de arranque en OpLink. Mi principal OpLink tiene BL # 4 en él y he ejecutado 16.09 y "next" en él.

Si aparece OpLink en la página de OpLink (las capturas de pantalla dicen que sí) probablemente tenga el firmware correcto, así que realmente parece que tiene un mal OpLink (la radio está quemada pero la CPU todavía está bien). Asegúrese de encender siempre OpLink y Revo con solo 5V, no más.

El firmware debe coincidir en todos los dispositivos y GCS y está integrado en el GCS. Parece que solo necesita actualizar el firmware en su OpLink para que coincida con el firmware en sus Revos.

Para asegurarse de tener el firmware correcto en OpLink, puede hacerlo si aún no lo ha hecho:
1 - deje desenchufado el OpLink USB hasta que se le indique que lo conecte
2 - Inicie GCS y vaya a la página Firmware
3 - presione Rescue
4 - conecte el USB OpLink
5 - presione "Actualizar y borrar"
6 - seguir instrucciones y esperar a que termine
7 - desconecta el USB OpLink
8 - conecte el USB OpLink
9 - ir a la página OpLink y configurar nuevamente

========================================

I doubt that you need a new bootloader on the OpLink.  My main OpLink has BL #4 on it and I have run 16.09 and "next" on it.

If OpLink shows up in OpLink page (your screen captures say that it does) then it probably has the correct firmware on it so it really sounds like you just have a bad OpLink (radio is burned out but CPU is still OK).  Make sure to always power OpLink and Revo with only 5V, not more.

Firmware must match on all devices and GCS and is built into the GCS.  It sounds like you simply need to upgrade the firmware in your OpLink to match the firmware in your Revos.

To make sure you have the correct firmware on the OpLink you can do this if you haven't done it already:
1 - leave OpLink USB unplugged until instructed to plug it in
2 - start GCS and go to Firmware page
3 - press Rescue
4 - plug in OpLink USB
5 - press "Upgrade and Erase"
6 - follow directions and wait for it to finish
7 - unplug OpLink USB
8 - plug in OpLink USB
9 - go to OpLink page and set up again