Nauest

  • *
  • 2
OP Link Fault
« on: February 27, 2018, 10:06:30 pm »
Hello Everyone!

I wondered if any could help, I have a new OPLink and I don't seem to be able to get it to connect to my computer or boot. I have tried replacing the firmware with the rescue feature, but I only get a green light with slow flashing blue and orange together on the OP link.

Libre Pilot GCS does not recognise it.

Have no problems connecting to my CC3D or Revolution boards with the same PC.

Any ideas?

f5soh

  • *****
  • 4337
    • LibrePilot
Re: OP Link Fault
« Reply #1 on: February 27, 2018, 10:26:54 pm »
Hi,
Can you try what happens with the following:
- Disconnect board
- Click the "Upgrade&Erase" button
- Connect Oplink and wait the flashing and erasing process.

You should get one led solid (Power) and another one blinking with a one second period (Link)

You can try also updating the bootloader attached to this post using the Rescue method and redo the firmware update like described above.
« Last Edit: February 27, 2018, 10:31:29 pm by f5soh »

Nauest

  • *
  • 2
Re: OP Link Fault
« Reply #2 on: March 06, 2018, 09:26:15 pm »
Tried all of that, I now have a slow flashing blue and yellow light and no connection.

f5soh

  • *****
  • 4337
    • LibrePilot
Re: OP Link Fault
« Reply #3 on: March 06, 2018, 09:31:36 pm »
Is the rescue process or "Upgrade&Erase" give something normal ?
What do you mean by "no connection" ?
Not able to connect both side using link or no Oplink panel displayed in config tab?