Simon

Cc3d not working properly,need help please,first quad build
« on: January 27, 2018, 02:46:11 am »
Well where do i start lol,i built my first quad and started the configuration process with lots of issues,quick rundown of my setup,gool rc radio(flysky i6),Flysky ia6b in ppm mode,blue sky cc3d power distribution board,cc3d controller,ocday 125 oneshot escs no becs,bec converter from pdb board to flight controller to power up.When i plug battery i hear a beep and motors twitch ,efcourse i have to configure,everytging powers up and receiver is binded.Escs are plugged into flight controller black negative and white positive for all 4 motors,escs are are soldered  to pdb positive and negative.bec is soldered to pdb to power flight controller and receiver.Now flight controller output wires are wired for ppm,black,red,and white on pin 8 and plug in first channel on receiver,what the heck am i doing wrong???i downloaded libre pilot,board connects only if i upgrade erase and plug usb quickly in which i googled lol.Anyhows it connects and pretty much lets me configure up to the esc configuration step,i wait for the beeps and nothing,i have done everything i can and am at a point of pulling my hair out,not sure what im doing wrong????i have radio set to ppm as well,i even went to a local hobby shop and they didnt want to help because it wasnt purchased there,aholes.please someone help me:(one week trying to figure this out

f5soh

  • *****
  • 4351
    • LibrePilot
Re: Cc3d not working properly,need help please,first quad build
« Reply #1 on: January 27, 2018, 05:06:11 am »
You should post some pictures and also your config file. File > Export UAV Settings

No need to go in all directions, first issues, one at time. Inputs, Esc calibration.

Quote
board connects only if i upgrade erase and plug usb quickly
The board do not connect in a normal way ?

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #2 on: January 27, 2018, 05:51:06 am »
Yes it will not connect in any other way ,only way is to click upgrade and erase and quickly plug usb.I also noticed when connection comes and goes when loading,however its working to some degree,in firmware tab once connected i can see pilot view and rotation moves when i move board.I will post some pics of connections and whatever is necessary tomorrow.Thanks again for the help,hopefully i get this resolved with youre expertise

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #3 on: January 27, 2018, 05:57:36 am »
Just to add i did try it on another laptop and same issue with connection,i did get a usb windows error,weird ..it was a perfectly working flight controller from another quadcopter i had.

Re: Cc3d not working properly,need help please,first quad build
« Reply #4 on: January 27, 2018, 06:03:47 am »
Try a different USB cable.  That sometimes causes problems.

Maybe you need to upgrade the CC3D bootloader?  This page also has links to troubleshooting.
https://librepilot.atlassian.net/wiki/display/LPDOC/Firmware+Tab

Also, be aware that the flysky 6 channel transmitter has some issues, but I don't think you have seen them yet.
https://www.rcgroups.com/forums/showthread.php?p=38300831&postcount=1755

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #5 on: January 27, 2018, 06:14:22 am »
Ok i will check the bootloader tomorrow as well,also my radio was a working radio on a different quad but good to know,my problem is escs not calibrating,i dont believe thats a radio issue on that step correct?

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #6 on: January 27, 2018, 06:15:32 am »
Escs are ocday 125 one shots with blheli firmware

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #7 on: January 27, 2018, 03:43:55 pm »
I gave up on the computer version,its just too many issues to resolve to get libre pilot configured on my new quad,could be computer,cable,board etc....i posted about using the playstore app to configure new quad and transmitter?any suggestions?im even willing to buy another flight controller thats easy to configure for a newbie like me,i prefer to use my android phone to configure,please help guys i keep dumping money on this quad,install and wiring is not the issue here its using a computer and configuring,like i said i prefer an android app,i appreciate all the help and suggestions

f5soh

  • *****
  • 4351
    • LibrePilot
Re: Cc3d not working properly,need help please,first quad build
« Reply #8 on: January 27, 2018, 06:10:09 pm »
Sadly an Android app will not magically resolve all the issues compared to the GCS.

Post pictures and config file.

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #9 on: January 28, 2018, 06:07:26 am »
Sorry was at work all day,tomorrow i am off and will post my issues with pics,however i came across this post on a forum,this is exactly how i have to connect to libre pilot ,only way it lets me stay connected,i did try to resolve bootloader and followed the directions and that did not fix the problem,im running windows 7,anyhows this is the post.........................................................
To cure the problem I did the following;
- connected the CC3D via USB and boot in to Libre Pilot
- confirm Libre Pilot recognozes the board as per the config tab
- disconnect the USB
- go to the Firmware tab and press "Erase & Upgrade"
- immediately plug in the the USB

The dialog in this tab changes to acknowledge that it is installing new firmware. Problem solved!!

I must say, in the course of trying to solve this problem I discovered quite a few users with the exact same issue. They get locked out of comms with the CC3D for no apparent reason yet the board's basic firmware is still functional. Very strange!

The question is - is this an obscure bug with Libre Pilot (I've never had it happen to me using Open Pilot) or the result of some kind of hardware issue brought on by variances in manufacturing from different vendors? Whatever the cause, it sure has been a royal pain trying to solve it. Wasted a lot of time in the process!

bb

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #10 on: January 28, 2018, 06:10:19 am »
I dont go thru all the steps,i click upgrade and erase and quickly plug usb back on ,it loads firmware and bingo connects

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #11 on: January 28, 2018, 06:47:29 am »
Wow i just thought of something,on configuration page system health with the boxes in rows it shows my input and output boxes in red,do you think that is why esc's will not beep and i cannot move further in configuration?im only using 3 wires from flight controller wires to ppm receiver red,black and white pin 8,what do you think?

f5soh

  • *****
  • 4351
    • LibrePilot
Re: Cc3d not working properly,need help please,first quad build
« Reply #12 on: January 28, 2018, 10:00:03 am »
Red alarms mean there is nothing configured in Input/output, looks normal after a upgrade&Erase.
Nothing configured in Outputs mean no signal.

Receiver wiring are described in this wiki page.

Upgrade&Erase will be needed at first time because the board can be flashed with other GCS version.
Later the board do not need something special for connect to the computer.

What you describe is the Manual method, this method is needed if a bad config occurs and you are locked out or with a old bootloader v3 where a v4 should be flashed.

Did you check the bootloader and look the troubleshooting page as requested ?

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #13 on: January 28, 2018, 03:33:06 pm »
Morning,yes i tried bootloader,there where a couple versions,i tried all three if i remember correctly and only one worked but problem persists,i will try again in a few minutes,how do i know what version i need?my board says 2016....and i believe bootliader said 2013...or something like that,i apologize but im not a computer guy so it takes me a bit to get things done,i use my phone to google directions,lol,i didnt grow up with computers,how can i look at what version i need for bootloader,sorry for driving u crazy

Simon

Re: Cc3d not working properly,need help please,first quad build
« Reply #14 on: January 28, 2018, 03:37:28 pm »
I ordered a new usb cable as well should be here in a couple of days.