Flightmode change makes CONFIG go red
« on: January 25, 2018, 03:46:35 am »
hello,

I finally set up my transmitter (DX7) channel 6 to by my flight mode switch. The problem is when I change Stabilized 2 or 3 to Rattitude or Acro + and save, the 'misc CONFIG and ?' turn red and I'm unable to use the quad.

The error message says something about GPS, but I don't have that on the basic board. The path it shows on the message doesn't exist in the Attitude > section.

Changing Stabilized 2 or 3 back to Attitude doesn't turn 'misc CONFIG and ?' back to green.

When this happens, the board needs to be reconfigured as if its a new setup in order to get my Flight Data all green again.

Does anyone know why this is happening?

I'm using a CC3D basic board.

f5soh

  • *****
  • 4392
    • LibrePilot
Re: Flightmode change makes CONFIG go red
« Reply #1 on: January 25, 2018, 07:09:07 am »
Hi, welcome.
There is no need to reconfigure all the board but only fix the issue.

Can you post your config file ?
File > Export UAV Settings...

Re: Flightmode change makes CONFIG go red
« Reply #2 on: January 26, 2018, 01:45:15 am »
here's the config without changing flight modes. all is green.

all green...


i only changed flight mode 2 to rattitude and CONFIG went red...


hover over CONFIG and error says:
System Configuration: Critical
- You have set up a GPS mode (poshold, RTB) to the flight mode switch, and you may have selected "basic" fusion algorithm
- Select "GPS Navigation (INS13)" in Config > Attitude Tab > Parameters > Attitude Estimation Algorithm

Well, that shit don't exist in the app as far as I can tell.


f5soh

  • *****
  • 4392
    • LibrePilot
Re: Flightmode change makes CONFIG go red
« Reply #3 on: January 26, 2018, 07:28:30 am »
Message in SystemHealt are generic and describe the most popular user errors.
What board do you use ? > A CC3D, so no INS13 and no GPS supported for Nav.
What changes are done between the Green and Red status ? > A flightMode.

Here is the issue:


Just remove the "Manual" in Rattitude stabilization line, nothing more.



Re: Flightmode change makes CONFIG go red
« Reply #4 on: January 26, 2018, 09:43:51 pm »
f5soh, thanks so much, figured it was a user error.  ;D

From the youtube vids I've been watching many have put ACRO + YAW and THRUST to MANUAL.

What do you recommend these values to be?

My goal is to start learning flips and rolls.

Re: Flightmode change makes CONFIG go red
« Reply #5 on: January 26, 2018, 09:50:01 pm »
One other question... for the Altitude line, THRUST is set to MANUAL. Why isn't that a problem and Yaw is?

If I understand correctly then ROLL, PITCH and YAW cannot be Manual... but THRUST can be Manual?

f5soh

  • *****
  • 4392
    • LibrePilot
Re: Flightmode change makes CONFIG go red
« Reply #6 on: January 27, 2018, 04:34:34 am »
Quote
From the youtube vids I've been watching many have put ACRO + YAW and THRUST to MANUAL.
This is fine, but you can keep Yaw as Rate or AxisLock.
Take a look at Acro+ page in Wiki

Quote
If I understand correctly then ROLL, PITCH and YAW cannot be Manual... but THRUST can be Manual?
Looks normal, as reported in flightmode tab. With Yaw as Manual the Yaw will be not stabilized at all, this mean without corrections maintaining heading.

Thrust as Manual is not a issue and anyways the only option using a CC3D because the board do not have sensor (baro) handling this axis.

If you want to do flips and rolls for first time you should consider using the Rattitude stabilization.