Take off problem
« on: December 11, 2017, 02:58:09 pm »
Hi,

I'm aware this topic has been discussed many times in the past but I haven't found a solution and it drives me crazy.

I have a quad with Revo + GPS + Mag. I finally got it to fly really nicely with INS13. I can now fly Velocity Roam and it's great. I also auto tuned it and he is very stable, the hires video looks nice, without wobbling or snake effect.

So, what's the problem you're asking. Well, take off is the problem. After power up, as soon as I apply a little thrust, it goes crazy, overturn, etc. The second time is better and typically after 3 attempts, it starts quietly and I can take off. I tried everything! After power up, I turn it in all direction to zero the gyro, I arm and disarm it, then turn it in all direction and arm again, etc. nothing helps. I tried auto takeoff, nothing, it goes crazy, only after 3 or 4 attempts, it managed to take off properly. Of course, each time it goes crazy, it damages the propellers  >:(

I read about micro vibrations etc. but couldn't find what's wrong. The fact is that after a few attempts, it calms down and starts nicely. Why can't it do that immediately. What setup can improve this behaviour?

Thanks for you help!

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #1 on: December 11, 2017, 05:42:05 pm »
Issue still is you take off in Basic Complementary fusion algorithm ?
Post your config file.

Re: Take off problem
« Reply #2 on: December 11, 2017, 08:21:51 pm »
You should use INS13.

You should have a Flight Mode Switch with at least Attitude mode and VelocityRoam mode.

First flight of the day you should let GPS warm up for 12 minutes before first flight.  After that, 2 minutes is OK, and I sometimes only wait 1 minute.

You should take off in Attitude mode, not VelocityRoam.  GPS drift accululates while it sits on ground and makes it think it immediately needs to move to a different place while lifting off in VelocityRoam mode.

You should have Stabilization -> ZeroTheIntegral* ENABLED.

You should take off from level ground immediately after starting motors.

You should immediately jump up to knee high; do not slowly increase throttle.

Do all of these things just one time and you will see that it works well and do it this way every time...

Re: Take off problem
« Reply #3 on: December 11, 2017, 09:05:45 pm »
Hi,

Thanks for the reply.

1. I use INS13
2. I check the number of satellites before I take off, it's typically around 9 or 10. I admit I don't wait 12 min but I assume the almanac is in memory if I fly every day.
3. I take off only in Attitude mode with Stabilized1. I tried AutoTakeOff, doesn't help.
4. Stabilization -> ZeroTheIntegral was disabled. I enabled it and I cross my fingers. Tomorrow we'll know  :)

I'm attaching my config file.

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #4 on: December 11, 2017, 09:51:41 pm »
You should redo Mag calibration, looks pretty asymmetric.

Re: Take off problem
« Reply #5 on: December 11, 2017, 10:33:02 pm »
Mag calibration is a bitch, no matters how many times I do it, it's never perfect. I tried outside, far from magnetic fields, I used a compass to find the north, etc, it's really difficult to do it. At least as it is I can fly. I'll try again!

Thanks!

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #6 on: December 12, 2017, 12:12:54 am »
No need a known North heading for Mag calibration, you just need to cover all the 3D space measuring mag vector and do it blindly.

Start the Mag calibration, hit the button for the first five steps and try the "Mag dance". Finally click for the last step and save.


Since you start the calibration, mag reading are recorded so you shouldn't start with a magnetic material too close like gimbal, lipo saver or buzzer.

Re: Take off problem
« Reply #7 on: December 12, 2017, 10:15:23 am »
Finally, it works!!!

Thanks TheOtherCliff, ZeroTheIntegral* ENABLED was the solution. I have read that somewhere in the past but didn't make the connection to my problem.

Question, would you recommend AutoTakeOff?

f5soh, can you point me to the lines in the config file showing Mag calibration symmetry? I'd like to understand this part better so when I calibrate the mag I can check it myself.

Thank you all for the quality feedback and help. I 3D printed my quad based on a Blackout 330 design with my modifications. I'll post some pictures.

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #8 on: December 12, 2017, 10:31:57 am »
Finally, it works!!!
Thanks TheOtherCliff, ZeroTheIntegral* ENABLED was the solution. I have read that somewhere in the past but didn't make the connection to my problem.

Strangely in config file you posted the LowThrottleZeroIntegral was already enabled
Code: [Select]
<field name="LowThrottleZeroIntegral" values="True"/>
Look the AuxMagSettings in UAVOBrowser, the mag_transform value will be almost the same.
With your calibration you can see 0.92, 0.89 and 1.02, this big difference highlight while calibrating you didn't rotate around all axis to cover all the 3D space. Especially with the AuxMag not disturbed by other objects around, this shouldn't happens.

Code: [Select]
<object name="AuxMagSettings" id="0xC380EF60">
            <field name="mag_bias" values="-103.296005,114.908028,-37.1961594"/>
            <field name="mag_transform" values="0.9263888,0,0,0,0.894628227,0,0,0,1.02042007"/>

Re: Take off problem
« Reply #9 on: December 12, 2017, 11:04:35 am »
Thanks f5soh!

Nothing strange, I posted my config file after enabling LowThrottleZeroIntegral.

I will redo my mag calibration and check these values.

What about AutoTakeOff, would you recommend I use it?

Thanks!

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #10 on: December 12, 2017, 11:28:17 am »
If manual take off works, the auto take off will work as well but cannot magically correct issues better than you.



Re: Take off problem
« Reply #11 on: December 13, 2017, 05:25:44 pm »
When you switch into a GPS mode it grabs the current GPS coordinates.  If the GPS has drifted by the time you try to take off, it thinks it needs to go sideways to get to where it should be.  So you need to minimize GPS drift.  That means let GPS warm up well (edit: before switching into final GPS mode) (to reduce drift rate) and take off immediately after switching into that GPS mode (reduce the time that it has to drift).

Be careful of this with VelocityRoam and other GPS modes.  It is possible that AutoTakeOff handles this differently, but I would assume not until proven otherwise or someone tells you.
« Last Edit: December 13, 2017, 08:52:45 pm by TheOtherCliff »

f5soh

  • *****
  • 4111
    • LibrePilot
Re: Take off problem
« Reply #12 on: December 13, 2017, 08:31:47 pm »
There is no issue you describe with autotakeoff since the current GPS position in picked just when the autotakeoff sequence is initiated and vehicle take off automatically just after.