Re: Moving from OP to LP
« Reply #15 on: December 01, 2015, 05:07:29 pm »
Thanks Cliff.

Here is the board inside the GPS Module.  The wire colors and connections are clearly visible. 

The GCS shows the GPS working properly having acquired 7 sats of 15 visible within a minute.  Will play with it in flight shortly.

Thanks again.

Re: Moving from OP to LP
« Reply #16 on: December 01, 2015, 09:41:11 pm »
Get SCL SDA connected to another standard OP connector (JST-SH 1.0mm) with SCL=pin3 and SDA=pin4 and you can use the mag that is built in these units with the next LP release.  :)

gitit20

  • *
  • 53
  • If it will fly I will crash it.
Re: Moving from OP to LP
« Reply #17 on: December 07, 2015, 04:59:50 am »
Looks like now that OP forums are down I will be spending a lot more time here. did you ever figure out why the gps mode would osculate when facing certain directions I could never figure this out.
Do the best you can It's all you can do.

Re: Moving from OP to LP
« Reply #18 on: December 07, 2015, 05:19:00 am »
No, but there are at least a couple users here that report a similar oscillation when using GPS and stopped (a little stick to make VelocityRoam move and the oscillation stops).  I've asked them to test if it happens at different compass directions, but I haven't seen and answer pop up on my summary yet.

Could you test if yours happens in VelocityRoam (or Attitude with GPS Assist) and goes away if you move the stick a little to give it motion?

gitit20

  • *
  • 53
  • If it will fly I will crash it.
Re: Moving from OP to LP
« Reply #19 on: December 07, 2015, 05:30:29 am »
I need to reset up everything I got so piseed that op died and could never figure this out I now have a cleanflight board installed I will try to do some more testing but I do remember it was with GPS assist or also just plane ole position hold as well.




No, but there are at least a couple users here that report a similar oscillation when using GPS and stopped (a little stick to make VelocityRoam move and the oscillation stops).  I've asked them to test if it happens at different compass directions, but I haven't seen and answer pop up on my summary yet.

Could you test if yours happens in VelocityRoam (or Attitude with GPS Assist) and goes away if you move the stick a little to give it motion?
Do the best you can It's all you can do.

lanzi

  • *
  • 53
Re: Moving from OP to LP
« Reply #20 on: December 07, 2015, 06:07:40 am »
Hi Cliff,
regarding the Oscillations in different directions. I answered this in the original thread. Yes the Oscillations differ quite dramatically depending on compass directions.

.........Hi TheOtherCliff,

that is exactly the case. i am doing my testflights within a radius of 10 km. some places are close to the shore and water and some are smack in the middle of a suburb. I noticed when hover in gps assist mode with the quad facing south the oscillations are at a minimum. when i yaw slowly 180 degrees so that the quad is facing north the oscillations are a much worse by a huge amount.. it is exactly as you described. this happens in GPS Assist and in Velocity Roam

I just do not know where to look anymore.

i started from scratch yesterday with default PID settings after i flashed  a fresh 15.09. on my board.  same thing it is oscillating in gps assist, velocity roam, pos hold and rth

do you have think this is a bug or do you think this can be dialed out by changing values somewhere.

cheers
lanzi............


No, but there are at least a couple users here that report a similar oscillation when using GPS and stopped (a little stick to make VelocityRoam move and the oscillation stops).  I've asked them to test if it happens at different compass directions, but I haven't seen and answer pop up on my summary yet.

Could you test if yours happens in VelocityRoam (or Attitude with GPS Assist) and goes away if you move the stick a little to give it motion?

gitit20

  • *
  • 53
  • If it will fly I will crash it.
Re: Moving from OP to LP
« Reply #21 on: December 07, 2015, 09:32:11 am »
It's very frustrating....

Hi Cliff,
regarding the Oscillations in different directions. I answered this in the original thread. Yes the Oscillations differ quite dramatically depending on compass directions.

.........Hi TheOtherCliff,

that is exactly the case. i am doing my testflights within a radius of 10 km. some places are close to the shore and water and some are smack in the middle of a suburb. I noticed when hover in gps assist mode with the quad facing south the oscillations are at a minimum. when i yaw slowly 180 degrees so that the quad is facing north the oscillations are a much worse by a huge amount.. it is exactly as you described. this happens in GPS Assist and in Velocity Roam

I just do not know where to look anymore.

i started from scratch yesterday with default PID settings after i flashed  a fresh 15.09. on my board.  same thing it is oscillating in gps assist, velocity roam, pos hold and rth

do you have think this is a bug or do you think this can be dialed out by changing values somewhere.

cheers
lanzi............


No, but there are at least a couple users here that report a similar oscillation when using GPS and stopped (a little stick to make VelocityRoam move and the oscillation stops).  I've asked them to test if it happens at different compass directions, but I haven't seen and answer pop up on my summary yet.

Could you test if yours happens in VelocityRoam (or Attitude with GPS Assist) and goes away if you move the stick a little to give it motion?
Do the best you can It's all you can do.

Re: Moving from OP to LP
« Reply #22 on: December 07, 2015, 12:58:02 pm »
I've started a thread that everyone can read.
It includes some things we can try, and after we have tried them, I will open a bug report.
https://forum.librepilot.org/index.php?topic=382.0

hicky

  • *
  • 3
Re: Moving from OP to LP
« Reply #23 on: March 16, 2016, 11:09:41 pm »
I'm still slightly confused.

We can use i2C on flexi for external mag in 15.09?

Or is this only possible in 16.01?

Many thanks.

I have it all wired up but still can see it in auxmagsettings to select i2c

hwh

  • *
  • 1018
Re: Moving from OP to LP
« Reply #24 on: March 16, 2016, 11:19:57 pm »
No, external I2C mag will be supported in the next release, which will be 16.  It's currently in the next branch if you want to compile the software yourself.

hicky

  • *
  • 3
Re: Moving from OP to LP
« Reply #25 on: March 16, 2016, 11:37:10 pm »
Ahh thanks that clears it up. Dependent on where you ready it can be interpreted differently.

I think compiling might be more than I can deal with. Is there any release date pencilled in?


hwh

  • *
  • 1018
Re: Moving from OP to LP
« Reply #26 on: March 16, 2016, 11:56:04 pm »
I haven't heard any talk of when the next release will be.  I think it has more to do with getting features they want in the release working correctly than an actual hard target date.