Lucky

  • *
  • 12
Latest developemnet download will not compile for me.
« on: September 25, 2017, 08:57:11 pm »
After hacking at the code to get the antenna tracker working, I cloned the code (git clone https://bitbucket.org/librepilot/librepilot.git) again to start fresh, and am now unable to compile it. I get the following error message.
  Reading C:/msys64/home/bdiffendaffe/librepilot/ground/gcs/src/libs/gstreamer/gstreamer.pro [C:/msys64/home/bdiffendaffe/librepilot/build/librepilot-gcs_release/src/libs/gstreamer]
Project MESSAGE: Using python interpreter: "python"
WARNING: headers.path is not defined: install target not created

Project ERROR: gstreamer-app-1.0 development package not found
mingw32-make: *** [Makefile:296: C:/msys64/home/bdiffendaffe/librepilot/build/librepilot-gcs_release/Makefile] Error 3

Is the build broken?
What am I missing?

Thanks, Lucky
Lucky

f5soh

  • *****
  • 3923
    • LibrePilot
Re: Latest developemnet download will not compile for me.
« Reply #1 on: September 25, 2017, 09:59:18 pm »
Quote
What am I missing?

Project ERROR: gstreamer-app-1.0 development package not found

You can find the answer into the latest commit:
https://bitbucket.org/librepilot/librepilot/commits/d9cce5e0d9b964906aa8c025263601eb2643c46a

or here

Lucky

  • *
  • 12
Re: Latest developemnet download will not compile for me.
« Reply #2 on: September 28, 2017, 11:03:25 pm »
I ended up just reinstalling the entire development package and LibrePilot compiles just fine now.
Now that I think about it, it makes perfect sense.... :)
Lucky