Thomas

  • *
  • 9
My FC disarms after a few seconds ?!
« on: September 24, 2017, 06:56:21 pm »
Hey guys!
I need your help. I am building my first plane with a cc3d-Revolution-board and everything is working like it should, as long as the USB is connected to my PC. When I try to use it only with the battery, I can arm but the motor stops after a second of running. When I only move the servos, they stop too after a time.
When it stops I have to wait a few seconds, then I can arm again to have another few seconds ;-)

I use no PowerDistributionBoard. The power for the FC and the four servos comes from the BEC of the 60A SkyWalker BEC (3A). It feels like the BEC is the reason for the problem. What do you think?
I am happy about any advice :-)

Best regards from Germany
Thomas

Re: My FC disarms after a few seconds ?!
« Reply #1 on: September 24, 2017, 10:55:31 pm »
Input -> Arming
Set the disarm timeout to the value you want.  :)

f5soh

  • *****
  • 4063
    • LibrePilot
Re: My FC disarms after a few seconds ?!
« Reply #2 on: September 25, 2017, 12:13:12 am »

Look tooltip for arming timeout.

Assuming you use a fixed wing the best option is set the timeout to "0".
This mean the board do not disarm automatically after a timeout but disarm only using the switch or the opposite movement for a arming stick.


Thomas

  • *
  • 9
Re: My FC disarms after a few seconds ?!
« Reply #3 on: September 25, 2017, 07:52:55 am »
The timeout is set to 0 :(
Another thing that happens is, the Oplink disconnects when the motor stopps. When its reconnected I can arm again.

Gesendet von meinem ALE-L21 mit Tapatalk


Re: My FC disarms after a few seconds ?!
« Reply #4 on: September 25, 2017, 08:53:07 am »
Look on the Firmware page at the FlightTime.  It counts up in seconds the time since the FC was powered up.  If it resets back to zeroish when the FC "disarms" then the FC is actually rebooting.

Do you have a GPS / aux mag?  Is the aux mag an I2C version (one cable for GPS and a second cable for aux mag)?  If so, disable aux mag on Hardware page to see if the issue goes away.  Adding pullup resistors in the GPS / aux mag is the real fix.

Thomas

  • *
  • 9
Re: My FC disarms after a few seconds ?!
« Reply #5 on: September 25, 2017, 09:05:34 am »
Yes! Thank you :)
The FlightTime resets to zero and the the Oplinks are 'unlinked' ...the thing reboots.
It seems like the power is breaking down.

I havent connected the GPS or a mag yet.

f5soh

  • *****
  • 4063
    • LibrePilot
Re: My FC disarms after a few seconds ?!
« Reply #6 on: September 25, 2017, 07:00:49 pm »
Seems you Esc with 3A (UBEC ?) provides enough power for all the servos you have, especially if plane sit on ground and servos do not have any torque needed.

You can measure the output voltage and see if still ok around 5V while servos working.

Just as a test, change OPLink power to minimal (1.25mW) in both sides.

Thomas

  • *
  • 9
Re: My FC disarms after a few seconds ?!
« Reply #7 on: September 26, 2017, 06:36:35 am »
I ordered a 5A SBEC now.
Next Sunday I am going to do more experiments. I will report what happend. :)

Gesendet von meinem ALE-L21 mit Tapatalk
« Last Edit: September 26, 2017, 06:47:14 am by Thomas »

Thomas

  • *
  • 9
Re: My FC disarms after a few seconds ?!
« Reply #8 on: September 28, 2017, 09:44:37 am »
Today I had a little time to test the new 5A SBEC. I took off the red cable from the old 3A UBEC first...

Its working now! *jipii*