Micro miniosd issue
« on: September 12, 2017, 10:26:11 am »
Hello, I'm having some trouble using a generic micro miniosd board and a cc3d FC:
1. using fw ver. 1708 and following instructions from MinOPOSD setup, I get "no tel com" and "link quality", (no reaction to the FC board movement);
2. using fw. ver 1.6.0.8 and following instructions from MWOSD setup, is working (react to the FC board movement) but the indications are not centered (some elements are missing).
Any ideas?
Thanks!

P.S. Similar board and miniRevo FC board works OK.


f5soh

  • *****
  • 3923
    • LibrePilot
Re: Micro miniosd issue
« Reply #1 on: September 12, 2017, 11:58:06 am »
1) Board do not receive telemetry, can be a bad wiring or board connected to USB and telemetry goes to USB instead of Mainport/FlexiPort.

2) Centering can be due to a bad NTSC/PAL setting, can you list the missing elements ?

Re: Micro miniosd issue
« Reply #2 on: September 12, 2017, 02:09:02 pm »
1) I'll check, is possible.
2) I'll take a picture.  :)
Thanks for answers.

later edit
I'd checked, no difference in case 1), same setup is showing reaction with MWOSD version.
Attached a movie, looks like is receiving something in case 1).
« Last Edit: September 12, 2017, 11:38:03 pm by TheOtherCliff »

f5soh

  • *****
  • 3923
    • LibrePilot
Re: Micro miniosd issue
« Reply #3 on: September 12, 2017, 02:31:01 pm »
MinOPOSD need MainPort or FlexiPort configured as Telemetry @57600

Re: Micro miniosd issue
« Reply #4 on: September 12, 2017, 02:41:01 pm »
Yes, I know, it is configured like that.

Re: Micro miniosd issue
« Reply #5 on: September 14, 2017, 02:24:15 pm »
I re-flash with 1.6.8. MWOSD, configured PAL instead of NTSC (default), and it's working OK,
now the only thing that is not OK is an orange warning on memory of the board (CC3D).
Still no resolution on mini OPOSD, yet. That's strange. I'm forgetting something for sure.
« Last Edit: September 14, 2017, 02:34:00 pm by octavvian »

Re: Micro miniosd issue
« Reply #6 on: September 15, 2017, 10:16:21 pm »
I re-flash with 1.6.8. MWOSD, configured PAL instead of NTSC (default), and it's working OK,
now the only thing that is not OK is an orange warning on memory of the board (CC3D).
Still no resolution on mini OPOSD, yet. That's strange. I'm forgetting something for sure.
So, MEM warning (orange) is normal when using MSP protocol for telemetry (miniosd) on a "generic" CC3D?
Thanks!

f5soh

  • *****
  • 3923
    • LibrePilot
Re: Micro miniosd issue
« Reply #7 on: September 15, 2017, 10:20:58 pm »
yes, "normal" or expected according to the MSP memory usage.

Re: Micro miniosd issue
« Reply #8 on: September 16, 2017, 10:44:46 pm »
Thanks for answer.

Re: Micro miniosd issue
« Reply #9 on: October 02, 2017, 06:15:17 pm »
MinimOP OSD issue (1.) solved by downgrading from next to 16.09 firmware.
« Last Edit: October 02, 2017, 10:50:53 pm by octavvian »