Joffrey

  • *
  • 10
Throttle problem, 0 to 100% instantaneously ... Resolved !
« on: August 23, 2017, 03:46:07 am »
Hello,

I'm new with openpilot, and sorry for my english :)

I have a FlySky i6 and fs-r6b with CC3D for my Falcon 250. All the configuration procedure was done 2 times

I can manage to arm the quad with "Yaw right", but when I use the throttle, it seems do be 0% to 100% instantly, it's not exponential like on my tinywhoop...

When i'm in test mode, I can manage to setup the "mini", and all is allright exponential.

If you have any idea to solve my problem, it will be very appreciated :)

Thanks a lot !

Joffrey
« Last Edit: September 14, 2017, 07:56:30 pm by Joffrey »

Re: Throttle unexponential ...
« Reply #1 on: August 23, 2017, 05:00:59 am »
This is usually because you didn't do transmitter wizard correctly.  You must move all sticks through full range when told to.

There are a few other possible reasons too.  Is this a powerful quad or a weak quad?  Have you calibrated ESCs and set motor neutrals?

f5soh

  • *****
  • 3874
    • LibrePilot
Re: Throttle unexponential ...
« Reply #2 on: August 23, 2017, 12:02:56 pm »
Rc input side looks fine and calibrated correctly.

- Verify if Throttle curve is default +-100% in Vehicle tab, use "Default" button if needed.

- If the option is not checked, revert the Stabilization > Basic > "Zero integral when Throttle is low" (bottom) to Checked, as default.

Joffrey

  • *
  • 10
Re: Throttle unexponential ...
« Reply #3 on: August 24, 2017, 12:18:07 am »
Thanks but it doesn't work  :'(

When I setup the ESC, do the bips must end ?
I have wait maybe 2 minutes before following the setup because I have always the bips of the ESC...
bip bip.... bip bip bip.... bip....

After this I have setup the motors one by one.

And finally, max and min range are ok. I have done the setup one more time without problem. I have just to reverse the pitch to be in the right direction.

I have tried the first part of this setup without more succes.. https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/12058743/ESC+Calibration

Thanks for your help
« Last Edit: August 24, 2017, 12:48:44 am by Joffrey »

f5soh

  • *****
  • 3874
    • LibrePilot
Re: Throttle problem with esc ...
« Reply #4 on: August 24, 2017, 01:19:31 am »
If Esc still beeping that maybe Esc allow programming mode.
If you calibrate with high level, connect battery and move to low level just after the first beep the continuous beep should not happens.

Can you test the outputs (remove props) and look how the motors react while changing output value ?


Joffrey

  • *
  • 10
Re: Throttle problem with esc ...
« Reply #5 on: August 24, 2017, 01:23:40 am »
Yes in test mode all works fine.

In this setup, how to recognize the bip sequence ? ^^
when I do it I have changements of beeps, but I don't know if it's good or not...

"10 - Enable "Test Outputs" (and read the caution pop-up).
11 - Click on one of the ESC sliders to give it focus.
12 - Press End key to max all ESC's.
13 - Plug in flight battery to power the ESC's
14 - Wait just for first beep and immediately press the keyboard Home key.  There are two beep sequences.  If you wait too long you will hear the second set of beeps and must immediately unplug flight battery and start over (or risk changing some ESC settings on some ESC's).
15 - You should hear a set of confirmation 'calibration done' beeps that ESC's are programmed.  Listen carefully.  You might get for instance only 3 of 4 motors done correctly.  You can tell that the beeps are all the same (good) or some are different (bad).  After you have done this a few times, you can tell that it is correct by the beeping "calibration done" beeps."

Edit :
I have found the manual, tryed to setup, I have differents beeps like on the manual, and my problem is still here :(
« Last Edit: August 24, 2017, 03:03:27 am by Joffrey »

Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #6 on: August 24, 2017, 04:52:53 am »
Unplug ESC/servo connectors and plug the battery in.  Are the beeps the same?  If they are then the ESC is not getting a signal that it recognizes.  Maybe you had the connectors upside down?

If you ran setup wizard, then maybe you selected an incompatible ESC signal method.

Did you try to follow instructions on ESC calibration and neutral setting?
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/12058743/ESC+Calibration

Maybe ESC signal is reversed so that high is low and low is high.  ESC does not allow start up at high throttle.

Some fixed wing ESCs are not usable because they require you to go low throttle, high throttle low throttle at the beginning of each battery.
« Last Edit: August 24, 2017, 04:56:37 am by TheOtherCliff »

Joffrey

  • *
  • 10
Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #7 on: August 26, 2017, 09:25:03 pm »
i'm back after lots of tests.
I have understand the setup of esc, and it works, but, i can drive only one...
My esc are Fairy 20A. I have seen on their website that they support oneshot125... So I have tried to configure like this and it doesnt work better.
I can manage 0 to 100% in test mode without any problem, so I think it's just in the setup, but where...

Joffrey

  • *
  • 10
Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #8 on: August 27, 2017, 04:09:51 am »
Test n ° 893848 check!

So I think my problem comes from my accelerator.
I've tried about everything, and the only way I've found is to set up my accelerator in log curve...
Like that, I have something like a steady acceleration.

It's not perfect, but it's flying! it flies with some "hics" though. it does not maintain itself perfectly, it seems that the controller tries to compensate the acceleration without reaching it fully.

Some idea ? :)
« Last Edit: August 27, 2017, 04:16:28 am by Joffrey »

Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #9 on: August 27, 2017, 06:56:56 am »
Are you sure your transmitter is sending everything plain without modification?

You should set your transmitter aircraft model to acro (stunt airplane), not heli or glider or ...
This should be plain, unmodified, uncurved, unmixed...
You can test this by plugging a servo into each receiver channel and making sure it acts simple, plain, linear.

Are your props balanced?  (really... :) )

You could save your current settings (File -> Export UAV ...) (so you can get back to them) and erase settings and start over.
« Last Edit: August 27, 2017, 07:17:43 am by TheOtherCliff »

Opps

  • **
  • 94
Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #10 on: August 27, 2017, 07:07:57 am »
What type of rx protocol are you trying to use? With a cc3d with oneshot enabled you have to use ppm or sbus or something like that on pin 8 maybe. Look it up in the wiki  under configuration for cc3d hardware. It has something to do with space available with the fc. Just something i read a while ago. Check it out

Joffrey

  • *
  • 10
Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #11 on: August 28, 2017, 12:12:30 am »
I have found some PID for my 250 and it works not bad with the throttle!
I have made a video to show you my  new problem ^^

I accelerate just very slowly and suddenly, it does this..

I have motor mounts with 10% degrees, do I need to add 10% compensation in openpilot before flying ?
I can't remove them right now because I don't have the goods screws... I don't care if my quad can't stabilized in the air, I just want to fly :)
I have learned quad driving with my tiny whoop, so I'm not totally a newbie ^^
« Last Edit: August 28, 2017, 05:09:51 am by TheOtherCliff »

Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #12 on: August 28, 2017, 05:16:49 am »
Either your PIDs are too high or your FC is rotated (arrow should be forward and ESC connectors on right side).  Or you are not running a high speed ESC protocol on ALL ESCs.  Output page.  Make sure all banks that talk to an ESC use the same high speed update rate.  At least PWM-490.

Does it seem that it oscillates in roll?  Then it would be roll PID...

If it is rotated, you can fix it with Attitude -> RotateVirtual
https://librepilot.atlassian.net/wiki/spaces/LPDOC/pages/2818092/CC+Attitude+Configuration

mr_w

  • *
  • 124
Re: Throttle problem, 0 to 100% instantaneously ...
« Reply #13 on: August 29, 2017, 02:50:30 am »
This quad has lifted correctly and did fly good for about two seconds, and then it just did flip like you intended to do the flip but were too close to the ground. What kind of input did you give it? Did you try going left?

Which flight mode did you use? It almost looks like it was rate on all axes and you weren't prepared for for it :) Or if it was rattitude, maybe you just gave it a bit too much input and it went into rate, giving you nice surprise.



Re: Throttle unexponential ...
« Reply #14 on: August 31, 2017, 03:33:49 pm »
Rc input side looks fine and calibrated correctly.

- Verify if Throttle curve is default +-100% in Vehicle tab, use "Default" button if needed.

- If the option is not checked, revert the Stabilization > Basic > "Zero integral when Throttle is low" (bottom) to Checked, as default.


Thank you.  Found this via a search and it solved my problem.   I haven't hooked my quad up to Librepilot in almost 2 years.  Finally did to change some settings and I did an update and stupidly erased everything and had to start from scratch.  For some reason "Zero Integral when throttle is low" does not default to being checked off when I load a profile from scratch.

I spent 2 days pulling my hair out trying to figure out why the throttle was acting "strange" until I read this post. Didn't see it because of it's location at the bottom of the tab and having to scroll down to it. Checked the box, reloaded, and was back to flying like normal.

I did test by reloading a spare board with a base profile, and it loads up with an unchecked box for the several I tried.