motors won't spin up on Librepilot
« on: July 25, 2017, 08:58:18 am »

I have been using CC3d boards and Librepilot for a while on various quads with no problems, using Walkera Devo 10, PWM.  I recently purchased a KingKong hex which was pnp.  I had an Flysky tarnsmitter and FS-IA6B, so decided to use them on the hex.  The motors will not spin up on Librepilot at calibration.  I have tried every know combination of plugs in the CC3D Atom and the receiver.  When I connect the board, the ESC's beep, and again, when I press stop, they all beep again.  The transmitter is not being detected.  This obviously has something to do with the connections on the receiver and FC.  I have tried using Cleanflight, and all the motors spun up on that system, but the motor numbering was totally different, and I couldn't work out how to change the motors around, as they are all soldered on to the escapes, and the wiring was too difficult to alter, hence going back to the system I know well ... Librepilot.  I cannot for the life of me, work out why the motors will not spin up, when the ESC's all beep.  Any help would be appreciated, as I would like to use this transmitter with PPM and Ibus.  I guess I can go back to the Walkera if there is no other solutions. thanks Dave.


  • *
  • 808
Re: motors won't spin up on Librepilot
« Reply #1 on: July 25, 2017, 09:30:51 am »
You have to calibrate ESCs and set neutral point (unless you use Dshot).
Manual way is set 1000, 1500 and 2000, then turn all channels to max, plug battery, wait for beeps, turn sliders to min, wait for beeps, disconnect battery.
Wizard does the same thing, but just steps you through these and gives you instructions. I would suggest following wizard.
Also you have to check what protocol does your ESC support. Try OneShot125 or RapidPWM if unsure. If you have wrong protocol the ESCs wont be calibrated properly or won't receive valid signal to spin the motors. Cleanflight is a way different software, so when you change to something else, you are likely to also change some settings, which is my it may work on another, but principles are the same. You are not configuring something as it should be. ESCs should only beep at start, when you plug battery, if the beep continues it means ESCs are not receiving valid signal. Also there are aforementioned beeps like music which are when you set max before plugging battery, and they indicate bootloader and calibration mode. There is also bacon (iddle) beep which triggers after 5-15min depending on setting and reminds to unplug battery if you're not flying.
Also check that output channels marked together with the same color, are the same protocol. These are hardware limitations, and if color spans two channels, they should use the same protocol.
Nothing more comes to my head now, but I hope it helps a bit.

If you have still problems post your UAVconfig file exported from GCS. Maybe then other ppl can spot the mistake.

Re: motors won't spin up on Librepilot
« Reply #2 on: July 25, 2017, 04:30:28 pm »
You can't use 1000,2000 with PwmSync which runs at 500hz.  It is less confusing to simply calibrate ESCs at 1000,1900.

With USB alone the RC receiver does not get powered.  You must plug in the flight battery.

I would first prove that the RC is bound and working by plugging a servo (or esc/motor/battery without prop) in to the receiver.  Make sure that all ports are working.  Even a single needed port of the 5 not working will shut it all down.

I would plug USB in with it ready to fly and see what system health may be bad.

A common problem is that it must be armed and people forget to press save after setting the arming option.  How do you have Input->Arming set?  With USB connected and flight battery in, you can go to Input->RC page and see the sliders move when you move the sticks.  Make sure that everything is working and that throttle and your other arming stick have full range so that it will arm.  Having a dual rate switch set to low rate will keep it from arming.

Re: motors won't spin up on Librepilot
« Reply #3 on: July 28, 2017, 12:05:57 am »
Ok, I have manually calibrated the motors using the config settings, and they all calibrated and spun up when I used the sliders.  I saved this, then set arming and saved.  I have confirmed that the receiver is working by plugging a servo into channel 4. I still cannot arm the hex.  The throttle is set at minimum trim, and the yaw at no trim.   The transmitter is working ok on 4 channels in the transmitter setup wizard, tho I can't get the aux switches to be seen.  Also, if I attempt to use the wizard to calibrate the motors they will not spin.  They will only spin if I calibrate manually. 

Re: motors won't spin up on Librepilot
« Reply #4 on: July 28, 2017, 12:59:46 am »
Go to input page and get all your configured inputs working.  If even one doesn't work (no signal) it won't arm.

What does system health say?  Is everything green?  Is the health input orange perhaps?

Re: motors won't spin up on Librepilot
« Reply #5 on: July 28, 2017, 04:54:25 am »
Hi, Cliff

I have done what you suggested.  All the inputs (I only have the four, aux channels  are disabled)  seem to be working, although movement of the sliders on screen the seems to be a bit slower than my stick movements.  When I move the yaw stick to the right (this is how I have arming setup) setup tells me that the hex is armed.  I have just disconnected it from GCS, and for some reason, it appears to be arming, and all motors spinning in right direction.  Dunno what I did, but thanks for all your help

regards Dave.

Re: motors won't spin up on Librepilot
« Reply #6 on: July 28, 2017, 05:31:31 am »
Something sticks in my head that someone had a problem where it would only arm if GCS was connected...  I hope you aren't having that problem.  I don't remember more about it.