Risuno

  • *
  • 1
3 von 4 Motoren viel zu schnell nach Umstieg auf LibrePilot
« on: April 04, 2017, 11:59:16 am »
Hey Leute! :)

Bin noch neu im Quad Business und hab auch leider schon ein Problem.

Hab mir vor 2 Wochen die E-Turbine von Robitronic geholt und bin bisher immer mit OpenPilot geflogen, tadellos.
Da ich aber mit der neuesten Version gehen will hab ich mir Libre geholt und draufgeladen.
Hab das Setup wie immer durchgeführt, ohne Probleme.
Jedoch drehen sich alle Motoren, bis auf SW, mit einer viel zu hohen Startgeschwindigkeit.
Soll heißen, sobald ich das Throttle genug raufschiebe damit sich irgendwas bewegt, drehn die gleich Vollgas los.
Hab das ganze Setup schon ein paar Mal gemacht und es war immer das gleiche Problem.
Hatte zwischendurch auch schon wieder OpenPilot drauf, weil ich ja fliegen wollte.

Was ich hier so mitgelesen habe hilft es viel die .uav File hier hochzuladen, also tu ich das auch gleich.

Danke für Hilfe! :)

Re: 3 von 4 Motoren viel zu schnell nach Umstieg auf LibrePilot
« Reply #1 on: April 17, 2017, 11:39:17 pm »
Ich bin jetzt kein Äxpärte - ich hab zum ersten mal ein "fremdes" UAV File mir angesehen. Bei mir werden keine Werte bei Output configuration angezeigt - bei Bank Channels - und Mode - unter "Mode" sollte PWM bei dir stehen - da du ja offensichtlich deine ESCS mit PWM ansteuerst und drüber so ein wert von 50 Aufwärts je nach dem wie schnell deine ESCs sind.
Vielleicht hast du ja auch BLHeli ESCs - dann kannst du evtl. Oneshot verwenden - was die Gasanahme des Motors verändert - verbessert - je nach dem wie man es sieht :)

Die Motoren selbst hast du ja eingestellt - und evlt. Auch die ESCs kalibriert.


« Last Edit: April 18, 2017, 03:07:23 pm by ArtusMuc »

Floyd

  • *
  • 5
Re: 3 von 4 Motoren viel zu schnell nach Umstieg auf LibrePilot
« Reply #2 on: September 23, 2017, 07:53:23 pm »
Servus
Selbe Geschichte selbes Problem.
Gabs eine Lösung ?
Gruß Floyd

Xviews

  • *
  • 48
Re: 3 von 4 Motoren viel zu schnell nach Umstieg auf LibrePilot
« Reply #3 on: September 24, 2017, 11:31:53 am »
Beim Setup welchen ESC Typ nehmt ihr? Bei allen ESC immer Rapid oder OneShot nehmen, Standard ist für Servos

Floyd

  • *
  • 5
Re: 3 von 4 Motoren viel zu schnell nach Umstieg auf LibrePilot
« Reply #4 on: September 24, 2017, 03:49:02 pm »
Servus
Ja, ESC 490Hz.
Bei OpenPilot funktionierts ja mit nach dem Assistenten mit den gleichen Einstellungen.
Es liegt definitiv nicht an den Einstellungen der TX.

Wenn ich in Libre für alle Basich Settings die Default Werte nehme, flippt der Copter sobald ich Throttle auch nur bewege.
Erst mit sehr kleinen Proportional Werten (~5) bei Rate Stabilization (Inner loop) für Roll und Pitch kann ich die Motoren langsam hochfahren, wenn sich der Copter dann aber bewegt, flippt er auch sofort. Entweder über die Roll oder die Pitch Achse. Je nach dem welcher Proportional Wert höher ist.

Wie bereits gesagt: Mit OpenPilot ein komplett anderes Verhalten.
Ich bin da echt demnächst am verzweifeln...

Gruß Floyd