mafo

  • *
  • 4
Tipico... no conecta con cc3d
« on: March 01, 2017, 10:52:41 pm »
Hola!

he leido ya varios mensajes pero no ha sido el mismo caso o no me ha funcionado y ay n ose que hacer... soy totalmente nuevo en esto y estoy ya harto de problemas asi que necesitaria vuestra ayuda...:(

No hay forma de conectar... haga lo que haga siempre pasa igual. El cc3d se queda azul fijo y rojo parpadeando a ritmo de 1 segundo.  si estoy en librepilot y seleccion el COM5 que es en el que esta, se conecta sí, porque pone luego "desconectar" y las barras de TC y RX de abajo durante 1 segundo al dar a conectar se quedan alumbradas toda entera pero luego solo se queda en 24 la TX y ya esta... de ahi no pasa y no detecta nada. Voy a "rescue" a ver si desde ahi pero nada... en esos 20seg no detecta nada. Algo me dice que es problema de drivers... en los controladores la cc3d esta identificada como "Silicon LAbs CP210x USB to UART Bridge" y eso no debe ser asi verdad?

Alguna ayuda? de verdad que necesito porque ya no se que hacer y seguro que es una tonteria pero no la he encontrado.

f5soh

  • *****
  • 4059
    • LibrePilot
Re: Tipico... no conecta con cc3d
« Reply #1 on: March 01, 2017, 10:58:39 pm »
Hola

El "Silicon LAbs CP210x USB to UART Bridge" viene de otra placa que tienes connectada, no puede ser la CC3D.
Parece que tu placa funciona correctamente.

Puedes intentar :
- desconnecta la placa
- clic en el botón Rescue
- Conecta la placa

Que pasa ?

mafo

  • *
  • 4
Re: Tipico... no conecta con cc3d
« Reply #2 on: March 01, 2017, 11:31:59 pm »
Hola! gracias por tu interes.

mmm... la cuestion es que no viene de otra placa. Porque si desconecto y conecto la cc3d ese nombre es el que aparece y desaparece.

Si le doy a rescue dejandolo en modo USB y luego conecto la placa... no pasa nada. Pasan los 20 seg y salta el error. Y la placa sigue azul con rojo parpadeando

f5soh

  • *****
  • 4059
    • LibrePilot
Re: Tipico... no conecta con cc3d
« Reply #3 on: March 01, 2017, 11:39:15 pm »
Estas seguro que tu placa es una CC3D ?

Con un chip CP210x suele ser una Naze :)

mafo

  • *
  • 4
Re: Tipico... no conecta con cc3d
« Reply #4 on: March 02, 2017, 11:58:16 am »
jajajaj apuuues... que yo tenga entendido si, concretamente compre esta http://www.banggood.com/Upgrade-NAZE32-F3-Flight-Controller-Acro-6-DOF-Deluxe-10-DOF-for-Multirotor-Racing-p-1010232.html

Me he ido a su manual que sale en bangoog http://img.banggood.com/file/products/20160622022448%E6%A8%A1%E5%9E%8B%E5%BA%93SPRacingF3-Manual-latest.pdf se que en el anuncio pone Naze pero realmente es una cc3d, verdad? y por ahi te dice que vayas aqui http://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers y descargues tus controladores... lo acabo de hacer y pasa lo mismo :(


Edito: acabo de probar usando "cleanflight" y ahi si que me lo ha detectado y el dibujo del drone se inclina y mueve y esas cosas... osea que cual debe ser el problema? bootleaders? driver? decir que yo simplemente he instalado librepilot y me descargue el bootlearder de cc3d pero no se que hacer con el ya que al no conectar no puedo seguir ningun tutorial :(
« Last Edit: March 02, 2017, 12:07:19 pm by mafo »

f5soh

  • *****
  • 4059
    • LibrePilot
Re: Tipico... no conecta con cc3d
« Reply #5 on: March 02, 2017, 01:13:36 pm »
Tu placa es una Naze - F3, diferente de una CC3D.
LibrePilot no soporte este tipo de placa por este momento.

Tienes que usar CleanFlight o Betaflight para configurar y programar la placa.

mafo

  • *
  • 4
Re: Tipico... no conecta con cc3d
« Reply #6 on: March 02, 2017, 03:41:40 pm »
mmm vaya vaya... jajajaj me acoste pensnado que tenia una cc3d y ahora tengo un naze xD... de todas formas ya lo he solucionado, al final segui el manual ese de bangood y a lo hora de seleccionar que tipo de placa tengo me dice que no es ni nade cc3d ni Naze... resulta que debo poner SPRacingF3.... xD y funciono! asi que es una spracingf3