Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« on: October 29, 2016, 08:32:48 am »
After searching the net for info on how to setup MWOSD with a CC3D and not finding much info, I decided to post this as I finally got it to work.

Before you compile the firmware with Arduino the are a few parameters that you need to change the commenting on. Please note that this is for pre-release firmware 1.6.4.0. (see .ino file attached). Once flashed setup the OSD with the GUI.

Configure LibrePilot Refresh Rates as per the Wiki (https://librepilot.atlassian.net/wiki/display/LPDOC/MinOPOSD+setup)

On the LibrePilot hardware configuration tab, select "MAVLink" from the drop down menu for the port you're going to use to connect to the OSD (either Main or Flexi), and set the telemetry speed to 57600.
« Last Edit: November 13, 2016, 07:25:33 pm by hwh »

f5soh

  • *****
  • 3907
    • LibrePilot
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #1 on: October 29, 2016, 09:44:54 am »
Hi, welcome.

Maybe this information and pre-compiled OSD firmware can be added to the Wiki ?
Tell me if you have already access to the wiki (need registration) and i will setup a starting page (basically the MinimOSD page) you can amend with MWOSD setup.

Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #2 on: October 29, 2016, 10:11:25 am »
Hi there,

Including this would be a great addition to an excellent resource and knowledge base. I'm still testing and checking out various options, ie why I can't access the PID controller settings or the calibration pages of MWOSD. Unfortunately I don't have a Revo board so can't add any value for those users.

Let me optimise this setup and then I'll try and add to the Wiki.

f5soh

  • *****
  • 3907
    • LibrePilot
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #3 on: October 29, 2016, 11:29:16 am »
Great, tell me when you are ready for Wiki.

Thanks.

jtrout19

  • ****
  • 334
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #4 on: October 29, 2016, 04:37:43 pm »
Quick question are there any benefits of mwosd over minimosd

Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #5 on: October 29, 2016, 07:41:38 pm »
I find it more flexible with more options and features. That said, I'm still to find out how well it interfaces with LibrePilot. CC3D is probably not the best FC to do this with but currently it's all ice got.

Sent from my HUAWEI MT7-L09 using Tapatalk


Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #6 on: November 08, 2016, 09:09:03 pm »
... ie why I can't access the PID controller settings or the calibration pages of MWOSD.

There was an issue with setting PID from OSD and this feature may have been disabled???  I recall that you could only change the numbers by a large amount...

f5soh

  • *****
  • 3907
    • LibrePilot
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #7 on: November 08, 2016, 09:19:57 pm »
I think you should use the MSP protocol for PID settings (innerloop) support, instead of Mavlink

klemo4

  • *
  • 1
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #8 on: November 11, 2016, 02:45:16 pm »
Hi. I have MICROMINIMOSD and i want to use MWOSD with my cc3d. I dont want the pid tune fuction. I have try but i cant get to work. Culd someone help me? What i have to change to conf.h in order to work?

Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #9 on: November 13, 2016, 03:23:11 pm »
Download the .ino file in the first post. I saved the settings once I'd gotten it to work.

Sent from my HUAWEI MT7-L09 using Tapatalk


Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #10 on: November 29, 2016, 05:27:59 pm »
Like f5soh said, I understood MWOSD was using the MSP protocol, maybe that's why you can't access the PID setting pages. Anyway I'm in the way of trying the same, ie using a micro osd with a CC3D, I'll report if I manage to have it on and working.

Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #11 on: November 29, 2016, 06:09:55 pm »
IIRC you can't do PIDs because the data format and range doesn't match.  MWOSD has integer PIDs and LP uses float.  I guess there could be a scaling and conversion from "their average PID/range" to "our average PID/range"?

Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #12 on: December 14, 2016, 08:45:53 pm »
ino file you given cant compile. so how?

hwh

  • *
  • 1018
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #13 on: December 14, 2016, 11:51:35 pm »
ino file you given cant compile. so how?
This really isn't the place for a tutorial on MWOSD and the basics of compiling Arduino programs.  MWOSD isn't a LP project, it's a completely different one.  We just added the ability to send telemetry in the format it recognizes. Your best bet would be to go back to the main MWOSD site where you downloaded the rest of the files and ask there.

f5soh

  • *****
  • 3907
    • LibrePilot
Re: Successfully using MWOSD (1.6.4.0) with CC3D (16.09 RC2)
« Reply #14 on: December 30, 2016, 01:41:36 pm »
I added the information for how to setup a MWOSD using LibrePilot:
https://librepilot.atlassian.net/wiki/display/LPDOC/MWOSD+Setup