babz

  • *
  • 49
programation de l'osd avec la revo
« on: September 17, 2016, 09:15:56 pm »
comment procede t'on pour parametrer l'osd avec la revo sans ftdi ?Le menu osdsettings reste grisé...et par ou passer pour changer le firmware de l'Osd ? il n'y a pas beaucoup de documentation à ce sujet sur le net.
« Last Edit: September 17, 2016, 09:38:22 pm by babz »

f5soh

  • *****
  • 4503
    • LibrePilot
Re: programation de l'osd avec la revo
« Reply #1 on: September 17, 2016, 09:49:27 pm »
Le osdSettings grisé correspond à un OSD qui date du temps d'OpenPilot et jamais finalisé.

Tu as ça comme doc, avec un FTDI bien sûr :
https://librepilot.atlassian.net/wiki/display/LPDOC/MinOPOSD+setup

babz

  • *
  • 49
Re: programation de l'osd avec la revo
« Reply #2 on: September 17, 2016, 10:14:49 pm »
il ne me reste plus qu'a retrouver mon FTDI  :-[

babz

  • *
  • 49
probleme flashage osd
« Reply #3 on: September 18, 2016, 11:24:51 am »
bonjour,
probleme de flashage apres avoir essayé plusieurs version ainsi que le charset voila ce que j'obtiens:
« Last Edit: September 18, 2016, 11:31:10 am by babz »

f5soh

  • *****
  • 4503
    • LibrePilot
Re: probleme flashage osd
« Reply #4 on: September 18, 2016, 12:31:14 pm »
Le charset n'est pas flashé correctement.

Sur un minimOSD de taille normale (pas le mini) il faut aussi alimenter le coté vidéo de l'osd sinon je chip ne stockera jamais le charset.

babz

  • *
  • 49
Re: programation de l'osd avec la revo
« Reply #5 on: September 18, 2016, 12:44:18 pm »
je ne comprends pas,minimosd normal,alimenté des deux cotés,ne prend pas le charset.
pourtant le configurateur ne me signale pas d'erreurs...je suis perdu là

f5soh

  • *****
  • 4503
    • LibrePilot
Re: programation de l'osd avec la revo
« Reply #6 on: September 18, 2016, 12:50:46 pm »
Tu as d'abord flashé le firmware du Wiki ?

Certains firmwares ne permettent pas de flasher le chip vidéo pour gagner de la place sur l'arduino.

Pin DTR obligatoire.

babz

  • *
  • 49
Re: programation de l'osd avec la revo
« Reply #7 on: September 18, 2016, 02:44:41 pm »
je viens de m'apercevoir que mon FTDI fonctionnait en 3,3V le defaut est peut etre là mais en dessoudant le pont,le circuit s'est abimé et maintenant la carte ne crache plus que du 1,8V,demain il faut que je trouve un autre FTDI.