Revo does not stay ARMED for more than 2 seconds [Solved]
« on: August 16, 2016, 05:31:25 pm »
Hi there,

First question, Why is my revo card unable to store the new accelerometer or mag calibration ?
The Apply button goes OK with a green checkmark but Save is slow and I get a red cross with no explanation. When I change "Flight Mode Switch Settings" from "Manual-PathPlanner" (Yes, only two states) to "Manual-Stabilized1", Save appears to be responding OK again but not sure this is the only reason...

Main question, After calibrating everything (sensors) but the temp, System Health is (and stays) green (except Plan = orange and Path = black) and I can Arm the system (Yaw right) but it goes back to Disarmed after 2 seconds. What can cause this ?
If I keep the yaw stick on the right, it re-arms continuously (every 2 seconds), the throttle servo moves a little bit (engine is off) and the artificial horizon on the PFD flips as well. The Revo board is next to the gas servo but there is no mechanical contact between them. I suspected the battery but a brand new one, connected directly to the board, makes no difference. Any suggestion ? My revo is US$57 from N-Phoenix on Aliexpress.
The only situation it doesn't disarm is when I move the throttle stick so that the gas servo is in the same position both armed and not armed. I can then move the throttle up but it will disarm if I move it below that position whatever the yaw.

Third question, there is an arrow on my GPS card with (unused) magnetometer. The way I installed it, it doesn't point forward (but left). Is it a problem ?

Thanks for your help,
« Last Edit: August 19, 2016, 01:38:32 pm by Bizuth_74 »

Re: Revo does not stay ARMED for more than 2 seconds
« Reply #1 on: August 19, 2016, 01:37:02 pm »
OK, I didn't read the ARMING chapter ( correctly. My Arming Timeout was 2 instead of 0 as recommended for Fixed Wing. This problem is solved.